Dell EMC Networking N2000 en N3000 herstellen van inconsistente status tijdens het downgraden van firmware

Summary: Dell EMC Networking N2000 en N3000 herstellen van inconsistente status tijdens het downgraden van firmware

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


In dit artikel wordt uitgelegd hoe u de switch vanuit een inconsistente status kunt herstellen tijdens het downgraden van de firmwareversie in De Dell N2000 en N3000.
 

Vereiste


Consoletoegang tot de switch is een must.  U hebt fysieke toegang nodig tot de consolepoort van de switch om de procedure te voltooien.  U hebt een personal computer nodig met een seriële poort of een USB-naar-seriële adapter en de seriële naar RJ45-kabel die bij de switch wordt geleverd.

Oorzaak


De switch zit vast in een inconsistente status vanwege een incompatibele CPLD-versie.
Een switch krijgt een inconsistente status wanneer de CPLD is geïnstalleerd een nieuwere versie is dan de firmware, die moet worden gedowngraded.  Wanneer u de firmware downgradet, moet u rekening houden met de CPLD-versie en deze indien nodig downgraden.
Firmwareversie 6.0.1.3 vereist bijvoorbeeld CPLD-versie 13.
Als een klant de switch van een hogere firmwareversie 6.6.0.2 met CPLD 20 rechtstreeks downgradet naar 6.0.1.3, zonder de juiste downgradeprocedure te volgen, kan de switch vastlopen in een inconsistente status.
U kunt de CPLD-versie vinden die compatibel is met de firmwareversie in de releaseopmerkingen die worden geleverd met het bijbehorende firmwaredownloadbestand.


 

Weten of een switch vastloopt in een inconsistente status


Tijdens het opstarten van de switch wordt een logboekbericht weergegeven met de melding "System is restarting due to inconsistent state".

Voorbeeld van consolelogboeken

Hieronder vindt u een voorbeeld van het consolelogboek van de switch tijdens het opstarten, waaruit blijkt dat de switch zich in een inconsistente status bevindt (waarbij de volledige opstartvolgorde voor de configuratie wordt weggelaten).

Operationele code uitpakken uit .stk-bestand... 2
klaar.
Operationele code laden... Gedaan.
Operationele code decomprimeren... Gedaan.
Uncompressing apps.lzma
SyncDB Running...
Bestand: stm_api.c, regel: 62, Fout 0 (0x0)
<185> 14 mei 01:38:40 0.0.0.0-0 Algemeen[fp_main_task]: stm_api.c(62) 1 %% Fout 0 (0x0)
DMA-poolgrootte:
16777216 AXI-eenheid 0: Dev 0xb342, Rev 0x01, Chip BCM56342_A0, Driver BCM56340_A0
In hpcLocalUnitTypeIdGet:611 kon de kaart
in sysapiHpcStmUnitDbEntryLocalUnitIndexGet:342 de kaart

niet vindenHet systeem wordt opnieuw opgestart vanwege de inconsistente status 0 in het bestand: stm_api.c line 62
<184> 14 mei 01:38:43 0.0.0.0-1 LOG[fp_main_task]: log_cnfgr.c(1357) 3 %% Het systeem wordt opnieuw opgestart vanwege een inconsistente status.      
                           
Kan het unitnummer niet krijgen! 
Switchsoftware SIGSEGV Handler
Deze build is geconfigureerd om deze crashinformatie naar een bestand te kopiëren.
Symbolen al geladen.
pid 12
syncing filesystems starten.... Dit kan even
duren voordat het systeem opnieuw wordt opgestart!
Het systeem gaat NU omlaag!
Sigterm verzonden naar alle processen
: Sigkill naar alle processen
gestuurd met het verzoek om het systeem opnieuw op te starten


 

Oplossing

Start de switch op in de juiste firmwareversie (compatibel met de CPLD-versie) en ga verder met de juiste downgradeprocedure.

Optie 1

Start de switch op in de back-uppartitie. De kans bestaat dat de klant net de oudere firmware naar de back-uppartitie heeft gekopieerd en probeert de switch opnieuw op te starten in de back-uppartitie.

Opstartopties
van Dell Networking============================
Selecteer een menuoptie binnen 3 seconden of de operationele code wordt automatisch gestart...
1 - Start Operational Code
2 - Display Boot Menu


Wanneer het opstartmenu wordt weergegeven, selecteert u 2 "Display Boot Menu".

Selecteer (1, 2) #2
Boot Main Menu
==============
1 - Start Operational Code
2 - Selecteer Baud Rate
3 - Retrieve Logs
4 - Load New Operational Code 5 - Display Operational Code
Details
9 - Reboot
10 - Restore Configuration to Factory Defaults
11 - Activate Backup Image
12 - Start Password Recovery

From Boot Main Menu select 11 "Activate Backup Image".

Enter Choice# 11

Hierna start u de switch opnieuw op met optie 9 "Reboot".

Hoofdmenu
opstarten==============
1 - Start operationele code
2 - Selecteer Baud Rate
3 - Retrieve Logs
4 - Load New Operational Code 5 - Display Operational Code
Details
9 - Reboot
10 - Restore Configuration to Factory Defaults
11 - Activate Backup Image
12 - Start Password Recovery

Enter Choice# 9

Option 2
If the 1st option
did not work, try to load firmware using TFTP/XMODEM. Volg de procedure in de upgradehandleiding voor switchherstel.

  • Als de vorige firmwareversie bekend is, moet u upgraden naar die versie.
  • Als de firmwareversie onbekend is, moet u deze upgraden naar de nieuwste beschikbare firmwareversie



Nadat de switch is hersteld, volgt u de juiste downgradeprocedure in de upgradehandleiding die bij het firmware-downloadbestand is meegeleverd. Upgrade naar de tussenliggende firmwarerelease N3000_N2000vB.6.3.2.stk en downgrade CPLD naar 13.



 

Cause

De switch zit vast in een inconsistente status vanwege een incompatibele CPLD-versie.
Een switch krijgt een inconsistente status wanneer de CPLD is geïnstalleerd een nieuwere versie is dan de firmware, die moet worden gedowngraded.  Wanneer u de firmware downgradet, moet u rekening houden met de CPLD-versie en deze indien nodig downgraden.

Resolution

Optie 1

Start de switch op in de back-uppartitie. De kans bestaat dat de klant net de oudere firmware naar de back-uppartitie heeft gekopieerd en probeert de switch opnieuw op te starten in de back-uppartitie.

Optie 2
Als de1e optie niet werkte, probeer dan firmware te laden met behulp van TFTP/XMODEM. Volg de procedure in de upgradehandleiding voor switchherstel.

Affected Products

PowerSwitch N2000 Series, PowerSwitch N3000 Series, SmartFabric OS10 Software
Article Properties
Article Number: 000143229
Article Type: Solution
Last Modified: 11 Oct 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.