Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

How to use Veeam with tape drives and Microsoft LTO driver in Windows 2012/2012R2

Summary: How to use Veeam with tape drives and Microsoft LTO driver in Windows 2012/2012R2.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Sporadic LTO tape drives went offline using Veeam on the PERC H330 with IBM driver.

Cause

As a possible solution to problems with using Veeam with LTO tape drives on the PERC H330 and using the IBM driver required by VEEAM, we have tested the use of the Microsoft inbox LTO driver. It is a workaround that has been successfully tested in our laboratory with certain hardware and software versions. However, due to the many possible combinations of hardware and software, we can not guarantee that the solution will work in all environments:

Resolution

Test environment:

- Power Edge T430 with PERC H330 Adapter and LTO 6 Tape drive
- Windows 2012R2 with all Patches (at 06/2016)
- Veeam Backup&Replication 9.0.0.1491
- Tested PERC H330 FW Stände: 25.3.0.0016; 25.4.0.0017; 25.4.1.0004
- Tested PERC driver: 6.603.07.00

In the given scenario, 3 LTO tapes were written with Veeam using the following FW/driver levels with different block sizes (64kB, 128kB, 256kB):

- PERC H330 FW: 25.3.0.0016
- PERC H330 Driver: 6.603.07.00
- IBM Tape driver: 6.2.5.6
- LTO6 FW: F9A1

The written tapes have been validated by recover of files.
Subsequently, the IBM driver was replaced by the current Microsoft inbox driver from Windows 2012R2 as described below:

At first, the installed driver (6.2.5.6) was uninstalled with the "uninst.exe" from the IBM driver package:
SLN316530_en_US__1Veeam 01
SLN316530_en_US__2Veeam 02

SLN316530_en_US__3Veeam 03

SLN316530_en_US__4Veeam 04

SLN316530_en_US__5Veeam 05

After the subsequent reboot, the LTO drive is displayed with a yellow exclamation mark.
SLN316530_en_US__6Veeam 06

Now the Microsoft driver has to be installed manually:
SLN316530_en_US__7Veeam 07

SLN316530_en_US__8Veeam 08

SLN316530_en_US__9Veeam 09

SLN316530_en_US__10Veeam 10

SLN316530_en_US__11Veeam 11

After another restart, the drive should now be displayed as LTO Tapedrive, the installed driver is now the Microsoft driver.
Version: 6.3.9600.16384
SLN316530_en_US__12Veeam 12

SLN316530_en_US__13Veeam 13

SLN316530_en_US__14Veeam 14

After that, a medium previously written with Veeam and the IBM driver was inventoried:
SLN316530_en_US__15Veeam 15

SLN316530_en_US__16Veeam 16

This was done with all 3 previously written media (64kB, 128kB and 256kB blocksize).
At first, each media was used to restore 1 file of the test method and then a further backup to the respective medium was carried out. There were no problems / issues.
In further tests, Veeam's behavior with the Microsoft driver could be determined:
  1. Tapes previously described with this Veaam installation could be inventoried without restriction. Recovery of data and further use for backups is possible without problems and regardless of the block size. Deleting or formatting the tape was not required.
  2. New, unused tapes could easily be inventoried and fully used for backups and further recovery.
  3. Tapes previously used with other backup application or test tools such as ITDT could not be inventoried, described, deleted or formatted with Veeam. This was only possible after deleting the tape with a suitable third party tool (in this case ITDT). However, after deleting the media, unrestricted use was possible under Veeam.
The problem described under point 3 shows the following behavior:
The inventory itself is apparently without error, but the drive will still be displayed as empty, so there is no backup or deletion to this media possible. In this case, the media must be deleted using a third-party tool, such as ITDT.
After that the medium can be easily inventoried and used.
To delete the tape for further use with Veeam using the ITDT utility, do the following:

Start ITDT as administrator:
SLN316530_en_US__17Veeam 17

SLN316530_en_US__18Veeam 18

Type U for "[ U ] Tapeutil" and Enter.
SLN316530_en_US__19Veeam 19

Type 1 for "[ 1 ] Open a Device" and Enter.
SLN316530_en_US__20Veeam 20

Continue with Enter.
SLN316530_en_US__21Veeam 21

Continue with Enter.
SLN316530_en_US__22Veeam 22

Continue with Enter.
SLN316530_en_US__23Veeam 23

The device was opened successfully, continue with Enter.
SLN316530_en_US__24Veeam 24

Type 28 for "[ 28 ] Erase" and Enter.
SLN316530_en_US__25Veeam 25

The deletion process is started.

Note: the deletion process (it is a "long erase") takes several hours. It can be interrupted by resetting the drive (pressing the ejection button for at least 15 seconds), the tape can be used without problems after re-loading by Veeam.

If you receive the following message when starting the deletion process:
SLN316530_en_US__26Veeam 26

Please carry out the following steps and then try to start the deletion process again:
  1. Check if the tape is actually loaded in the drive and load it again if necessary.
  2. Unload/load the tape.
  3. Restart the system.

The following behavior is still unclear:
  1. Tapes previously written with Veeam using the IBM driver are recognized by ITDT as read-only when using the Microsoft driver. After deleting, as described above, they are normally usable.
  2. If IBM Tapedriver is installed, it is sometimes not possible to up- or downgrade the PERC firmware ('no supported device found'). In some cases, it is possible to upgrade / downgrade after a restart, but sometimes only after the LTO drive has been physically disconnected from the controller.
  3. If the IBM Tapedriver is installed, it is partially impossible to up- / downgrade the LTO firmware. Sometimes this is possible after a restart, in some cases only after upgrading or downgrading the PERC firmware or switching to the Microsoft driver.

Article Properties


Affected Product

Dell EMC ML3, PowerVault 124T, Powervault LTO6, PowerVault ML6000, PowerVault TL2000, PowerVault TL4000, PowerVault TL1000

Last Published Date

07 Oct 2022

Version

4

Article Type

Solution