NetWorker: NMC no se abre con el error "Cannot determine a valid Java Home"
Summary: NMC no se abre con el error "Cannot determine a valid Java Home"
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Se utiliza Oracle Java Runtime Environment (JRE) en lugar de NetWorker Runtime Environment (NRE)
- NetWorker Management Console (NMC) no se puede abrir con el siguiente error: "No se puede determinar una página de inicio de Java válida"
- Es posible que este problema no aparezca en todos los hosts
Cause
Este no es un problema de NetWorker\NMC.
Cuando se inicia NMC, se ejecuta el comando javaws.exe de JAVA en el host desde el que accede a NMC. El archivo javaws.exe se puede encontrar en la ruta de instalación de JAVA actual en.. Directorio \bin. Este problema puede aparecer si queda un archivo javaws.exe de una instalación anterior de JAVA. Cuando intenta abrir NMC, se hace referencia al archivo JAVA incorrecto; por ejemplo, JAVA 8 "181" está instalado, pero el cuadro "Java Web Start" muestra JAVA 8 "171":
Cuando se inicia NMC, se ejecuta el comando javaws.exe de JAVA en el host desde el que accede a NMC. El archivo javaws.exe se puede encontrar en la ruta de instalación de JAVA actual en.. Directorio \bin. Este problema puede aparecer si queda un archivo javaws.exe de una instalación anterior de JAVA. Cuando intenta abrir NMC, se hace referencia al archivo JAVA incorrecto; por ejemplo, JAVA 8 "181" está instalado, pero el cuadro "Java Web Start" muestra JAVA 8 "171":
Es probable que este problema aparezca en hosts que tienen (o tenían) JAVA de x64 bits y x86 bits. De manera predeterminada, NMC utilizará JAVA de 86 bits, incluso cuando java de 64 bits esté instalado.
Resolution
- Confirme qué versión de JAVA está instalada en el sistema, abra Configurar Java.
a. Seleccione Java.
B. Seleccione Ver:
c. En la ventana Java Runtime Environment Settings, compruebe las pestañas User y System. Solo debe haber una instancia de JAVA instalada. Tome nota de la versión de JAVA y la ubicación de instalación. La casilla de verificación indica que esta versión de JAVA está habilitada.
B. Seleccione Ver:
c. En la ventana Java Runtime Environment Settings, compruebe las pestañas User y System. Solo debe haber una instancia de JAVA instalada. Tome nota de la versión de JAVA y la ubicación de instalación. La casilla de verificación indica que esta versión de JAVA está habilitada.
d. Si hay varias versiones de JAVA instaladas, elimine las versiones anteriores. Esto se puede hacer desde el panel de control de Java o programas y características.
- Abra un Explorador de archivos de Windows y vaya a C:\
Un. En la barra de búsqueda, ingrese: javaws.exe
b. Según el paso 1, c. javaws.exe solo debe aparecer en la ruta de instalación que se muestra en el Panel de control de JAVA.
b. Según el paso 1, c. javaws.exe solo debe aparecer en la ruta de instalación que se muestra en el Panel de control de JAVA.
Nota: Si el sistema tiene varias unidades, también debe buscarlas para asegurarse de que JAVA no se haya instalado anteriormente en otro lugar.
C. Si aparecen varios archivos javaws.exe, elimine los que no estén asociados con la ruta de instalación de Java actual (paso 1, c)
C. Si aparecen varios archivos javaws.exe, elimine los que no estén asociados con la ruta de instalación de Java actual (paso 1, c)
- Volver al Panel de control de Java
a) En la pestaña General , seleccione Configuración...
b) En la ventana Configuración de archivos temporales, seleccione Eliminar archivos...
c) En la ventana Eliminar archivos y aplicaciones, marque Aplicaciones y applets instalados (las 3 casillas deben estar marcadas):
b) En la ventana Configuración de archivos temporales, seleccione Eliminar archivos...
c) En la ventana Eliminar archivos y aplicaciones, marque Aplicaciones y applets instalados (las 3 casillas deben estar marcadas):
d. Haga clic en Aceptar y, a continuación, haga clic en Aceptar nuevamente.
Nota: Esto debe eliminar cualquiera de los íconos/accesos directos de NMC antiguos; sin embargo, si el vínculo javaws.exe está roto, es posible que deban eliminarse manualmente.
e. Cierre el Panel de control de Java.
Nota: Esto debe eliminar cualquiera de los íconos/accesos directos de NMC antiguos; sin embargo, si el vínculo javaws.exe está roto, es posible que deban eliminarse manualmente.
e. Cierre el Panel de control de Java.
- Abra un navegador web y vaya a http:// nmc_servername:9000, especificando el nombre de host o la dirección IP del servidor de NMC.
Un. En la página web de NMC, inicie NMC.
B. Inicie sesión en NMC para confirmar el acceso, se debe colocar un nuevo acceso directo de NMC en el escritorio.
C. Minimice la NMC y pruebe iniciarla desde el acceso directo de escritorio recién creado.
B. Inicie sesión en NMC para confirmar el acceso, se debe colocar un nuevo acceso directo de NMC en el escritorio.
C. Minimice la NMC y pruebe iniciarla desde el acceso directo de escritorio recién creado.
Si se requiere más ayuda, comuníquese con los administradores de su sistema operativo Windows o dominio.
Additional Information
Solución alternativa:
Puede confirmar que el problema está aislado en JAVA iniciando NMC desde el directorio de instalación de JAVA, por ejemplo:
C:\> cd C:\Program Files\Java C:\Program Files\Java> dir | findstr jre 08/10/2018 03:24 PM <DIR> jre1.8.x_xxx C:\Program Files\Java> cd jre1.8.x_xxx\bin C:\Program Files\Java\jre1.8.x_xxx\bin> javaws.exe http://nmc_servername:9000/gconsole.jnlp Note: When performing the above make sure you cd to your JAVA installation. The NMC only requires x86 Java so x64 bit JAVA may not be installed. The JAVA \bin dir you cd into should contain javaws.exe. When running the javaws.exe command ensure to specify your NMC server's resolvable hostname or IP address.
Si la solución alternativa anterior funciona, esto confirma que no hay ningún problema con NetWorker. Este problema se debe a la forma en que el sistema operativo/sistema ejecuta los comandos de JAVA.
Affected Products
NetWorkerProducts
NetWorker, NetWorker Management ConsoleArticle Properties
Article Number: 000160813
Article Type: Solution
Last Modified: 05 Jun 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.