The system hostname key is missing from the lockbox after NetWorker server fails over

Summary: The system hostname key is missing from the lockbox after NetWorker server fails over.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • The NetWorker server is configured as a clustered server, and a lockbox resource has been created.
  • After a failover to the second node, the second node (now active) is not able to open the lockbox.
  • The NetWorker server's daemon.raw shows the following error:
nsrd RAP critical Error encountered while re-signing lockbox '/nsr/lockbox/<cluster_name.domain.com>/clb.lb'
  • The system hostname key is missing from the lockbox

Cause

There is a configuration issue.
 
The NetWorker server's Logical client remote access does not have a physical node account.
 
NOTE: Clustered NetWorker systems typically involve a client resource for each of the physical nodes, and a client resource for the resolvable cluster resource. The logical client is associated with the cluster resource.

Resolution

The solution is documented in the NetWorker Cluster Integration Guide under Configuring the NetWorker virtual server.

For NetWorker Servers configured to use the lockbox only:
    a. From the NetWorker Management Console (NMC), go to Protection->Clients.
    b. Right-click the client resource for the NetWorker virtual service and select Modify Client Properties.
    c. On the Globals (2 of 2) tab, specify the name of each cluster node in the Remote Access field.
  • For Red Hat cluster nodes, specify the name of the host that appears when you use the hostname command.
  • For Windows cluster nodes, use the full computer name that appears in the Control Panel > System > Computer name field.
NOTE: When configuring the NetWorker Server with a lockbox, update the Remote Access field before the virtual node fails over to another cluster node. If you do not update the Remote Access field before failover, you must delete and create the lockbox resource. The NetWorker Security Configuration Guide describes how to configure the lockbox resource.
 
The NetWorker Cluster Integration and NetWorker Security Configuration guides are available through: https://www.dell.com/support/product-details/product/networker/docs

Affected Products

NetWorker

Products

NetWorker, NetWorker Series
Article Properties
Article Number: 000164825
Article Type: Solution
Last Modified: 04 Jun 2025
Version:  5
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