VPLEX: How to reboot the VPLEX management server.

Summary: This article talks about being unable to contact the management server during a maintenance activity, the DHCP server is not working and adding a Static IP address on the laptop does not allow contact to the management server. The workaround is to reboot the management server. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 Issues:

  • Unable to contact the management server during a maintenance activity.
  • How to reboot the VPLEX management server.


The field was following the SolVe procedure for replacing the management server and were not able to receive the correct IP address from the Management Server Service Port (Red Cable). Instead, they receive the address, 128.221.252.x, the laptop showed IP address 169.254.242.223 with netmask 255.255.0.0.

Using a static IP address on the laptop did not resolve the issue.

The DHCP server on the management server is not working. When setting a static IP address on the laptop it does not allow contact to the management server.

 

 

Cause

Dynamic Host Configuration Protocol (DHCP) is not responding or is assigning an incorrect address when connecting to a laptop on the service LAN Port (eth1) RED Cable.

 

 

Resolution

Workaround:

The workaround is to reboot the management server. 

Warning!!: Before rebooting the management server, advise users that may be working in the VPLEX GUI or CLI to stop all work, especially any configuration change activity, while the management server is being rebooted. This takes approximately five minutes.

 

  1. After asking users to stop all work in the VPLEX GUI or CLI and they have confirmed they have exited the GUI or CLI, reboot the VPLEX management server as shown below.

  2. From the Linux shell prompt, issue the following command:
 
sudo /sbin/shutdown -rf

where:
r = reboot option
f = force option

Example:
Login as: service
Using keyboard-interactive authentication.
Password:

service@ManagementServer:~> sudo /sbin/shutdown -rf

Broadcast message from root (pts/1) (Wed Sep 11 15:23:21 2018):
The system is going down for reboot NOW!

service@ManagementServer:~>
  
If, after rebooting the management server and you are not able to access the management server, contact Customer Support for further assistance and mention this article.

 

Important Note:
The "force" option, ' -f ', should be included in the command /sbin/shutdown -rf in order to have more of a chance for the VPLEX management server to come back up after reboot, particularly if there is already some issue with the VPLEX management server itself that requires reboot in the beginning.

Support has seen instances where a number of VPLEX management servers did not come back up after running either sudo /sbin/shutdown -r (without the -force option). Hence this is why it is best practice to use the -f option at the end of /sbin/shutdown command.

Reason to use the -f, force, option:
All processes will be killed forcibly, hence a drastic, yet relatively safe option to request an immediate reboot. If the -f option is not used, sometimes the processes within the VPLEX management server cannot be shut down properly causing the management server to not come back up.

 

 

Additional Information

VS2 Management Server: 

kA2j0000000QWQFCA4_5_0


VS6 Management Server (MMCS)

VS6 Component Location, look for MMCS-A:
kA2j0000000QWQFCA4_5_1


VS6 MMCS-A (Management Server) Service Port:

                    kA2j0000000QWQFCA4_5_2
                     This module is flipped for the MMCS-B so the
                     service port is on the opposite side.


VS6 MMCS Service port cable (Red):
              kA2j0000000QWQFCA4_5_3       

 

The RED Ethernet service cable is connected to MMCS-A on Engine-1 of the cluster. If MMCS-A is faulty and is being replaced, temporarily transfer the service cable from MMCS-A and insert it in the service port on MMCS-B. 

               

Affected Products

VPLEX GeoSynchrony, VPLEX Series, VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000165693
Article Type: Solution
Last Modified: 11 Mar 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.