AppSync: SQL Server sürümleri eşleşmediği için kurtarma başarısız oluyor

Summary: Kurtarma işlemi şu hata mesajıyla başarısız olur: "Üretim örneğinin SQL Server sürümü, bağlama örneğinin sürümünden daha yüksek. Her iki sunucudaki sürümler eşleşmiyorsa kurtarma başlatılamaz. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

AppSync 3.x'ten 3.7 veya sonraki bir sürüme güncellendi ve ayrıca Ürün ana bilgisayar aracısı güncellendi ancak Bağlama ana bilgisayar aracısı güncellenmedi.

AppSync 3.5'ten AppSync 3.7 veya sonraki bir sürüme yükselttikten sonra, Servis Planları kurtarma aşamasında başarısız olabilir. Aşağıdaki hata AppSync GUI de görülebilir.

Servis Planı olaylarında görülen hata: 
Üretim örneğinin SQL Server sürümü <Sürüm Numarası> , bağlama örneğinin sürüm <Sürüm Numarasından> daha yüksektir. Her iki sunucudaki sürümler eşleşmezse kurtarma başlatılamaz.

Sunucu günlüklerinde görülen hata: 
02-22-2018 21:44:27.198 INFO [EJB default - 5] [com.emc.archway.service.eventservice.EventServiceBean] [Host_Name] [] d1xxxxxxxxxxxxxxxxxxxx->>>EVENT [SQL_000028]:  SQL Server sürümü <Üretim örneğinin Sürüm Numarası> , bağlama örneği XYZ'nin Sürüm <Numarasından> daha yüksektir . Her iki sunucudaki sürümler eşleşmezse kurtarma başlatılamaz. (META VERI: TYPE-ERROR, TIME-2018-02-22 21:44:27.198-0800NATIVETIME-2018-02-22 21:44:27.198-0800, HOST-Host_ Name, PHASE-Recover copy, THREAD=EJB default - 5, USER-User_Name, CATEGORY-GENERIC, SESSIONID-f4-20V8nudbHq8155MOFFTZkHayb1PYEgeAaELoj)
02-22-2018 21:44:27.198 ERROR [EJB default - 5] [com.emc.archway.commands.application.RunApplicationRecoveryCommandBean] [Host_Name] [] d1xxxxxxxxxxxxxxxx->>>Exception Occurred: IncompatibleSqlInstanceVersion, Message:  Üretim örneği ABC'nin SQL Server sürüm <Sürüm Numarası> , XYZ bağlama örneğinin sürüm <sürümünden> daha yüksek. Her iki sunucudaki sürümler eşleşmezse kurtarma başlatılamaz.

Cause

Bu, aşağıdaki durumlarda görülebilir: 
  • Hem üretim hem de bağlama ana bilgisayarındaki SQL Server sürümü aynı olabilir ancak SQL Server da Toplu Güncelleştirme veya Servis Paketi yüklüdür ve bu da az sayıda SQL Örnek sürümünde artışa neden olur.
  • Üretim ana bilgisayarı AppSync 3.7 çalıştırmalıdır ve Bağlama Ana Bilgisayarı 3.5 veya önceki bir sürümü çalıştırmalıdır. Bağlama ana bilgisayarı AppSync Agent sürüm 3.7 çalıştırmıyorsa AppSync in bir sürüm uyumsuzluğu algılaması nedeniyle kurtarma başarısız olur.
AppSync 3.7'den önce AppSync yalnızca temel SQL Örneği sürümünü gösteriyordu. AppSync sürümünü 3.7 ye yükselttikten sonra, yüklü tüm Hizmet Paketleri veya Toplu Güncelleştirmelerle birlikte SQL sürümünü tanımlayan SQL örneği sürümü gösterilir.

Resolution

Geçici Çözüm: 
  1. Üretim Ana Bilgisayarında ve Bağlama Ana Bilgisayarında yüklü olan AppSync Ana Bilgisayar Eklentisi sürümünü doğrulayın.
  2. Bağlama Ana Bilgisayarındaki AppSync Ana Bilgisayar Eklentisi sürümü, Üretim Ana Bilgisayarı ile aynı olmalıdır.
  3. AppSync sürüm uyumsuzluğu varsa Ana Bilgisayar Bağla öğesine gidin ve AppSync Sunucusunda Ana Bilgisayarı Yeniden Keşfedin.

Products

AppSync
Article Properties
Article Number: 000167338
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.