DPA: Die Anfrage wird zur Verarbeitung in Warteschlange gestellt angezeigt und das Datenspeicherprotokoll zeigt Folgendes an: ERROR: Der NULL-Wert in der Spalte "f_agent_name" verstößt gegen die Nicht-NULL-Einschränkung

Summary: DPA-Anforderungen (Data Protection Advisor) zeigen "Zur Verarbeitung in Warteschlange" an, da der NULL-Wert in Spalte "f_agent_name" gegen den "Not-NULL"-Einschränkungsfehler in Datenspeicherprotokollen verstößt. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Die Datenerhebung wird nicht verarbeitet und in den Berichten werden keine Daten angezeigt.

Überprüfen des Bestands>Objektbibliotheksanwendungen>und Öffnen des Servers, auf dem keine Daten angezeigt werden. Klicken Sie auf die Registerkarte Datenerhebung, wählen Sie dann die Auftragsmonitorerfassung aus und klicken Sie auf die Schaltfläche Verlauf.
Im Pop-up-Fenster Request History wird für die Datensammlungen Queued for Processing angezeigt.

Beim Überprüfen der Datenspeicherprotokolle werden die folgenden Fehler angezeigt:

2018-03-10 21:45:56.588 GMT 1916 5acvxxxxx.77c 1 apollo:ERROR: null value in column "f_agent_name" violates not-null constraint

Cause

Dieser Fehler zeigt, dass die Datenerfassungsmeldung, die der Agent gesendet hat, keinen Wert für die abgelegten f_agent_name hat. 

Resolution

Dies ist ein Problem mit dem Serverhostnamen auf dem Agent-Server.

Bilden Sie das Verzeichnis dpa/agent/bin und führen Sie Folgendes aus:
 

./dpaagent -i


Sie sollten Folgendes erhalten:
 

[root@rhel-dpa-app bin]# ./dpaagent -i
Hostname is:
labserver.dell.com
Interfaces are:
192.xxx.x.x
labserver.dell.com


Wenn Sie eine Antwort wie unten gezeigt erhalten, liegt ein Problem mit dem Hostnamen auf diesem Server vor.

[root@ bin]# ./dpaagent -i
Hostname is:
.
Interfaces are:
.
192.xxx.x.x
labserver.dell.com



Die Lösung dieses Problems erfordert eine Untersuchung durch die Administratoren des betroffenen Servers.


In einem Fall wurde festgestellt, dass die Host-Datei nicht die IP des Servers als Eintrag hatte. Wir haben die IP-Adresse des Servers mit dem FQDN und dem Kurznamen zur Hostdatei hinzugefügt und den Agent neu gestartet. Dadurch wurde dieses Problem behoben und der Agent konnte den Servernamen ermitteln und das f_agent_name ausfüllen.

Weitere Details oder Informationen erhalten Sie vom Dell Support .

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000167718
Article Type: Solution
Last Modified: 23 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.