PowerPath for Linux 6.5 does not start automatically: "Starting PowerPath: /etc/init.d/PowerPath: line 1717: uniq : command not found" found in boot.log. "Starting PowerPath: /etc/init.d/PowerPath: /usr/bin/uniq: No such file or directory" on console
Summary: After installing Powerpath for Linux 6.5, the following error occurs on boot when Powerpath loads "Starting PowerPath: /etc/init.d/PowerPath: line 1717: uniq : command not found". After boot manual start ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Upgraded PowerPath or fresh installed PowerPath for Linux 6.5.
DELL EMC SW: PowerPath for Linux 6.5
After installing PowerPath for Linux 6.5, PowerPath will not start on boot. The following error is seen when trying to start PowerPath:
PowerPath is successfully started manually after the host has booted up.
DELL EMC SW: PowerPath for Linux 6.5
After installing PowerPath for Linux 6.5, PowerPath will not start on boot. The following error is seen when trying to start PowerPath:
"Starting PowerPath: /etc/init.d/PowerPath: line 1717: uniq : command not found" is logged in boot.log
"Starting PowerPath: /etc/initi.d/PowerPath: /usr/bin/uniq: No such file or directory" appears on the Console upon boot.
"Starting PowerPath: /etc/initi.d/PowerPath: /usr/bin/uniq: No such file or directory" appears on the Console upon boot.
PowerPath is successfully started manually after the host has booted up.
Cause
The issue is caused by the result of the host having /usr separated from / .
For example:
For example:
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/vg01-lvroot
1998672 556332 1337484 30% / <--- Root
tmpfs 132060916 0 132060916 0% /dev/shm
/dev/sda1 245679 73875 158697 32% /boot
/dev/mapper/vg01-lvgrid
103164844 37104 97888268 1% /grid
/dev/mapper/vg01-lvopt
8125880 2230424 5476028 29% /opt
/dev/mapper/vg01-lvoracle
50992892 53080 48348248 1% /oracle
/dev/mapper/vg01-lvtmp
3030800 18720 2854796 1% /tmp
/dev/mapper/vg01-lvusr
8125880 2014876 5691576 27% /usr <--- /usr not located under root
/dev/mapper/vg01-lvvar
3997376 1078044 2709620 29% /var
Resolution
Immediate workaround:
To allow PowerPath to boot, copy /usr/bin/uniq to /bin and it will allow it to load on boot.
Note:
If the user is also mounting /bin under a disk managed by PowerPath, this will not work and the user needs to make the changes to allow /bin/uniq to be available when / is mounted.
This issue is fixed in PowerPath 7.0 and higher.
To allow PowerPath to boot, copy /usr/bin/uniq to /bin and it will allow it to load on boot.
Note:
If the user is also mounting /bin under a disk managed by PowerPath, this will not work and the user needs to make the changes to allow /bin/uniq to be available when / is mounted.
This issue is fixed in PowerPath 7.0 and higher.
Additional Information
The content was translated in different languages:
The error message does not always show up in /var/messages. It will show up in the boot.log which can be checked as well.
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB535665.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB535665.pdf |
The error message does not always show up in /var/messages. It will show up in the boot.log which can be checked as well.
Article Properties
Article Number: 000167759
Article Type: Solution
Last Modified: 23 Sep 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.