AppSync: The Lockbox stable value threshold was not met because the system fingerprint has changed.

Summary: Migrating the AppSync Server VM to a new environment in VMware causes an issue with the CST lockbox which requires a re-install or upgrade of AppSync to resolve.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



After migrating the Windows VM where the AppSync server is installed to a new environment, AppSync fails with the following error.
 
Lockbox stable value threshold was not met because the system fingerprint has changed.

AppSync Apache tomcat logs (C:\EMC\AppSync\apache-tomcat\logs\appsyncsecurityserver-stout)
 
2018-06-10 16:59:44,392 INFO [com.emc.archway.cas.auth.CASAuthenticationAdaptor] - <      CASAuthenticationAdaptor constructor >
2018-06-10 16:59:44,752 INFO [com.emc.archway.cas.auth.CSTInterface] - < CST Application data - product =Archway component Name =ArchwaySecurity version = 1.0>
2018-06-10 16:59:44,799 INFO [com.emc.archway.cas.auth.CSTInterface] - <      CSTInterface constructor - exception The Lockbox stable value threshold was not met because the system fingerprint has changed. To reset the system fingerprint, open the Lockbox using the passphrase. : File : C:\EMC\AppSync\cst\xml/csp.clb>
2018-06-10 16:59:44,799 ERROR [com.emc.archway.cas.auth.CSTInterface] - <The Lockbox stable value threshold was not met because the system fingerprint has changed. To reset the system fingerprint, open the Lockbox using the passphrase. : File : C:\EMC\AppSync\cst\xml/csp.clb>
com.emc.csp.error.IOException: The Lockbox stable value threshold was not met because the system fingerprint has changed. To reset the system fingerprint, open the Lockbox using the passphrase. : File : C:\EMC\AppSync\cst\xml/csp.clb
2018-06-10 16:59:44,845 INFO [com.emc.archway.cas.attributes.rolePersonAttributeDao] - < NO ROLES >
2018-06-10 17:00:21,310 INFO [com.emc.archway.cas.auth.CASAuthenticationAdaptor] - <      CASAuthenticationAdaptor constructor >
2018-06-10 17:00:21,310 INFO [com.emc.archway.cas.auth.CSTInterface] - <Checking for LDAP authority: PSO-AD-Authority>
2018-06-10 17:00:21,310 INFO [com.emc.archway.cas.attributes.rolePersonAttributeDao] - < getPerson called for admin>
2018-06-10 17:00:21,310 INFO [com.emc.archway.cas.attributes.rolePersonAttributeDao] - < retrieved cstIF ....com.emc.archway.cas.auth.CSTInterface@169be832>
2018-06-10 17:00:21,310 INFO [com.emc.archway.cas.auth.CSTInterface] - < Accesing roles in lockbox ... >
2018-06-10 17:00:21,310 INFO [com.emc.archway.cas.auth.CSTInterface] - < Accessed role exception >
2018-06-10 17:00:21,310 ERROR [com.emc.archway.cas.auth.CSTInterface] - <>
java.lang.NullPointerException

Cause

Problem in upgrading the CST lockbox which stores the credential and role information in AppSync.

Resolution

Workaround 1: 
  1. Shutdown all AppSync services.
  2. Take a VM snap of the AppSync server (If the AppSync server is a VM).
  3. Backup the AppSync Postgres database using backup assistant tool (as per the AppSync installation guide).
  4. Uninstall AppSync.
  5. Re-install AppSync.
  6. Restore AppSync database (as per the AppSync installation guide).
 
OR
 
Workaround 2:
 
Upgrade AppSync to the latest version.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000167818
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  3
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