VxRail: Disky vSAN ve stavu „Not mounted on this host“ a „Ineligible for use by vSAN“ nelze přidat do skupin disků vSAN
Summary: Tento článek popisuje, jak vyřešit problém, kdy není možné vytvářet skupiny disků vSAN. Rovněž řeší problémy s přidáváním disků ke stávajícím diskům, pokud na hostiteli panují abnormální podmínky. Konkrétní podmínky popsané v tomto článku zahrnují „nezpůsobilé“ disky, které by měly být k dispozici. Může se také zobrazit nesprávný celkový počet disků v hostiteli nebo další skupiny disků, které by zde neměly být. ...
Symptoms
Po kontrole disků pomocí příkazu „vdq -qH“ nebo „vdq -Hi“ najdete jeden nebo více disků s chybou „Reason: Not mounted on this host.“ Tyto disky a některé další ukazují zprávu „State: Ineligible for use by VSAN.“ Stav Ineligible mohou mít také karty Boss, disky Satadom, RecoverPoint a další typy, které by měly tento stav vykazovat. V nástroji vCenter může být více disků, než očekáváte, ačkoli ty navíc nelze přidat do skupin disků.
Nové disky po přidání nebo výměně po selhání disku nemusí být viditelné. Disky, které za „Name:“ nemají nic, by měly mít stav „naa.<numbers&letters>“. Ty se obvykle označují jako stínové disky nebo fantomové disky. Nacházejí se na místě, kde bývalo nyní ztracené zařízení. Přítomnost stínových disků může vést k různým problémům, jako jsou dlouhé časy spouštění, selhání ověření, neschopnost zajistit přístupnost a v některých situacích selhání hostitele.
Stínové disky je často možné odebrat prostřednictvím nástroje vCenter nebo příkazového řádku. Někdy se je však také nepodaří odstranit a v těchto případech je často nutné nejprve opravit disk ve stavu „Not mounted…“.
Cause
Pokud úložiště vSAN zjistí selhání zápisu na disk, může disk z úložiště vSAN vyhodit, i když hardwarové snímače zatím nezaznamenaly stav, který by mohl disk označit jako vadný. Pokud tento disk slouží jako cache nebo používáte deduplikaci a kompresi, musí úložiště vSAN přepnout celou skupinu disků do režimu offline. I když to může vést k výše uvedeným stavům, nejedná se o základní příčinu. Příčinou jsou poškozená metadata nebo disky, které stále obsahují oddíly (z dřívější konfigurace). Nejsou obnovené a připravené k opětovnému přidání do úložiště vSAN. K tomu může dojít i z jiných důvodů, když jsou metadata disku neúmyslně přepsána. Data jsou neporušená, ale již nepřístupná, a úložiště vSAN musí obnovit soulad se zásadami úložiště pomocí opětovné synchronizace.
Disk s tímto typem oddílu se může domnívat, že je součástí skupiny disků, a zobrazit cache disk tam, kde by neměl být. Tento cache disk nemá normální informace, jako je kapacita nebo název (chybí informace naa). Nelze jej však odebrat, protože hostitel si myslí, že disk není připojen. Takovou situaci nelze napravit ani opětovným spuštěním kontroly řadičů úložiště (to může způsobit selhání hostitele) ani restartováním hostitele.
Resolution
Obraťte se na technickou podporu společnosti Dell nebo autorizovaného servisního zástupce a uveďte ID tohoto článku znalostní databáze.
Oprava: U jakýchkoli „nepřipojených“ disků je nutné odebrat nebo skrýt oddíly disků a všechny vzdálené disky je nutné odstranit z prostředí. Pokud jsou oddíly maskované, měly by se znovu zobrazit jako „Eligible for use by vSAN“. Při přidání do skupiny disků by se měly vymazat veškeré položky, které se na nich během procesu nacházely. Po opravě tohoto problému a odstranění všech fantomových disků může být nutné hostitele restartovat. To se provádí poté, jakmile se na hostiteli zobrazí vše správně. V oblasti Cluster > Configure > Disk Management nástroje vCenter můžete vytvořit skupinu disků jako obvykle.
Postup:
Přepněte hostitele do režimu údržby (Ensure Accessibility). To chrání data v hostiteli před jakýmikoli chybami nebo neočekávanými problémy. Ujistěte se, že je v pořádku i zbytek úložiště vSAN. Pokud probíhá opětovná synchronizace úložiště vSAN, musí být tato synchronizace dokončena předtím, než bude možné z úložiště vSAN odebrat disky nebo skupiny disků s daty.
Společnost Broadcom představila ve verzích 7.X a vyšších jednoduchou funkci „Erase ESXi storage Devices“.
Vymazání úložných zařízení ESXi (vmware.com)
- V klientovi vSphere přejděte na hostitele ESXi.
- Klikněte na kartu Configure.
- V části Storage klikněte na položku Storage Devices.
- Vyberte jedno nebo více zařízení a klikněte na ikonu Erase Partitions.
- Ověřte, že informace o oddílu, které mažete, nejsou kriticky důležité.
- Kliknutím na tlačítko OK potvrďte změnu.
Pokud výše uvedené kroky nefungují, použijte níže uvedené ruční kroky:
-
Spusťte níže uvedený příkaz na hostiteli (v rozhraní Putty) a zkopírujte výstup do dokumentu. Není nutné použít rozhraní Putty, ale možnost kopírování a vkládání je užitečná.
vdq -qH
-
Určete disky, které jsou ve stavu „Ineligible for Use by VSAN“ a zobrazují buď zprávu „Reason: Not mounted on this host“ nebo nemají nic v poli Name (bez naa).
-
U správných disků se nejprve zobrazuje zpráva „Not mounted…“:
- Získejte NAA nezpůsobilého disku z výstupu příkazu „vdq -qH“ na hostiteli – spuštěním tohoto příkazu zamaskujte oddíly na disku:
partedUtil mklabel /dev/disks/<naa.#'s> gpt
- Spusťte znovu níže uvedený příkaz a ujistěte se, že se u disku nyní zobrazuje zpráva „Eligible for use by vSAN“.
vdq -qH
*Pokud ne, je nutné provést restart a zopakovat předchozí krok. Před restartováním byste se měli pokusit odstranit stínové disky, abyste se vyhnuli dlouhému procesu spouštění, protože hostitel inicializuje disky a pokouší se spustit služby vSAN.
- Získejte NAA nezpůsobilého disku z výstupu příkazu „vdq -qH“ na hostiteli – spuštěním tohoto příkazu zamaskujte oddíly na disku:
-
Odstraňte stínové disky. To lze obvykle provést ve stejné oblasti Disk Management. Pokud ne, použijte na hostiteli příkazový řádek.
$ esxcli vsan storage remove -u <UUID>
Poznamenejte si UUID disků bez názvů naa z výstupu v kroku 1.
-
Zkontrolujte, zda vše vypadá tak, jak má. Obnovte nástroj vCenter, znovu oblast Disk Management a spusťte na hostiteli příkaz „vdq -qH“, abyste se ujistili, že se všechny očekávané disky zobrazují a vykazují stav „Eligible for use by vSAN“. Pokud ne, restartujte hostitele, protože některé disky ještě nemusí být inicializovány, a proveďte kontrolu znovu.
-
Vytvořte skupinu disků nebo přidejte disky do stávajících skupin disků obvyklým způsobem (pokud používáte deduplikaci nebo kompresi, je nutné znovu vytvořit celou skupinu disků).