VxRail: Las unidades vSAN “No montadas en este host” y “No elegibles para su uso por vSAN” no se pueden agregar a los grupos de discos vSAN
Summary: En este artículo, se describe cómo corregir la imposibilidad de crear grupos de discos vSAN. También prevé problemas al agregar discos a los discos existentes cuando se muestran condiciones anormales en el host. Las condiciones específicas que se abordan en este artículo incluyen unidades “no elegibles” que deberían estar disponibles. También puede observar una cantidad incorrecta de unidades totales en el host o grupos de discos adicionales que no deberían estar allí. ...
Symptoms
Después de comprobar los discos con el comando “vdq -qH” o “vdq -Hi”, encontrará una o más unidades que muestran “Motivo: No se montó en este host”. Estas, y algunas otras, muestran “Estado: No es elegible para su uso por vSAN”. Entre las que no son elegibles, puede haber tarjetas Boss, Satadom, discos RecoverPoint y otros tipos que deben mostrar ese estado. Dentro de vCenter, es posible que observe más unidades de las esperadas, aunque las adicionales no están disponibles para agregarlas a grupos de discos.
Es posible que las unidades nuevas no estén visibles después de agregarlas o reemplazarlas tras una falla de la unidad. Las unidades que no tienen nada después de “Nombre:” deben ser “NAA.<numbers&letters>”. Por lo general, se denominan “discos fantasma” o “unidades fantasma”. Están en un lugar donde solía estar un dispositivo ya perdido. Tener discos fantasma presentes puede provocar varios problemas, como tiempos de inicio prolongados, validaciones fallidas, incapacidad de “garantizar la accesibilidad” y bloqueos del host en algunas situaciones.
La eliminación de las unidades fantasma suele ser posible a través de vCenter o mediante la línea de comandos. Sin embargo, a veces también fallan al eliminarse, y en estos casos suele ser necesario arreglar primero la unidad “No montada…”.
Cause
Si vSAN detecta una falla de escritura en una unidad, puede expulsarla incluso si los sensores de hardware aún no han detectado una condición que haga que marquen el disco como fallido. Si ese disco es una unidad de caché o si utiliza desduplicación y compresión, vSAN debe desconectar todo el grupo de discos. Si bien esto puede provocar las condiciones mencionadas anteriormente, no es la causa subyacente. La causa son los metadatos dañados o los discos que aún tienen particiones (de la configuración anterior). No se recuperan ni están listos para volver a agregarse a vSAN. Esto también puede ocurrir por otras razones cuando algo se escribe inadvertidamente sobre metadatos de disco de manera incorrecta. Los datos están intactos, pero ya no se puede acceder a ellos, y vSAN debe recuperar el cumplimiento de la política de almacenamiento con una resincronización.
Una unidad con este tipo de partición puede suponer que es parte de un grupo de discos y mostrar una unidad de caché donde no debería haberla. Esta unidad de caché no tiene información normal, como la capacidad o el nombre (falta información de NAA). Sin embargo, no se puede quitar debido a que el host cree que hay una unidad que no está montada. Tampoco se puede corregir volviendo a analizar las controladoras de almacenamiento (esto puede provocar un bloqueo del host) ni reiniciando el host.
Resolution
Comuníquese con el soporte técnico de Dell o con su representante de servicio autorizado y proporcione el ID de este artículo de la base de conocimientos.
Corregir: Cualquier unidad “No montada…” debe tener sus particiones eliminadas u ocultas y cualquier disco fantasma se debe eliminar del entorno. Si las particiones están enmascaradas, esto debería permitir que vuelvan a aparecer como “Elegibles para su uso por vSAN”. Agregarlas a un grupo de discos debería borrar todo lo que había en ellos durante el proceso. Después de arreglar eso y eliminar los discos fantasma, es posible que deba reiniciar el host. Esto se hace después de que todo se muestra correctamente en el host. En el área Cluster > Configure > Disk Management de vCenter, puede crear un grupo de discos de manera normal.
Pasos:
Coloque el host en modo de mantenimiento (Ensure Accessibility). Esto protege los datos en el host de errores o problemas inesperados. Asegúrese de que el resto de vSAN también esté en buen estado. Si hay una resincronización de vSAN en curso, esta debe completarse antes de que los discos o grupos de discos con datos se puedan eliminar de vSAN.
Broadcom introdujo una función simple “Borrar dispositivos de almacenamiento ESXi” en las versiones 7.X y superiores.
Borrar dispositivos de almacenamiento ESXi (vmware.com)
- En vSphere Client, vaya al host ESXi.
- Haga clic en la pestaña Configuration.
- En Storage, haga clic en Storage Devices.
- Seleccione uno o más dispositivos y haga clic en el ícono Erase Partitions.
- Verifique que la información de la partición que está borrando no sea fundamental.
- Haga clic en OK para confirmar el cambio.
Si el procedimiento anterior no funciona, siga los pasos manuales que se indican a continuación:
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Ejecute el siguiente comando en el host (en PuTTY) y copie el resultado en un documento. No se requiere PuTTY, pero es útil poder copiar y pegar.
vdq -qH
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Identifique las unidades que son “No elegibles para su uso por vSAN" Y muestren “Motivo: No se montó en este host” o no tiene nada en el campo Nombre (sin NAA).
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Corrija primero las unidades que muestren “No montadas…”:
- Obtenga la NAA del disco no elegible de la salida de “vdq -qH” en el host: ejecute este comando para enmascarar las particiones en el disco:
partedUtil mklabel /dev/disks/<naa.#'s> gpt
- Vuelva a ejecutar el siguiente comando y asegúrese de que la unidad ahora muestre “Elegible para su uso por vSAN”.
vdq -qH
* Si no es así, es necesario reiniciar y, luego, repetir el paso anterior. Debe intentar quitar los discos fantasma antes de reiniciar para evitar un proceso de inicio prolongado a medida que el host inicializa los discos y los servicios de vSAN intentan iniciarse.
- Obtenga la NAA del disco no elegible de la salida de “vdq -qH” en el host: ejecute este comando para enmascarar las particiones en el disco:
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Quite los discos fantasma. Por lo general, puede hacer esto en la misma área de Administración de discos. Si no es así, utilice la línea de comandos en el host.
$ esxcli vsan storage remove -u <UUID>
Anote el UUID de los discos sin nombres de NAA, de la salida en el paso 1.
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Compruebe que todo funcione correctamente. Actualice vCenter y compruebe nuevamente la Administración de discos, además de ejecutar el comando “vdq -qH” en el host para asegurarse de que todas las unidades esperadas aparezcan y muestren “Elegibles para su uso por vSAN” ahora. Si no es así, reinicie el host, ya que es posible que algunas unidades aún no se hayan inicializado, y vuelva a realizar la comprobación.
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Cree el grupo de discos o agregue discos a los grupos de discos existentes de manera normal (si utiliza la desduplicación o la compresión, se necesita recrear todo el grupo de discos).