VPLEX: Nepodařilo se zrušit uvolnění svazku úložiště, který byl odstraněn z backendového pole.

Summary: Při pokusu o zrušení nároku na svazek úložiště, který byl odstraněn z backendového pole, došlo k chybě příkazu firmwaru.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Svazek pole "storage_volume_1" původně s VPDID "VPD83T3:514f0c55892000abc" byl již odebrán z pole VPLEX a backendového pole.
  • Byl vytvořen nový úložný svazek se stejným názvem, jako má odebraný úložný svazek, tedy "storage_volume_1", a byl prezentován ve VPLEX. Příkaz "naa:" Identifikátor backendového pole je "514f0c55892000xyz".

       Příklad: 

VPlexcli:/clusters/cluster-2/storage-elements/storage-arrays/XtremIO-XtremApp-CKMxxxxxxxxx69/logical-units> ll
Name                      Connectivity  Active/AAO      Passive/AAN  Visibility  LUNs                ALUA
------------------------  Status        Controllers     Controllers  ----------  ------------------  Support
------------------------  ------------  --------------  -----------  ----------  ------------------  -------
VPD83T3:xxxxxxxxxxxxxx54  ok            CKMxxxxxxxxx69                active     0x0008000000000000  none

 

  • Po vytvoření nového svazku úložiště na VPLEX se pole úložišť stalo "neznámým". Příkaz "naa:" Identifikátor byl "VPD83T3:514f0c55892000abc", což byl identifikátor dříve odebraného svazku pole s názvem "storage_volume_1".
  • Nový svazek úložiště byl ale namapován na "naa:" Identifikátor "514f0c55892000xyz" používající předchozí název svazku úložiště "storage-volume_1" při pohledu z backendového pole a pokusu o odmapování způsobil chybu.
  • Nově vytvořený svazek úložiště má při pohledu z backendu jako ID NAA "VPD83T3:514f0c5589200xyz".
  • Technicky vzato svazek s identifikátorem končícím na "abc" neexistuje. Zatímco nový svazek s identifikátorem končícím na "xyz" je v pořádku.



Když byl příkaz unclaim použit ke zrušení deklarace objemu úložiště, který byl odebrán z backendového pole, nepodařilo se zrušit získání svazku úložiště.
 
Při pokusu o zrušení získání konkrétního svazku úložiště ze systému VPLEX se zobrazí chyba "Firmware command error." a příčina selhání hlášená firmwarem
 
Příklad:
     VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d <storage_volume_name>
     storage-volume unclaim:  Evaluation of <<unclaim -d storage_volume_name>> failed.
     cause:                   Failed to unclaim storage-volumes.
     cause:                   Firmware command error.
     cause:                   Valid storage-volume, but storage-volume not known by device. << reason of failure
 

Ukázkový výstup: 
      VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d INFxxxxxxxxxxxxDS01
     storage-volume unclaim:  Evaluation of <<unclaim -d INFXXXXXXXXXXXXDS01>> failed.
      cause:                   Failed to unclaim storage-volumes.
      cause:                   Firmware command error.
      cause:                   Valid storage-volume, but storage-volume not known by device.
 

Cause

Název svazku úložiště s konkrétním kódem VPDID, který je nutné použít s příkazem unclaim, byl odstraněn z pole úložišť, ale nebyl uvolněn ze systému VPLEX. Byl však vytvořen nový svazek úložiště se stejným názvem.

Příklad:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> ll
Name                                       VPD83 ID                                  Capacity  Use        Vendor      IO      Type         Thin     Provision  Thin
-----------------------------------------  ----------------------------------------  --------  ---------  -------        Status  -----------  Rebuild  Type       Capable
-----------------------------------------  ----------------------------------------  --------  ---------  -------        ------  -----------  -------  ---------  -------
INFxxxxxxxxxxxxDS01                        VPD83T3:xxxxxxxxxxxxxx12                  10T       claimed    -              alive   normal      true    legacy     -    

 

Resolution

  •  Pro ověření se přihlaste do VPlexcli a zkontrolujte hierarchii svazku úložiště, který má být nenárokován. 

         Příklad:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> show-use-hierarchy <storage_volume_name>
storage-volume: <storage_volume_name> (size)

     

POZNÁMKA: Pokud nejste na úrovni kontextu, kde spustíte příkaz show-use-hierarchy, budete potřebovat úplnou cestu, kde svazek, zařízení nebo rozsah zobrazíte podrobnosti o hierarchii úplného použití, například pro použití s storage-volume:
show-use-hierarchy clusters/cluster-2/storage-elements/storage-volumes/<storage_volume_name>


    Ukázkový výstup:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> show-use-hierarchy INFxxxxxxxxxxxxDS01
storage-volume: INFxxxxxxxxxxxxDS01 (10T) 
  • Restartujte server VplexManagementConsole, jak je znázorněno níže:
service@<ManagemetServer>:~> sudo /etc/init.d/VPlexManagementConsole restart
Restarting EMC VPlex Management Console...

 

POZNÁMKA:
Po restartování konzole pro správu počkejte 1–2 minuty, aby se systém stabilizoval, než se znovu pokusíte o nové přihlášení do VPlexcli.
  • Přihlaste se do konzole Vplexcli a znovu zadejte příkaz "unclaim -d <storage_volume_name>“.

          Příklad:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d <storage_volume_name>
Unclaimed 1 of 1 storage-volumes.


          Ukázkový výstup:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d INFxxxxxxxxxxxxDS01
Unclaimed 1 of 1 storage-volumes.
  • Udělejte dlouhý výpis " ll " v kontextu svazku úložiště. storage_volume_name<> by se neměl zobrazovat. Pokud tomu tak není, znamená to, že svazek, jehož jste právě zrušili nárokování, byl úspěšně zrušen.

 

Affected Products

VPLEX Series

Products

VPLEX Series, VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000167851
Article Type: Solution
Last Modified: 09 Sep 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.