VPLEX: Kunne ikke gøre krav på storagediskenhed, som blev slettet fra backend-arrayet.

Summary: Der opstod en firmwarekommandofejl, da du forsøgte at ophæve kravet på en storagediskenhed, som var blevet slettet fra backend-arrayet.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • En systemdiskenhed "storage_volume_1" oprindeligt med VPDID "VPD83T3:514f0c55892000abc" var allerede fjernet fra VPLEX- og backend-arrayet.
  • En ny lagerdiskenhed med samme navn som den fjernede lagerdiskenhed, dvs. "storage_volume_1", blev oprettet og præsenteret for VPLEX. "Naa:" Identifikatoren er "514f0c55892000xyz" på backend-arrayet.

       Eksempel: 

VPlexcli:/clusters/cluster-2/storage-elements/storage-arrays/XtremIO-XtremApp-CKMxxxxxxxxx69/logical-units> ll
Name                      Connectivity  Active/AAO      Passive/AAN  Visibility  LUNs                ALUA
------------------------  Status        Controllers     Controllers  ----------  ------------------  Support
------------------------  ------------  --------------  -----------  ----------  ------------------  -------
VPD83T3:xxxxxxxxxxxxxx54  ok            CKMxxxxxxxxx69                active     0x0008000000000000  none

 

  • Storagesystemet blev "ukendt" efter oprettelse af den nye storagediskenhed på VPLEX. "Naa:" Id blev til "VPD83T3:514f0c55892000abc", som var identifikatoren for den tidligere fjernede systemdiskenhed med navnet "storage_volume_1".
  • Den nye lagerdiskenhed blev dog knyttet til "naa:" Identifikatoren "514f0c55892000xyz" med det tidligere lagerdiskenhedsnavn, "storage-volume_1", set fra backend-arrayet, og forsøg på at fjerne tilknytningen udløste en fejl.
  • Den nyoprettede lagervolumen har "VPD83T3: 514f0c5589200xyz" som sit NAA-id, når det ses fra backend.
  • Teknisk set findes der ikke et volumen med en identifikator, der slutter med "abc". Mens det nye volumen med en identifikator, der slutter med "xyz", er fint.



Når kommandoen unclaim" blev brugt til at ophæve kravet på en storagediskenhed, der var blevet fjernet på backend-arrayet, kunne den ikke ophæve kravet på Storage Volume.
 
Når du forsøger at gøre krav på en bestemt lagerdiskenhed fra VPLEX, modtager vi fejlen "Firmwarekommandofejl.", og årsagen til fejlen som rapporteret af firmwaren
 
Eksempel:
     VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d <storage_volume_name>
     storage-volume unclaim:  Evaluation of <<unclaim -d storage_volume_name>> failed.
     cause:                   Failed to unclaim storage-volumes.
     cause:                   Firmware command error.
     cause:                   Valid storage-volume, but storage-volume not known by device. << reason of failure
 

Eksempel på output: 
      VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d INFxxxxxxxxxxxxDS01
     storage-volume unclaim:  Evaluation of <<unclaim -d INFXXXXXXXXXXXXDS01>> failed.
      cause:                   Failed to unclaim storage-volumes.
      cause:                   Firmware command error.
      cause:                   Valid storage-volume, but storage-volume not known by device.
 

Cause

Et lagerdiskenhedsnavn med en bestemt VPDID, som skal bruges sammen med kommandoen unclaim, blev slettet fra storagesystemet, men blev ikke gjort utilgængeligt fra VPLEX. Der blev dog oprettet en ny lagerdiskenhed med samme navn.

Eksempel:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> ll
Name                                       VPD83 ID                                  Capacity  Use        Vendor      IO      Type         Thin     Provision  Thin
-----------------------------------------  ----------------------------------------  --------  ---------  -------        Status  -----------  Rebuild  Type       Capable
-----------------------------------------  ----------------------------------------  --------  ---------  -------        ------  -----------  -------  ---------  -------
INFxxxxxxxxxxxxDS01                        VPD83T3:xxxxxxxxxxxxxx12                  10T       claimed    -              alive   normal      true    legacy     -    

 

Resolution

  •  For bekræftelse skal du logge ind på VPlexcli og kontrollere hierarkiet for den lagerdiskenhed, der skal afhentes. 

         Eksempel:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> show-use-hierarchy <storage_volume_name>
storage-volume: <storage_volume_name> (size)

     

BEMÆRK: Hvis du ikke er på det kontekstniveau, hvor du vil køre kommandoen show-use-hierarchy, skal du bruge den fulde sti til, hvor diskenheden/enheden/omfanget for at se detaljerne for det fulde brugshierarki, eksempel til brug med lagerdiskenhed:
show-use-hierarchy clusters/cluster-2/storage-elements/storage-volumes/<storage_volume_name>


    Eksempel på output:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> show-use-hierarchy INFxxxxxxxxxxxxDS01
storage-volume: INFxxxxxxxxxxxxDS01 (10T) 
  • Genstart VplexManagementConsole-serveren som vist nedenfor,
service@<ManagemetServer>:~> sudo /etc/init.d/VPlexManagementConsole restart
Restarting EMC VPlex Management Console...

 

SEDDEL:
Når du har genstartet administrationskonsollen, skal du vente i 1-2 minutter, så systemet kan stabilisere sig, før du forsøger at logge på VPlexcli igen.
  • Log på Vplexcli-konsollen, og genudsted kommandoen "unclaim -d <storage_volume_name>"

          Eksempel:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d <storage_volume_name>
Unclaimed 1 of 1 storage-volumes.


          Eksempel på output:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d INFxxxxxxxxxxxxDS01
Unclaimed 1 of 1 storage-volumes.
  • Lav en lang liste, ' ll ', på lagerdiskenhedskonteksten. De <storage_volume_name> bør ikke dukke op. Hvis det ikke gør det, betyder det, at det volumen, du lige havde opkrævet, er blevet uopkrævet.

 

Affected Products

VPLEX Series

Products

VPLEX Series, VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000167851
Article Type: Solution
Last Modified: 09 Sep 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.