VPLEX: Kan ikke hente tilbake lagringsvolumet som ble slettet fra backend-arrayet.

Summary: Det oppsto en fastvarekommandofeil under forsøk på å hente tilbake et lagringsvolum som var slettet fra backend-arrayet.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Et matrisevolum "storage_volume_1" opprinnelig med VPDID "VPD83T3:514f0c55892000abc" ble allerede fjernet fra VPLEX- og backend-matrisen.
  • Et nytt lagringsvolum med samme navn som det fjernede lagringsvolumet, det vil si "storage_volume_1", ble opprettet og presentert for VPLEX. Den "naa:" Identifikatoren er "514f0c55892000xyz" på backend-matrisen.

       Eksempel: 

VPlexcli:/clusters/cluster-2/storage-elements/storage-arrays/XtremIO-XtremApp-CKMxxxxxxxxx69/logical-units> ll
Name                      Connectivity  Active/AAO      Passive/AAN  Visibility  LUNs                ALUA
------------------------  Status        Controllers     Controllers  ----------  ------------------  Support
------------------------  ------------  --------------  -----------  ----------  ------------------  -------
VPD83T3:xxxxxxxxxxxxxx54  ok            CKMxxxxxxxxx69                active     0x0008000000000000  none

 

  • Lagringsarrayet ble "ukjent" etter å ha opprettet det nye lagringsvolumet på VPLEX. Den "naa:" Identifikatoren ble "VPD83T3:514f0c55892000abc", som var identifikatoren for det tidligere fjernede matrisevolumet kalt "storage_volume_1".
  • Det nye lagringsvolumet ble imidlertid tilordnet "naa:" Identifikatoren "514f0c55892000xyz" ved hjelp av det tidligere lagringsvolumnavnet, "storage-volume_1", sett fra backend-matrisen, og forsøk på å fjerne tilordningen utstedte en feil.
  • Det nyopprettede lagringsvolumet har "VPD83T3:514f0c5589200xyz" som sin NAA-ID sett fra backend.
  • Teknisk sett eksisterer ikke et volum med en identifikator som slutter med "abc". Mens det nye volumet med en identifikator som slutter med "xyz" er greit.



Når kommandoen for å fjerne krav ble brukt til å hente tilbake et lagringsvolum som var fjernet på serverdel-arrayet, kunne den ikke hente tilbake lagringsvolumet.
 
Når vi prøver å hente tilbake et bestemt lagringsvolum fra VPLEX, får vi en feilmelding "Firmware command error." og årsaken til feilen som rapportert av fastvaren
 
Eksempel:
     VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d <storage_volume_name>
     storage-volume unclaim:  Evaluation of <<unclaim -d storage_volume_name>> failed.
     cause:                   Failed to unclaim storage-volumes.
     cause:                   Firmware command error.
     cause:                   Valid storage-volume, but storage-volume not known by device. << reason of failure
 

Eksempel på utdata: 
      VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d INFxxxxxxxxxxxxDS01
     storage-volume unclaim:  Evaluation of <<unclaim -d INFXXXXXXXXXXXXDS01>> failed.
      cause:                   Failed to unclaim storage-volumes.
      cause:                   Firmware command error.
      cause:                   Valid storage-volume, but storage-volume not known by device.
 

Cause

Et lagringsvolumnavn som har en bestemt VPDID, som kreves for å brukes med unclaim-kommandoen, ble slettet fra lagringsarrayet, men ble ikke hentet fra VPLEX. Et nytt lagringsvolum med samme navn ble imidlertid opprettet.

Eksempel:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> ll
Name                                       VPD83 ID                                  Capacity  Use        Vendor      IO      Type         Thin     Provision  Thin
-----------------------------------------  ----------------------------------------  --------  ---------  -------        Status  -----------  Rebuild  Type       Capable
-----------------------------------------  ----------------------------------------  --------  ---------  -------        ------  -----------  -------  ---------  -------
INFxxxxxxxxxxxxDS01                        VPD83T3:xxxxxxxxxxxxxx12                  10T       claimed    -              alive   normal      true    legacy     -    

 

Resolution

  •  For bekreftelse, logg på VPlexcli og sjekk hierarkiet til lagringsvolumet som skal hentes. 

         Eksempel:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> show-use-hierarchy <storage_volume_name>
storage-volume: <storage_volume_name> (size)

     

MERK: Hvis du ikke er på kontekstnivået der du skal kjøre kommandoen vis-bruk-hierarki, trenger du hele banen for hvor volumet/enheten/omfanget skal se hierarkidetaljene for full bruk, for eksempel for bruk med lagringsvolum:
show-use-hierarchy clusters/cluster-2/storage-elements/storage-volumes/<storage_volume_name>


    Eksempel på utdata:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> show-use-hierarchy INFxxxxxxxxxxxxDS01
storage-volume: INFxxxxxxxxxxxxDS01 (10T) 
  • Start VplexManagementConsole-serveren på nytt som vist nedenfor,
service@<ManagemetServer>:~> sudo /etc/init.d/VPlexManagementConsole restart
Restarting EMC VPlex Management Console...

 

NOTAT:
Når du har startet administrasjonskonsollen på nytt, venter du i 1–2 minutter for å la systemet stabilisere seg før du prøver å logge på VPlexcli på nytt.
  • Logg på Vplexcli-konsollen og utsted kommandoen " på nyttunclaim -d <storage_volume_name>»

          Eksempel:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d <storage_volume_name>
Unclaimed 1 of 1 storage-volumes.


          Eksempel på utdata:

VPlexcli:/clusters/cluster-2/storage-elements/storage-volumes> unclaim -d INFxxxxxxxxxxxxDS01
Unclaimed 1 of 1 storage-volumes.
  • Gjør en lang liste, ' ll ', på lagringsvolum sammenheng. storage_volume_name<> skal ikke dukke opp. Hvis ikke, betyr dette at volumet du nettopp hadde uhentet, har blitt avhentet.

 

Affected Products

VPLEX Series

Products

VPLEX Series, VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000167851
Article Type: Solution
Last Modified: 09 Sep 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.