AppSync. Сбой Oracle Database Recovery при попытке изменить владельца места назначения архивного журнала
Summary: Команда Chown для каталога архивного журнала завершается сбоем, так как сам каталог не существует на хосте монтирования.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
При попытке смонтировать и восстановить копию базы данных Oracle происходит сбой плана обслуживания на этапе предварительного восстановления базы данных со следующими ошибками:
В событиях плана обслуживания отображаются:
Восстановление копии, MILE_000005,< сервер AppSync>, этап восстановления копии для <DBNAME> завершен с ошибками
Восстановление копии, GENL_000055,< сервер AppSync>, произошла ошибка при запуске preRecoverDatabase на хосте <MOUNTHOST.> Дополнительные сведения см. xxx.log на хосте агента.
Восстановление копии, GENL_000055,< сервер AppSync>, произошла ошибка при запуске preRecoverDatabase на хосте <MOUNTHOST.> Дополнительные сведения см. xxx.log на хосте агента.
В журнале сервера AppSync отображается следующее:
ОШИБКА [EJB по умолчанию — 6] [com.emc.archway.service.sshservice.SshServiceBean] [<Сервер> AppSync] [] —>>> сбой ACP, дамп stderr: Traceback (most recent call last):
Файл "/usr/local/lib/python3.3/site-packages/cx_Freeze/initscripts/Console3.py", строка 27, в <модуле>
Файл "acp.py", строка 146, в <файл
> модуля "acp.py", строка 118, в основном
файле "generic/oracle.py", строка 117, запуск
файла "generic/oracle.py", строка 618, файл preRecoverDatabase
"generic/oracle.py", строка 2928, файл preRecoverDatabase
"generic/oracle.py", строка 4458, в changeOwner
Файл «/jenkins/lglbi061/workspace/Build-Linux-3.8.0.0/urm/appsync/3.8.0.0/integration/acp/src/appsync/acputil.py», строка 656, в разделе «Execute
acputil». ShellException: Команда 'chown -R 1000:1000 /archives/<Сбой имени>файловой системы с кодом ошибки 1: ['chown: не удается получить доступ \u20xx/archives/<Имя>файловой системы/\u20yy: Нет такого файла или каталога']
Файл "/usr/local/lib/python3.3/site-packages/cx_Freeze/initscripts/Console3.py", строка 27, в <модуле>
Файл "acp.py", строка 146, в <файл
> модуля "acp.py", строка 118, в основном
файле "generic/oracle.py", строка 117, запуск
файла "generic/oracle.py", строка 618, файл preRecoverDatabase
"generic/oracle.py", строка 2928, файл preRecoverDatabase
"generic/oracle.py", строка 4458, в changeOwner
Файл «/jenkins/lglbi061/workspace/Build-Linux-3.8.0.0/urm/appsync/3.8.0.0/integration/acp/src/appsync/acputil.py», строка 656, в разделе «Execute
acputil». ShellException: Команда 'chown -R 1000:1000 /archives/<Сбой имени>файловой системы с кодом ошибки 1: ['chown: не удается получить доступ \u20xx/archives/<Имя>файловой системы/\u20yy: Нет такого файла или каталога']
В журнале подключаемого модуля AppSync на хосте монтирования, на который ссылается событие Service Plan для просмотра дополнительных сведений, будет отображаться выполняемая команда, но за этим ничего не последует, например:
acputil.py[643]:execute() Info:Выполнение команды: chown -R 1000:1000 /archives/<DBNAME>/
Cause
Каталог архивного журнала был создан как имя> /archive/<Filesystem при создании базы данных Oracle, но он был смонтирован с именем файловой системы: /archive. В базе данных AppSync место назначения архива сохраняется как имя /archive/<Filesystem —> то же имя, которое указано при создании базы данных.
Когда AppSync монтирует копию и пытается восстановить ее, целевой ресурс извлекается из базы данных AppSync и пытается изменить владельца в целевой системе. Поскольку AppSync смонтировал его как /archive, имени /archive/<Filesystem не> существует на хосте монтирования. Причина в том, что путь не указан в параметрах «Path mapping settings» для /archive, поэтому по умолчанию он будет смонтирован в /archive на хосте монтирования.
Имени> каталога /archive/<Filesystem не существует на хосте монтирования, но при изменении разрешения AppSync находит имя из базы данных.
Когда AppSync монтирует копию и пытается восстановить ее, целевой ресурс извлекается из базы данных AppSync и пытается изменить владельца в целевой системе. Поскольку AppSync смонтировал его как /archive, имени /archive/<Filesystem не> существует на хосте монтирования. Причина в том, что путь не указан в параметрах «Path mapping settings» для /archive, поэтому по умолчанию он будет смонтирован в /archive на хосте монтирования.
Имени> каталога /archive/<Filesystem не существует на хосте монтирования, но при изменении разрешения AppSync находит имя из базы данных.
Resolution
Технический отдел AppSync выпустил исправление для этой проблемы. Откройте заявку в службе технической поддержки Dell EMC и укажите идентификатор этой статьи, чтобы получить оперативное исправление.
Это оперативное исправление будет включено в будущие выпуски AppSync. Ознакомьтесь с примечаниями к будущим выпускам, чтобы убедиться, что проблема устранена в версии, которую вы хотите установить.
Это оперативное исправление будет включено в будущие выпуски AppSync. Ознакомьтесь с примечаниями к будущим выпускам, чтобы убедиться, что проблема устранена в версии, которую вы хотите установить.
Additional Information
Содержание этой статьи переведено на разные языки:
| https://downloads.dell.com/TranslatedPDF/AR-SA_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_537205.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-TW_537205.pdf |
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000168360
Article Type: Solution
Last Modified: 18 Sep 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.