AppSync:嘗試變更歸檔記錄目的地的擁有者時,Oracle 資料庫復原會失敗

Summary: 歸檔記錄目錄的 chown 命令失敗,因為掛接主機上不存在目錄本身。

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Symptoms



嘗試掛接並還原 Oracle 資料庫複本時,服務計劃在「預先復原資料庫」步驟中失敗,並顯示下列錯誤:

服務計畫事件隨即顯示:
還原複本, MILE_000005,AppSync< 伺服器>,DBNAME> 的復原複本階段<已完成,但發生錯誤
復原複本, GENL_000055,AppSync< 伺服器>,在主機 <MOUNTHOST> 上執行 preRecoverDatabase 時發生錯誤。如需詳細資訊,請參閱代理主機上的xxx.log。

AppSync 伺服器記錄將顯示:
錯誤 [EJB default - 6] [com.emc.archway.service.sshservice.SshServiceBean] [<AppSync Server>] [] ->>> ACP 失敗,傾印 stderr:Traceback (most recent call last):
  檔案「/usr/local/lib/python3.3/site-packages/cx_Freeze/initscripts/Console3.py」,第 27 行,在 <模組>
檔案「acp.py」中,第 146 行,在 <模組>
檔案「acp.py」,第 118 行,在主
檔案「generic/oracle.py」中,在第 117 行中,在執行
檔案「generic/oracle.py」中,在 preRecoverDatabase
檔案「generic/oracle.py」中,在第 2928 行中,在 preRecoverDatabase
檔案「generic/oracle.py」中,在第 4458 行中,在 changeOwner
中 檔案「/jenkins/lglbi061/workspace/Build-Linux-3.8.0.0/urm/appsync/3.8.0.0/integration/acp/src/appsync/acputil.py」,第 656 行,以執行
acputil。ShellException:命令 'chown -R 1000:1000 /archives/
<檔案系統名稱>/' 失敗,錯誤代碼 1:['chown: 無法存取 \u20xx/archives/<檔案系統名稱>/\u20yy:沒有此類檔案或目錄']

在服務計畫事件中參考掛接主機上的 AppSync 附掛程式記錄,以檢視更多詳細資料,會顯示正在執行的命令,但不會有任何後續內容,如下所示:
acputil.py[643]:execute() Info:Running command: chown -r 1000:1000 /archives/<DBNAME>/

Cause

建立 oracle 資料庫時,已將歸檔記錄目錄建立為 /archive/<Filesystem 名稱> ,但掛接該目錄的檔案系統名稱為 /archive。在 AppSync 資料庫中,存檔目的地會另存為 /archive/<Filesystem 名稱>,與建立資料庫時提供的名稱相同。

當 AppSync 掛接複本並嘗試還原時,它會從 AppSync 資料庫取得目的地,並嘗試變更目的地上的擁有權。由於 AppSync 將其掛接為 /archive,因此掛接主機上不存在 /archive/<Filesystem 名稱> 。原因是 /archive 的「路徑映射設定」中並未指定路徑,這會預設在掛接主機上將其掛載為 /archive。

掛接主機上不存在目錄 /archive/<Filesystem 名稱> ,但在變更權限時,AppSync 會從資料庫中找到該名稱。

Resolution

AppSync 工程部門已針對此問題發佈了修補程式。請向 Dell EMC 技術支援開立工單,並引述本文 ID 以取得 hotfix。

此修補程式將合併到 AppSync 未來的版本中。查看未來的發行說明,確認此問題是否已在您要安裝的版本中解決。

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Affected Products

AppSync

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Article Properties
Article Number: 000168360
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  4
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