AppSync. Замена самозаверяющего сертификата сертификатом CA завершается сбоем с ошибкой
Summary: Более старые версии OpenSSL могут вызывать проблемы при импорте сертификатов для использования с AppSync.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
При попытке заменить самозаверяющий сертификат сертификатом CA для использования с AppSync происходит сбой процесса со следующей ошибкой:
java.lang.Exception: Сертификат не импортирован, псевдоним <appsync> уже существует
Эта ошибка может наблюдаться после выполнения следующих команд в рамках процесса.
C:\EMC\AppSync\jboss\_jre\bin\keytool -importcert -file C:\OpenSSL\cert.pem -keystore C:\EMC\AppSync\jboss\_jre\lib\security\cacerts -storepass changeit -alias appsync noprompt
Cause
Версия OpenSSL, установленная в среде, была 1.0.2j 64-bit.
Возникли проблемы с импортом сертификатов при использовании версии openSSL из ветви 1.0.2 и более ранних.
Возникли проблемы с импортом сертификатов при использовании версии openSSL из ветви 1.0.2 и более ранних.
Resolution
Обновление до версии OpenSSL 1.1.0h решило эту проблему.
Если эта проблема будет возникать в будущем, рекомендуется обновить OpenSSL до последней доступной версии.
Последние версии OpenSSL доступны для скачивания на https://www.openssl.org/source/
Если эта проблема будет возникать в будущем, рекомендуется обновить OpenSSL до последней доступной версии.
Последние версии OpenSSL доступны для скачивания на https://www.openssl.org/source/
Additional Information
Содержание этой статьи переведено на разные языки:
Дополнительные сведения о замене самозаверяющего сертификата сертификатом CA см. в руководстве по безопасности и настройке AppSync 3.9, стр. 26, доступном на странице поддержки продукта AppSync.
https://support.emc.com/products/25364_AppSync
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/AR-EG_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB533599.pdf |
Дополнительные сведения о замене самозаверяющего сертификата сертификатом CA см. в руководстве по безопасности и настройке AppSync 3.9, стр. 26, доступном на странице поддержки продукта AppSync.
https://support.emc.com/products/25364_AppSync
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000168555
Article Type: Solution
Last Modified: 18 Sep 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.