AppSync: Kendinden İmzalı Sertifikayı CA Sertifikası ile değiştirme hata vererek başarısız oluyor
Summary: OpenSSL'nin eski sürümleri, AppSync ile kullanılmak üzere sertifikaları içe aktarırken sorunlara neden olabilir.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Kendinden imzalı bir sertifikayı AppSync ile kullanılacak bir CA sertifikasıyla değiştirmeye çalışırken işlem aşağıdaki hatayla başarısız olur.
java.lang.Exception: Sertifika içe aktarılmadı, diğer <ad appsync> zaten var
Bu hata, aşağıdaki komutlar işlemin bir parçası olarak çalıştırıldıktan sonra görülebilir.
C:\EMC\AppSync\jboss\_jre\bin\keytool -importcert -file C:\OpenSSL\cert.pem -keystore C:\EMC\AppSync\jboss\_jre\lib\security\cacerts -storepass changeit -alias appsync noprompt
Cause
Ortamda yüklü olan OpenSSL sürümü 1.0.2j 64 bit idi.
OpenSSL sürümü 1.0.2 ve daha eski bir sürümden olduğunda sertifikaların içe aktarılmasıyla ilgili sorunlar gözlemlenmiştir.
OpenSSL sürümü 1.0.2 ve daha eski bir sürümden olduğunda sertifikaların içe aktarılmasıyla ilgili sorunlar gözlemlenmiştir.
Resolution
OpenSSL sürüm 1.1.0h ye yükseltmek bu sorunu çözmüştür.
Gelecekte bu sorunla karşılaşırsanız, OpenSSL'nin mevcut en son sürümüne yükseltmeniz önerilir.
OpenSSL'nin en son sürümleri şu adresten indirilebilir https://www.openssl.org/source/
Gelecekte bu sorunla karşılaşırsanız, OpenSSL'nin mevcut en son sürümüne yükseltmeniz önerilir.
OpenSSL'nin en son sürümleri şu adresten indirilebilir https://www.openssl.org/source/
Additional Information
Bu içerik farklı dillere çevrilmiştir:
Kendinden imzalı bir sertifikayı CA sertifikasıyla değiştirme hakkında daha fazla bilgi için lütfen AppSync ürün destek sayfasında bulunan AppSync 3.9 Güvenlik ve Yapılandırma Rehberi, sayfa 26'ya bakın.
https://support.emc.com/products/25364_AppSync
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/AR-EG_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB533599.pdf |
Kendinden imzalı bir sertifikayı CA sertifikasıyla değiştirme hakkında daha fazla bilgi için lütfen AppSync ürün destek sayfasında bulunan AppSync 3.9 Güvenlik ve Yapılandırma Rehberi, sayfa 26'ya bakın.
https://support.emc.com/products/25364_AppSync
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000168555
Article Type: Solution
Last Modified: 18 Sep 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.