AppSync:將自我簽署憑證更換為 CA 憑證失敗,並傳回錯誤

Summary: 匯入憑證以搭配 AppSync 使用時,舊版的 OpenSSL 可能會導致問題。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



嘗試將自我簽署憑證更換為 CA 憑證以搭配 AppSync 使用時,程序會失敗,並顯示下列錯誤。 
 
java.lang.exception:憑證未匯入,別名 <appsync> 已存在 

在程序中執行下列命令後,可能會出現此錯誤。 
 
C:\EMC\AppSync\jboss\_jre\bin\keytool -importcert -file C:\OpenSSL\cert.pem -keystore C:\EMC\AppSync\jboss\_jre\lib\security\cacerts -storepass changeit -alias appsync noprompt

Cause

環境中安裝的 OpenSSL 版本為 1.0.2j 64 位元。

當 openSSL 版本為 1.0.2 分支及更舊版本時,匯入憑證時會發現問題。 

Resolution

升級至 OpenSSL 1.1.0h 版可解決此問題。

如果將來遇到此問題,建議升級到 OpenSSL 的最新可用版本。

最新版本的 OpenSSL 可在 https://www.openssl.org/source/ 下載

Additional Information

本內容已翻譯為不同語言: 
https://downloads.dell.com/TranslatedPDF/PT-BR_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/AR-EG_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/ES_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/PT_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB533599.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB533599.pdf


如需有關將自我簽署憑證更換為 CA 憑證的詳細資訊,請參閱 AppSync 3.9 安全性與組態指南第 26 頁,可從 AppSync 產品支援頁面取得。

https://support.emc.com/products/25364_AppSync

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000168555
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  4
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