Синхронізація додатків: Заміна самопідписаного сертифіката сертифікатом ЦС не вдається з помилкою
Summary: Старіші версії OpenSSL можуть спричиняти проблеми під час імпорту сертифікатів для використання з AppSync.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Під час спроби замінити самопідписаний сертифікат сертифікатом CA для використання з AppSync процес завершується невдачею з такою помилкою.
java.lang.Виняток: Сертифікат не імпортовано, псевдонім <appsync> вже існує
Ця помилка може з'явитися після виконання наведених нижче команд під час процесу.
C:\EMC\AppSync\jboss\_jre\bin\keytool -importcert -file C:\OpenSSL\cert.pem -keystore C:\EMC\AppSync\jboss\_jre\lib\security\cacerts -storepass changeit -alias appsync noprompt
Cause
Версія OpenSSL, встановлена в оточенні, була 1.0.2j 64 bit.
Проблеми спостерігалися під час імпорту сертифікатів, коли версія openSSL належить до гілки 1.0.2 і старше.
Проблеми спостерігалися під час імпорту сертифікатів, коли версія openSSL належить до гілки 1.0.2 і старше.
Resolution
Оновлення до OpenSSL версії 1.1.0h вирішило цю проблему.
Якщо в майбутньому виникне ця проблема, рекомендується оновитися до останньої доступної версії OpenSSL.
Останні версії OpenSSL доступні для завантаження за адресою https://www.openssl.org/source/
Якщо в майбутньому виникне ця проблема, рекомендується оновитися до останньої доступної версії OpenSSL.
Останні версії OpenSSL доступні для завантаження за адресою https://www.openssl.org/source/
Additional Information
Цей контент перекладено різними мовами:
Щоб отримати додаткові відомості про заміну самопідписаного сертифіката сертифікатом CA, перегляньте Посібник із безпеки та конфігурації AppSync 3.9, сторінка 26, доступний на сторінці підтримки продукту AppSync.
https://support.emc.com/products/25364_AppSync
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/AR-EG_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB533599.pdf |
Щоб отримати додаткові відомості про заміну самопідписаного сертифіката сертифікатом CA, перегляньте Посібник із безпеки та конфігурації AppSync 3.9, сторінка 26, доступний на сторінці підтримки продукту AppSync.
https://support.emc.com/products/25364_AppSync
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000168555
Article Type: Solution
Last Modified: 18 Sep 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.