AppSync: Oracle Database Discovery fails with error ORA-12547: TNS:lost contact

Summary: AppSync discovery of Oracle databases will fail in environments that require the ORACLE_BASE to be added to the Oracle user profile.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Discovering an Oracle database from AppSync for the first time fails with the following errors. 

AppSync Agent Logs:
 
2019-03-26 14:45:05.600 acp.py[115]:main() Command: checkDatabase
2019-03-26 14:45:05.686 oracle.py[4146]:_sqlQuery() SQL*plus > ERROR:
2019-03-26 14:45:05.687 oracle.py[4146]:_sqlQuery() SQL*plus > ORA-12547: TNS:lost contact
2019-03-26 14:45:05.689 oracle.py[4146]:_sqlQuery() SQL*plus > Enter user-name: SP2-0306: Invalid option.
2019-03-26 14:45:05.693 oracle.py[4146]:_sqlQuery() SQL*plus > SP2-0157: unable to CONNECT to ORACLE after 3 attempts, exiting SQL*Plus

Cause

SQL*Plus fails to attach to the Oracle Instance when ORACLE_BASE is not set in the user profile for the Oracle user session invoked by AppSync.
This is only applicable to certain Oracle environments which require ORACLE_BASE to be explicitly set.

Resolution

AppSync Engineering has released a hotfix for this issue on AppSync version 3.8. 

Please open a Service Request with DellEMC Technical Support and quote this article number in order to obtain the hotfix.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000168566
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  3
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