AppSync: L'autenticazione SQL ha esito negativo dopo la modifica delle credenziali di connessione per SQL e dopo aver eseguito correttamente una o poche esecuzioni.

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Symptoms

La password della connessione SQL è stata modificata.
Nell'esempio fornito in questo articolo, la password è stata modificata da 7 caratteri alfanumerici/simbolo a 12. 
In seguito a tale modifica, il piano di assistenza ha funzionato correttamente due volte, ma ha fallito come documentato in questo articolo alla terza esecuzione.

Dopo aver modificato le credenziali per una connessione SQL, un piano di servizio può essere eseguito una o più volte correttamente.
Tuttavia, dopo una o poche esecuzioni riuscite, il piano di assistenza ha esito negativo con quanto segue:

 Gli eventi CSV di AppSync mostrano:
 
2019-10-10 09:52:02.18, Individuazione delle applicazioni, ,GENL_000003,host<> di origine,Impossibile eseguire l'autenticazione utilizzando le credenziali fornite.
 Verificare che le credenziali siano corrette e che l'account disponga dei diritti e dei privilegi richiesti.
 Informazioni aggiuntive: Errore di accesso: nome utente sconosciuto o password non valida.

Il registro del plug-in AppSync dell host di origine mostra:
 
2019-10-10 09:52:05.197 INFO [<sourcehost>] [<numero univoco>] SQL: Connessione al database <DBName.master
> 2019-10-10 09:52:05.197 INFO [<sourcehost>] [<numero> univoco] SQL: rappresentazione <di dominio\utente>
2019-10-10 09:52:05.228 ERRORE [<sourcehost>] [<numero> univoco] SQL: Impossibile eseguire l'autenticazione utilizzando le credenziali fornite. Verificare che le credenziali siano corrette e che dispongano dei diritti e dei privilegi richiesti. Informazioni aggiuntive: Errore di accesso: nome utente sconosciuto o password non valida.

Il registro del server AppSync indica quanto segue:
 
10-10-2019 09:52:00.805 INFO [Thread-3009 /id<>dominio<>Dominio></<>password>< dominio/password<>nome utente><Utente></nome utente/credenziali<>
<>
10-10-2019 09:52:02.180 ERRORE [Thread-3009 (HornetQ-client-global-threads-216778052)] [org.jboss.as.ejb3.invocation] [] [] WFLYEJB0034: La chiamata EJB non è riuscita sul componente SqlServiceBean per il metodo pubblico com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice. <rimosso>... HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException

Nota: La prima o alcune esecuzioni riuscite potrebbe mostrare un numero diverso di asterischi nel registro del server se la nuova password contiene un numero diverso di caratteri alfanumerici/speciali. In questo modo nell'esempio seguente in cui la password è stata modificata da 7 caratteri alfanumerici/speciali a 12.
 
10-10-2019 09:15:05.704 INFO [Thread-2952 /id<>domain>MESSA</<>domain password<>/password<>username>User</username></credentials
<> 

 
Quindi, in una successiva esecuzione non riuscita, notare che la password è più breve:
 
10-10-2019 09:52:00.805 INFO [Thread-3009 /id<>dominio<>Dominio></<>password>< dominio/password<>nome utente><Utente></nome utente/credenziali<>
<>

Cause

Bug software in cui AppSync aggiorna le credenziali utilizzate un secondo momento inappropriato, vale a dire durante l'esecuzione del piano di assistenza.

Resolution

Risoluzione:

esiste un hotfix per risolvere questo problema per AppSync 3.8.

Citare questo articolo quando si invia una Service Request per il problema.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000168662
Article Type: Solution
Last Modified: 19 Aug 2025
Version:  4
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