SourceOne: After upgrade to SNAC 12 or 13, installation fails with a Database Connection Error
Summary: After upgrading to SNAC 12 or 13, SourceOne installations fail with a Database Connection Error
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Symptoms
After upgrading the SQL Server Native Client (SNAC) to version 12 or 13, running a repair or new install of SourceOne software under version 7.2.7 or 7.2.8 fails with the following error:
Activity Database Connection Error
Error(s) occurred when validating the Activity database input:
SSL Security error
ConnectionOpen (SECDoClientHandshake()).
Please verify and re-enter your database information.
Note: for Native Archive installations the error indicates a problem on the Archive Database.
Cause
SourceOne software versions 7.2.7 and 7.2.8 currently do not support the SNAC 12 or 13 versions.
Resolution
Uninstall the unsupported Microsoft Server Native Client (SNAC) client and install a supported version: (Such as SNAC 10.5 or 11) Run the installer again and validate the issue no longer occurs.
If the issue persists the ODBC Connection may still be defined with an incorrect SNAC 12 or 13 version driver. Identify and remove the entry:
- Open the 32-bit ODBC Data Source Administrator (e.g
C:\Windows\SysWOW64\odbcad32.exe) - Click the "
System DSN" tab - Remove any SourceOne data source: (
ES1Activity, ES1Archive, Es1Search) using the unsupported SQL Server Native Client driver. - Rerun the appropriate SourceOne installer or run a repair installation to re-create the ODBC connector.
Affected Products
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000168793
Article Type: Solution
Last Modified: 02 Jul 2025
Version: 3
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