SourceOne: After upgrade to SNAC 12 or 13, installation fails with a Database Connection Error

Summary: After upgrading to SNAC 12 or 13, SourceOne installations fail with a Database Connection Error

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After upgrading the SQL Server Native Client (SNAC) to version 12 or 13, running a repair or new install of SourceOne software under version 7.2.7 or 7.2.8 fails with the following error:
 

Activity Database Connection Error

Error(s) occurred when validating the Activity database input:

SSL Security error

ConnectionOpen (SECDoClientHandshake()).

Please verify and re-enter your database information.

Note: for Native Archive installations the error indicates a problem on the Archive Database.

Cause

SourceOne software versions 7.2.7 and 7.2.8 currently do not support the SNAC 12 or 13 versions. 

Resolution

Uninstall the unsupported Microsoft Server Native Client (SNAC) client and install a supported version: (Such as SNAC 10.5 or 11) Run the installer again and validate the issue no longer occurs.

If the issue persists the ODBC Connection may still be defined with an incorrect SNAC 12 or 13 version driver. Identify and remove the entry:

  1. Open the 32-bit ODBC Data Source Administrator (e.g C:\Windows\SysWOW64\odbcad32.exe)
  2. Click the "System DSN" tab
  3. Remove any SourceOne data source: (ES1Activity, ES1Archive, Es1Search) using the unsupported SQL Server Native Client driver.
  4. Rerun the appropriate SourceOne installer or run a repair installation to re-create the ODBC connector.

Affected Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000168793
Article Type: Solution
Last Modified: 02 Jul 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.