Isilon OneFS 8.0: Bellenim paketi yüklenemiyor: /var/patch/backup: bir dizin değildir

Summary: Bellenim paketi yüklemesi tamamlanmaz.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Bellenim paketi yüklemesi sırasında yükleme tamamlanmaz ve aşağıdaki gibi çıktılar elde edilir:

# isi upgrade patches list

Patch Name                                          Description                                           Status
----------------------------------------------------------------------------------------------------------------------------------
IsiFw_Package_v9.3.5 Package Name  : IsiFw Package v9.3.5 2017-04-04 To... Installing

Durum, süresiz olarak yükleniyor olarak gösterilir.

 

Son birkaç satıra bakın: /var/log/isi_pkg ve aşağıdaki hatayı görmeniz gerekir:

# isi_for_array -s 'tail -50 /var/log/isi_pkg'
.........
2017-05-28T13:31:56-05:00 <3.6> node-1 isi_pkg[16306]: Starting task for request 'INSTALL', task 'INSTALL_INIT', hash '2693c810637d37a02ee9cb57a9d01d3d'
2017-05-28T13:31:59-05:00 <3.6> node-1 isi_pkg[16306]: Running requirements file first for IsiFw_Package_v9.3.5..
2017-05-28T13:31:59-05:00 <3.3> node-1 isi_pkg[16306]: /var/patch/backup: is not a directory.
2017-05-28T13:31:59-05:00 <3.3> node-1 isi_pkg[16306]: install_init: Task encountered unknown failures

 

Bu sorun , IsiFw_Package_v9.3.5.tar veya IsiFw_Package_v10.0.1.tar gibi bellenim paketlerinin herhangi birinde meydana gelebilir.

 

Cause

Bölüme monte edilen /var Bellenim paketi gibi büyük bir yamanın yüklenmesine izin vermek için en az %40 boş disk alanı gerektirir. altında yeterli boş disk alanınız yoksa /var, düğüm şu hatayla yüklemede başarısız olur:

/var/patch/backup: is not a directory

 

Resolution

Şu koşullar altında disk kullanımını azalt: /var. Genellikle /var/log Kesilmesi gerekebilecek büyük dosyaları içeren dizin. Bunu belirlemek için:

  1. Hangi düğümün altında en az %40 (Kapasite %60 veya daha az olmalıdır) boş alana sahip olmadığını belirleyin /var

    # isi_for_array -s 'df -h /var'
  2. SSH'yi altında yeterli boş alana sahip olmayan kök kullanıcı olarak düğüme /var

    # cd /var/log
    # du ./* | sort -n -r | head -n 10
  3. İçinde bir yedekleme dizini oluşturun /ifs/data/Isilon_Support/ Kesilecek dosyaların yedeğini saklamak için:

    # mkdir /ifs/data/Isilon_Support/Node<node number>_VarLog_Backup
  4. Kısalttığınız dosyaları yeni yedekleme dizinine kopyalayın:

    # cp  /ifs/data/Isilon_Support/Node_VarLog_Backup
  5. 2. adımın çıktısı size altındaki en büyük 10 dosyayı verecektir. /var/log. Şu komutu kullanarak dosyaları kısaltabilirsiniz:

    # truncate -s 0 <filename>
  6. Şu bölüm altında disk alanının en az %40'ını (Kapasite %60 veya daha az olmalıdır) boşalttığınızdan emin olmak için bölümü yeniden kontrol edin. /var:

    # isi_for_array -s 'df -h /var'
  7. Yeterli kapasiteyi boşalttıktan sonra şu komutu kullanarak başarısız yükseltmeyi yeniden deneyin:

    # isi upgrade retry-last-action --nodes=<lnn of failed node>
  8. Yükseltme işleminin tamamlanması için 30 dakika bekleyin ve paketin şu durum için Yüklendi olarak gösterildiğinden emin olun:

    # isi upgrade patches list
    Patch Name                                               Description                                           Status
    ------------------------------------------------------------------------------------------------------------------
    IsiFw_Package_v10.0.1 Package Name  : IsiFw Package v10.0.1 2017-05-02 T... Installed

 

Dosyaların güvenli bir şekilde kısaltılıp kısaltılamayacağını bilmiyorsanız veya altında büyük dosya yoksa /var/log ama /var bölüm hala çok dolu veya retry-last-action yama kurulumunu tamamlamıyorsa yardım için Teknik Destek ile iletişime geçin ve referans olarak bu KB ye bakın.

 

Affected Products

Isilon
Article Properties
Article Number: 000170772
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.