{ISILON} OneFS: Intermitterende langsom SMB-godkendelse eller ydeevne til deling isi_cbind_d DNS-forsinkelser
Summary: periodisk forsinket eller ikke-reagerende (timeout) SMB-godkendelse og/eller deling
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Brugere kan opleve periodisk ventetid eller timeouts, når de forsøger at få adgang til delinger, der er gemt på en Isilon-klynge. Adgang genoprettes uden indgriben inden for få sekunder/minutter.
Det kan tage flere gange 5 sekunder (f.eks. 25 sekunder) at gennemføre godkendelse og/eller delingsoptælling, men med jævne mellemrum (præcis ~15 minutter pr. node). En node kan opleve problemet, mens andre ikke gør det. Når du bruger SmartConnect round-robin, kan problemet også forekomme hyppigere, da hver node oplever dette problem uafhængigt af hinanden.
SEDDEL: Denne KB dækker én mulig årsag til langsom SMB-godkendelse og deling optælling; Andre årsager kan eksistere. Henstillingen om løsning her er et middel til at udelukke en sandsynlig årsag
Følgende vises muligvis i de isi_cbind_d logfiler omkring tidspunktet for problemerne:
Hvilket kan findes ved at køre:
Det kan tage flere gange 5 sekunder (f.eks. 25 sekunder) at gennemføre godkendelse og/eller delingsoptælling, men med jævne mellemrum (præcis ~15 minutter pr. node). En node kan opleve problemet, mens andre ikke gør det. Når du bruger SmartConnect round-robin, kan problemet også forekomme hyppigere, da hver node oplever dette problem uafhængigt af hinanden.
SEDDEL: Denne KB dækker én mulig årsag til langsom SMB-godkendelse og deling optælling; Andre årsager kan eksistere. Henstillingen om løsning her er et middel til at udelukke en sandsynlig årsag
Følgende vises muligvis i de isi_cbind_d logfiler omkring tidspunktet for problemerne:
isi_cbind_d[76119]: [0x800703400]bind: CBIND_send_query(1161) Advarsel: Stallset dns har ingen tilgængelige boder
Hvilket kan findes ved at køre:
# isi_for_array 'zegrep Stallset /var/log/isi_cbind_d.log*'
Cause
Som standard udløber vi hvert 15. minut vores AD LDAP DC-forbindelse proaktivt. Udløb af DC-forbindelsen sker på det tidspunkt, hvor forbindelsen bruges (dvs. under godkendelse), hvilket starter processen med:
Den samlede forsinkelse, der tilskrives DNS-opslag, er lig med 5 gange antallet af A-poster, vi skal løse. Hvis antallet af poster overstiger 12 poster, vil dette udløse en 60 sekunders timeout/nulstilling fra klienten, hvilke fejl der vil blive set på klienten i forbindelse med manglende evne til at nå klyngen/dele.
SEDDEL: Den mest almindelige synder i denne situation tilskrives isi_cbind_d DNS-opslag, men kan også være resultatet af andre faktorer
- Lås AD DC-forbindelsesmutex (dette blokerer alle anmodninger, indtil en ny DC er valgt)
- Udløb den eksisterende forbindelse
- Opregne en liste over DC'er, der skal oprettes forbindelse til (DNS SRV-post; _ldap._tcp.dc._msdcs.domain.com)
- Løse DNS-navne til IP-adresse fra listen over DC'er (A-post DNS-opslag)
- Send CLDAP ping til alle DC'er; Vent på hurtigste respondenter (stop afsendelse / modtagelse efter 10 ms fra første svar)
- Vælg intelligent blandt de reagerende DC'er (semi-tilfældig ved hjælp af historisk DC-statistik)
Den samlede forsinkelse, der tilskrives DNS-opslag, er lig med 5 gange antallet af A-poster, vi skal løse. Hvis antallet af poster overstiger 12 poster, vil dette udløse en 60 sekunders timeout/nulstilling fra klienten, hvilke fejl der vil blive set på klienten i forbindelse med manglende evne til at nå klyngen/dele.
SEDDEL: Den mest almindelige synder i denne situation tilskrives isi_cbind_d DNS-opslag, men kan også være resultatet af andre faktorer
Resolution
Under forudsætning af følgende:
Alternativt (hvis du foretrækker at holde DNS-cachen aktiveret), ville en afhjælpning være at genstarte DNS-cachetjenesten på alle noder:
Og kontroller, at den er blevet genstartet på alle noder (baseret på tidsstempel, da processen startede):
Hvis ovenstående ikke løser dit problem, kan der være andre faktorer, der spiller ind, som vil kræve hjælp fra Dell EMC Isilon Support.
OneFS-versionerne 8.0.0.6/8.0.1.3/8.1.0.2/8.1.1.1 indeholder rettelsen (id 205142) til isi_cbind_d, der er en sandsynlig årsag til de DNS-fejl, der er beskrevet i denne KB, og når den er tilgængelig, anbefaler Isilon, at du opgraderer til denne version, hvorefter DNS-cache kan genaktiveres.
Hvis problemet stadig eksisterer efter opgradering til de ovennævnte versioner, eller DNS-cachelagring er indstillet til false på gruppenettet/grupperne, kan det være nødvendigt med yderligere oplysninger og dataindsamling for at fastslå den nøjagtige årsag.
Hvis der er spørgsmål vedrørende dette problem og relaterede stier til løsning, eller hvis der er behov for hjælp, skal du kontakte Isilon Support.
- Problemet afhjælper sig selv uden indblanding fra administratorer
- Forsinkelser rammer 5 sekunders tidsintervaller
- Frekvens pr. node er ~15 minutter
# ISI netværksgruppenet ændrer <groupnet> --dns-cache-enabled = false
Alternativt (hvis du foretrækker at holde DNS-cachen aktiveret), ville en afhjælpning være at genstarte DNS-cachetjenesten på alle noder:
# isi_for_array 'killall -9 isi_cbind_d'
Og kontroller, at den er blevet genstartet på alle noder (baseret på tidsstempel, da processen startede):
# isi_for_array 'ps auxwp 'pgrep isi_cbind_d''
BEMÆRK: Dette skal muligvis gentages, hvis problemet opstår igen i fremtiden, hvorefter manuel indgriben vil være påkrævet for proaktivt at genstarte eller ty til at deaktivere cachen, indtil en opgradering kan administreres (detaljer nedenfor)
Hvis ovenstående ikke løser dit problem, kan der være andre faktorer, der spiller ind, som vil kræve hjælp fra Dell EMC Isilon Support.
OneFS-versionerne 8.0.0.6/8.0.1.3/8.1.0.2/8.1.1.1 indeholder rettelsen (id 205142) til isi_cbind_d, der er en sandsynlig årsag til de DNS-fejl, der er beskrevet i denne KB, og når den er tilgængelig, anbefaler Isilon, at du opgraderer til denne version, hvorefter DNS-cache kan genaktiveres.
Hvis problemet stadig eksisterer efter opgradering til de ovennævnte versioner, eller DNS-cachelagring er indstillet til false på gruppenettet/grupperne, kan det være nødvendigt med yderligere oplysninger og dataindsamling for at fastslå den nøjagtige årsag.
Hvis der er spørgsmål vedrørende dette problem og relaterede stier til løsning, eller hvis der er behov for hjælp, skal du kontakte Isilon Support.
Additional Information
Relateret KB: 502259 (ventetider kan også ses som et resultat af, at det ikke lykkedes at finde en GC; hvilket også kan være modtageligt for det isi_cbind_d-problem, der er beskrevet i denne KB)
Affected Products
PowerScale OneFSProducts
PowerScale OneFSArticle Properties
Article Number: 000170774
Article Type: Solution
Last Modified: 08 Jul 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.