{ISILON} OneFS: Autenticazione SMB lenta e intermittente o prestazioni dell'enumerazione delle condivisioni isi_cbind_d ritardi DNS
Summary: Autenticazione SMB intermittente, ritardata o mancata risposta (timeout) ed enumerazione delle share e dell'autenticazione SMB
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Symptoms
Gli utenti potrebbero riscontrare latenza intermittente o timeout quando tentano di accedere alle condivisioni archiviate in un cluster Isilon. L'accesso viene ripristinato senza alcun intervento in pochi secondi/minuti.
Il completamento dell'autenticazione e/o dell'enumerazione delle condivisioni può richiedere multipli di 5 secondi (ad esempio, 25 secondi), ma a intervalli periodici (~15 minuti per nodo esatto). Un nodo potrebbe riscontrare il problema, mentre altri no. Inoltre, quando si utilizza SmartConnect Round Robin, il problema potrebbe apparire più frequente in quanto ogni nodo riscontra questo problema indipendentemente dagli altri.
NOTA: Questo articolo della KB illustra una possibile causa del rallentamento dell'autenticazione SMB e dell'enumerazione delle share. possono esistere altre cause. La raccomandazione per la risoluzione è un mezzo per escludere una probabile causa
Nei registri isi_cbind_d potrebbero essere visualizzati i seguenti elementi all'incirca al momento in cui si sono verificati i problemi:
Che può essere trovato eseguendo:
Il completamento dell'autenticazione e/o dell'enumerazione delle condivisioni può richiedere multipli di 5 secondi (ad esempio, 25 secondi), ma a intervalli periodici (~15 minuti per nodo esatto). Un nodo potrebbe riscontrare il problema, mentre altri no. Inoltre, quando si utilizza SmartConnect Round Robin, il problema potrebbe apparire più frequente in quanto ogni nodo riscontra questo problema indipendentemente dagli altri.
NOTA: Questo articolo della KB illustra una possibile causa del rallentamento dell'autenticazione SMB e dell'enumerazione delle share. possono esistere altre cause. La raccomandazione per la risoluzione è un mezzo per escludere una probabile causa
Nei registri isi_cbind_d potrebbero essere visualizzati i seguenti elementi all'incirca al momento in cui si sono verificati i problemi:
isi_cbind_d[76119]: [0x800703400]legare: CBIND_send_query(1161) Attenzione: Stallset dns non ha stalli disponibili
Che può essere trovato eseguendo:
# isi_for_array 'zegrep Stallset /var/log/isi_cbind_d.log*'
Cause
Per impostazione predefinita, ogni 15 minuti la connessione al controller di dominio LDAP di Active Directory scadrà in modo proattivo. La scadenza della connessione DC avviene nel momento in cui viene utilizzata la connessione (ad esempio, durante l'autenticazione), avviando il processo di:
Il ritardo totale attribuito alle ricerche DNS è pari a 5 volte il numero di record A da risolvere. Se il numero di record supera i 12 record, si attiverà un timeout/reimpostazione di 60 secondi da parte del client, i cui errori verranno visualizzati sul client in relazione all'impossibilità di raggiungere il cluster/la condivisione.
NOTA: Il colpevole più comune in questa situazione è attribuito a isi_cbind_d ricerche DNS, ma può anche essere il risultato di altri fattori
- Blocco mutex della connessione del controller di dominio AD (blocco di tutte le richieste fino a quando non viene selezionato un nuovo controller di dominio)
- Far scadere la connessione esistente
- Enumerare un elenco di controller di dominio a cui connettersi (record SRV DNS; _ldap._tcp.dc._msdcs.domain.com)
- Risolvere i nomi DNS in indirizzi IP dall'elenco dei controller di dominio (ricerche DNS di record A)
- Inviare il ping CLDAP a tutti i DC; Attendi chi risponde più velocemente (smette di inviare/ricevere dopo 10 ms dalla prima risposta)
- Selezione intelligente dai DC che rispondono (in modo semi-casuale utilizzando le statistiche cronologiche dei DC)
Il ritardo totale attribuito alle ricerche DNS è pari a 5 volte il numero di record A da risolvere. Se il numero di record supera i 12 record, si attiverà un timeout/reimpostazione di 60 secondi da parte del client, i cui errori verranno visualizzati sul client in relazione all'impossibilità di raggiungere il cluster/la condivisione.
NOTA: Il colpevole più comune in questa situazione è attribuito a isi_cbind_d ricerche DNS, ma può anche essere il risultato di altri fattori
Resolution
Supponendo quanto segue:
In alternativa (se si preferisce mantenere abilitata la cache DNS), una mitigazione potrebbe essere il riavvio del servizio di memorizzazione nella cache DNS su tutti i nodi:
Verificare che sia stato riavviato su tutti i nodi (in base al timestamp di quando è stato avviato il processo):
Se quanto sopra non risolve il problema, potrebbero esserci altri fattori in gioco che richiederebbero l'assistenza del supporto Dell EMC Isilon.
Le versioni di OneFS 8.0.0.6/8.0.1.3/8.1.0.2/8.1.1.1 contengono la correzione (ID 205142) per isi_cbind_d che è una probabile causa degli errori DNS descritti in questo articolo della KB e, una volta disponibili, Isilon consiglia di eseguire l'aggiornamento a tale versione nel qual caso è possibile riabilitare la cache DNS.
Se il problema persiste dopo l'aggiornamento alle versioni sopra indicate o se la memorizzazione nella cache DNS è impostata su false sui groupnet, potrebbe essere necessario raccogliere ulteriori dettagli e dati per determinare la causa esatta.
In caso di domande relative a questo problema e ai percorsi di risoluzione correlati, o se è necessaria assistenza, contattare il supporto Isilon.
- Il problema si risolve automaticamente senza alcun intervento da parte degli amministratori
- I ritardi raggiungono incrementi di 5 secondi
- La frequenza per nodo è ~15 minuti
# isi network groupnets modify <groupnet> --dns-cache-enabled=false
In alternativa (se si preferisce mantenere abilitata la cache DNS), una mitigazione potrebbe essere il riavvio del servizio di memorizzazione nella cache DNS su tutti i nodi:
# isi_for_array 'killall -9 isi_cbind_d'
Verificare che sia stato riavviato su tutti i nodi (in base al timestamp di quando è stato avviato il processo):
# isi_for_array 'ps auxwp 'pgrep isi_cbind_d''
NOTA: Potrebbe essere necessario ripetere questa operazione se il problema si ripresenta in futuro, nel qual caso sarà necessario un intervento manuale per riavviare in modo proattivo o ricorrere alla disabilitazione della cache fino a quando non sarà possibile amministrare un aggiornamento (dettagli di seguito)
Se quanto sopra non risolve il problema, potrebbero esserci altri fattori in gioco che richiederebbero l'assistenza del supporto Dell EMC Isilon.
Le versioni di OneFS 8.0.0.6/8.0.1.3/8.1.0.2/8.1.1.1 contengono la correzione (ID 205142) per isi_cbind_d che è una probabile causa degli errori DNS descritti in questo articolo della KB e, una volta disponibili, Isilon consiglia di eseguire l'aggiornamento a tale versione nel qual caso è possibile riabilitare la cache DNS.
Se il problema persiste dopo l'aggiornamento alle versioni sopra indicate o se la memorizzazione nella cache DNS è impostata su false sui groupnet, potrebbe essere necessario raccogliere ulteriori dettagli e dati per determinare la causa esatta.
In caso di domande relative a questo problema e ai percorsi di risoluzione correlati, o se è necessaria assistenza, contattare il supporto Isilon.
Additional Information
KB correlato: 502259 (le latenze possono anche essere viste come il risultato dell'impossibilità di trovare un GC; che potrebbe anche essere suscettibile al problema di isi_cbind_d descritto in questo articolo della KB)
Affected Products
PowerScale OneFSProducts
PowerScale OneFSArticle Properties
Article Number: 000170774
Article Type: Solution
Last Modified: 08 Jul 2025
Version: 4
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