{ISILON} OneFS: Tillfälligt långsam SMB-autentisering eller uppräkningsprestanda för resurs. isi_cbind_d DNS-fördröjningar
Summary: SMB-autentisering och/eller resursuppräkning som tillfälligt fördröjs eller inte svarar (timeout)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Användare kan uppleva tillfälliga svarstider eller tidsgränser när de försöker komma åt resurser som lagras i ett Isilon-kluster. Åtkomsten återställs utan åtgärd inom några sekunder/minuter.
Autentisering och/eller resursuppräkning kan ta multiplar på 5 sekunder (t.ex. 25 sekunder, till exempel) att slutföra, men i periodiska intervall (~15 minuter per nod exakt). En nod kan uppleva problemet, medan andra inte gör det. När du använder SmartConnect resursallokering kan problemet dessutom se mer frekvent ut eftersom varje nod upplever det här problemet oberoende av varandra.
NOT: Den här kunskapsbasartikeln omfattar en möjlig orsak till långsam SMB-autentisering och resursuppräkning. Det kan finnas andra orsaker. Rekommendationen om lösning här är ett sätt att utesluta en sannolik orsak
Följande kan visas i isi_cbind_d-loggarna vid tiden för problemen:
Som du hittar genom att köra:
Autentisering och/eller resursuppräkning kan ta multiplar på 5 sekunder (t.ex. 25 sekunder, till exempel) att slutföra, men i periodiska intervall (~15 minuter per nod exakt). En nod kan uppleva problemet, medan andra inte gör det. När du använder SmartConnect resursallokering kan problemet dessutom se mer frekvent ut eftersom varje nod upplever det här problemet oberoende av varandra.
NOT: Den här kunskapsbasartikeln omfattar en möjlig orsak till långsam SMB-autentisering och resursuppräkning. Det kan finnas andra orsaker. Rekommendationen om lösning här är ett sätt att utesluta en sannolik orsak
Följande kan visas i isi_cbind_d-loggarna vid tiden för problemen:
isi_cbind_d[76119]: [0x800703400]binda: CBIND_send_query(1161) Varning: Stallset dns har inga tillgängliga bås
Som du hittar genom att köra:
# isi_for_array 'zegrep Stallset /var/log/isi_cbind_d.log*'
Cause
Som standard upphör vår AD LDAP DC-anslutning proaktivt att upphöra var 15:e minut. DC-anslutningens utgångsdatum inträffar när anslutningen används (dvs. under autentisering), vilket startar processen för:
Den totala fördröjningen som tillskrivs DNS-sökningar är lika med 5 gånger det antal A-poster som vi behöver lösa. Om antalet poster överskrider 12 poster utlöser detta en tidsgräns på 60 sekunder/återställning från klienten, vilket fel visas på klienten som rör oförmåga att nå klustret/resursen.
NOT: Den vanligaste boven i denna situation tillskrivs isi_cbind_d DNS-sökningar, men kan också vara resultatet av andra faktorer
- Lås AD DC-anslutningens mutex (detta blockerar alla begäranden tills en ny domänkontrollant väljs)
- Avsluta den befintliga anslutningen
- Räkna upp en lista över domänkontrollanter som ska anslutas till (DNS SRV-post; _ldap._tcp.dc._msdcs.domain.com)
- Matcha DNS-namn till IP-adress från listan över domänkontrollanter (DNS-sökningar för A-post)
- Skicka CLDAP-ping till alla domänkontrollanter. Vänta på snabbast svarande (sluta skicka/ta emot efter 10 ms från första svar)
- Välj på ett smart sätt bland de svarande domänkontrollanterna (halvslumpmässigt med historisk DC-statistik)
Den totala fördröjningen som tillskrivs DNS-sökningar är lika med 5 gånger det antal A-poster som vi behöver lösa. Om antalet poster överskrider 12 poster utlöser detta en tidsgräns på 60 sekunder/återställning från klienten, vilket fel visas på klienten som rör oförmåga att nå klustret/resursen.
NOT: Den vanligaste boven i denna situation tillskrivs isi_cbind_d DNS-sökningar, men kan också vara resultatet av andra faktorer
Resolution
Förutsatt följande:
Alternativt (om du föredrar att behålla DNS-cachen aktiverad) är en åtgärd att starta om DNS-cachelagringstjänsten på alla noder:
Kontrollera att den har startats om på alla noder (baserat på tidsstämpeln när processen startade):
Om ovanstående inte löser problemet kan det finnas andra faktorer som spelar in som kräver hjälp av DellEMC Isilon-supporten.
OneFS-versionerna 8.0.0.6/8.0.1.3/8.1.0.2/8.1.1.1 innehåller korrigeringen (ID 205142) för isi_cbind_d som är en trolig orsak till DNS-felen som beskrivs i denna KB, och när den blir tillgänglig rekommenderar Isilon att du uppgraderar till den versionen och då kan DNS-cachen återaktiveras.
Om problemet fortfarande kvarstår efter uppgradering till de ovan nämnda versionerna, eller om DNS-cachelagringen är inställd på false på gruppnätet/grupperna, kan ytterligare information och datainsamling vara nödvändig för att fastställa den exakta orsaken.
Om det finns frågor om det här problemet och relaterade vägar till lösning, eller om du behöver hjälp, kontaktar du Isilon-supporten.
- Problemet åtgärdas av sig själv utan att administratörerna ingriper
- Förseningar nådde 5 sekunders tidsintervall
- Frekvens per nod är ~15 minuter
# ISI Network GroupNets modify <groupnet> --dns-cache-enabled=false
Alternativt (om du föredrar att behålla DNS-cachen aktiverad) är en åtgärd att starta om DNS-cachelagringstjänsten på alla noder:
# isi_for_array "killall -9 isi_cbind_d"
Kontrollera att den har startats om på alla noder (baserat på tidsstämpeln när processen startade):
# isi_for_array 'ps auxwp 'pgrep isi_cbind_d''
Obs! Detta kan behöva upprepas om problemet uppstår igen i framtiden, då manuella åtgärder kommer att krävas för att proaktivt starta om eller tillgripa inaktivering av cacheminnet tills en uppgradering kan administreras (detaljer nedan)
Om ovanstående inte löser problemet kan det finnas andra faktorer som spelar in som kräver hjälp av DellEMC Isilon-supporten.
OneFS-versionerna 8.0.0.6/8.0.1.3/8.1.0.2/8.1.1.1 innehåller korrigeringen (ID 205142) för isi_cbind_d som är en trolig orsak till DNS-felen som beskrivs i denna KB, och när den blir tillgänglig rekommenderar Isilon att du uppgraderar till den versionen och då kan DNS-cachen återaktiveras.
Om problemet fortfarande kvarstår efter uppgradering till de ovan nämnda versionerna, eller om DNS-cachelagringen är inställd på false på gruppnätet/grupperna, kan ytterligare information och datainsamling vara nödvändig för att fastställa den exakta orsaken.
Om det finns frågor om det här problemet och relaterade vägar till lösning, eller om du behöver hjälp, kontaktar du Isilon-supporten.
Additional Information
Relaterad KB: 502259 (svarstider kan också ses som ett resultat av att det inte går att hitta en GC; som också kan vara mottaglig för det isi_cbind_d problemet som beskrivs i denna KB)
Affected Products
PowerScale OneFSProducts
PowerScale OneFSArticle Properties
Article Number: 000170774
Article Type: Solution
Last Modified: 08 Jul 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.