Avamar: MCS flush fails with avtar Error <16507>: Pad: "var/mc/server_data/prefs/sessionticket.srl"

Summary: Avamar: server MCS database flush fails with avtar Error <16507>: Path "var/mc/server_data/prefs/sessionticket.srl": Totaal verwerkte bytes <#> is inconsistent met de oorspronkelijke gegevensgrootte <#> ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De volgende fout kan worden weergegeven wanneer een back-up van de MCS-database plaatsvindt:

avtar Error <16507>: Path "var/mc/server_data/prefs/sessionticket.srl": Totaal verwerkte bytes <#> is inconsistent met oorspronkelijke datagrootte <#>

De daaropvolgende back-ups worden zonder problemen voltooid.

Cause

Deze fout treedt op wanneer sessionticket.srl wordt geschreven naar tijdens de back-up en verandert in grootte.

Resolution

De sessionticket.srl is niet vereist om de MCS te herstellen, dus deze fout kan veilig worden genegeerd.  

Tijdelijke oplossing:
Als u deze fout in de toekomst wilt voorkomen, volgt u de onderstaande tijdelijke oplossing om het bestand mcserver.xml te

wijzigen Voordat u wijzigingen aanbrengt in de mcserver.xml, maakt u er een back-up van:
cd /usr/local/avamar/var/mc/server_data/prefs/
cp -p mcserver.xml x-mcserver.xml.old.'date -I'

Edit /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml and add the following information to the flush_exclude_subdirs line:

,prefs/sessionticket.srl

So the flush_exclude_subdirs line should appear as follows:
value="mcs_data_dump.sql.restore,postgres/data/base,postgres/data/global,postgres/data/pg_clog,postgres/data/pg_xlog,postgres/data/postmaster.pid,flush,postgres/data/pg_log,postgres/data/pg_tblspc,postgres/data/pg_twophase,postgres/data/pg_multixact,postgres/data/pg_subtrans,postgres/data/pg_stat_tmp,prefs/sessionticket.srl" />

Note that the MCS will need to be restarted for these changes to take affect:
 
dpnctl stop mcs
dpnctl start mcs

Once the next backup of the MCS has been completed you can confirm the sessionticket.srl was not backed up by grepping through the flush.log to confirm;

grep sessionticket.srl /usr/local/avamar/var/mc/server_log/flush.log
 
2016-10-26 05:50:10 avtar Info <7838>: - Toevoegende gebruiker sluit "var/mc/server_data/prefs/sessionticket.srl" uit
2016-10-26 05:52:38 avtar Info <5375>:   1 keer voor uitsluitingspatroon "var/mc/server_data/prefs/sessionticket.srl".
2016-10-26 06:50:01 avtar Info <5551>: Opdrachtregel: /usr/local/avamar/bin/avtar.bin --flagfile=/usr/local/avamar/etc/usersettings.cfg --password=**************** --vardir=/usr/local/avamar/var --server=server-internal --id=root --bindir=/usr/local/avamar/bin --vardir=/usr/local/avamar/var --bindir=/usr/local/avamar/bin --sysdir=/usr/local/avamar/etc -c -v --account=/MC_BACKUPS --nocache --senddata --logfile=var/mc/server_log/flush.log --id=root --password=**************** --retention-type=daily, wekelijks,maandelijks,jaarlijks var/mc/server_data/ --exclude=var/mc/server_data/mcs_data_dump.sql.restore --exclude=var/mc/server_data/postgres/data/base --exclude=var/mc/server_data/postgres/data/global --exclude=var/mc/server_data/postgres/data/pg_clog --exclude=var/mc/server_data/postgres/data/pg_xlog --exclude=var/mc/server_data/postgres/data/postmaster.pid --exclude=var/mc/server_data/flush --exclude=var/mc/server_data/postgres/data/pg_log --exclude=var/mc/ server_data/postgres/data/pg_tblspc --exclude=var/mc/server_data/postgres/data/pg_twophase --exclude=var/mc/server_data/postgres/data/pg_multixact --exclude=var/mc/server_data/postgres/data/pg_subtrans --exclude=var/mc/server_data/postgres/data/pg_stat_tmp --exclude=var/mc/server_data/prefs/sessionticket.srl --server=server-internal --hfsport=27000 --conntimeout=120 --vardir=/usr/local/avamar/var

Affected Products

Avamar

Products

Avamar, Avamar Server
Article Properties
Article Number: 000170855
Article Type: Solution
Last Modified: 12 Mar 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.