Cisco: login using sudo causes message from "show system internal kernel memory global detail"

Summary: User login with a sudo account generates a scrolling message

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

User login with a sudo account when collecting  "show system internal kernel memory global detail" results in scrolling  message - 
 

MDS# show system internal kernel memory global detail We trust you have received the usual lecture from the local System Administrator. It usually boils down to these three things: #1) Respect the privacy of others. #2) Think before you type. #3) With great power comes great responsibility. Sorry, try again. Sorry, try again. Sorry, try again. sudo: 3 incorrect password attempts We trust you have received the usual lecture from the local System Administrator. It usually boils down to these three things: #1) Respect the privacy of others. #2) Think before you type. #3) With great power comes great responsibility.

Symptoms: 

symptom 1: NX-OS version is 8.3.2

symptom 2 - Customer logs in using a sudo account.
(sudo is a program for Unix-like computer operating systems that allows users to run programs with the security privileges of another user, by default the superuser.  It originally stood for "superuser do")

symptom 3: command output requests "show system internal kernel memory global detail" (This is contained in a show tech-support details).

Cause

Cisco bug CSCvn95578




Resolution

No fix currently.

Workaround
Log in using admin account - 

MDS# show system internal kernel memory global detail Application usage details: -------------------------- Memory for a process is divided into the stack, heap, I/O etc. as listed below. For each process the size

 The issue is cosmetic but fills the collection file with several thousand lines of unrelated text.

Products

Connectrix MDS-Series Firmware 8.X
Article Properties
Article Number: 000170883
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  4
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