NVP-vProxy:FLR 失敗,並顯示「filesystems:無法將檔案『name-unknown』上傳至 VM」
Summary: 檔案層級還原 (FLR) 無法掛接虛擬機器磁碟 (VMDK),此時出現「filesystems:無法將檔案『name-unknown』上傳至 VM」訊息。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NetWorker VMware Protection (NVP) 解決方案是透過 vProxy 裝置進行設定。虛擬機器 (VM) 的檔案層級還原 (FLR) 無法將 VMDK 掛接在目標虛擬機器上。FLR 掛接工作階段記錄顯示:
YYYY-MM-DD HH:MM:SS INFO: [99] Found virtual machine '[VM_NAME]' with MORef 'vm-####'.
YYYY-MM-DD HH:MM:SS INFO: [99] Adding VMDKs to VM '[VM_NAME]' (vm-####)
YYYY-MM-DD HH:MM:SS INFO: [99] Added VMDKs to VM '[VM_NAME]' (vm-####).
YYYY-MM-DD HH:MM:SS INFO: [99] Mounting disks on VM '[VM_NAME]' (vm-####)
YYYY-MM-DD HH:MM:SS ERROR: [99] Unable to upload file 'name-unknown' to VM '[VM_NAME]' (vm-####): Command 'C:\Program Files (x86)\EMC\vProxy FLR Agent\bin\vflragentc.exe' terminated with exit code 2.
YYYY-MM-DD HH:MM:SS INFO: [99] Unmounting after mount failure: Could not mount VMDKs onto VM '[VM_NAME]' (vm-####) filesystems: Unable to upload file 'name-unknown' to VM '[VM_NAME]' (vm-####): Command 'C:\Program Files (x86)\EMC\vProxy FLR Agent\bin\vflragentc.exe' terminated with exit code 2.
在目標虛擬機器上,
C:\Program Files (x86)\EMC\vProxy FLR Agent\logs\vflragentd\vflragentd.log 顯示:
YYYY/MM/DD HH:MM:SS Recover agent Upgrade
YYYY/MM/DD HH:MM:SS Starting [C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\vflragentd-upgrade-2012.exe C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\emc-vProxy-FLRAgent.msi C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\vflragentd-upgrade-2012.exe.out]
YYYY/MM/DD HH:MM:SS [PID 5356] Performing FLR Agent upgrade (C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\emc-vProxy-FLRAgent.msi C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\vflragentd-upgrade-2012.exe.out)
YYYY/MM/DD HH:MM:SS Running [msiexec.exe /fvomus C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\emc-vProxy-FLRAgent.msi /Lweamruc! C:\Program Files (x86)\EMC\vProxy FLR Agent\logs\upgrade.log]
YYYY/MM/DD HH:MM:SS =====Output from agent upgrade:
YYYY/MM/DD HH:MM:SS Command execution error: exit status 1603
=== Logging started: MM/DD/YYYY HH:MM:SS ===
Error 1316. The specified account already exists.
=== Logging stopped: MM/DD/YYYY HH:MM:SS ===
YYYY/MM/DD HH:MM:SS =====End of output
YYYY/MM/DD HH:MM:SS [PID 5356] FLR Agent upgrade processing completed.
YYYY/MM/DD HH:MM:SS 'C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\vflragentd-upgrade-2012.exe' finished with error: <nil>
在目標虛擬機器上,
C:\Program Files (x86)\EMC\vProxy FLR Agent\logs\vflragentd\vflragentd-upgrade-####.exe.out 和 upgrade.log 示:
=== Logging started: MM/DD/YYYY HH:MM:SS ===
Error 1316. The specified account already exists.
=== Logging stopped: MM/DD/YYYY HH:MM:SS ===
Cause
vProxy 已升級,且目標 VM 上的 Dell FLR 代理程式升級失敗。Dell FLR 代理程式升級失敗的原因不得而知。
Microsoft Windows 安裝程式 (msiexec.exe) 無法執行 Dell FLR 代理程式升級,並產生 Windows 結束狀態 1603 (安裝期間發生嚴重錯誤)。Dell FLR 代理程式輸出檔案指出嚴重錯誤與 Windows 結束狀態 1316 (指定的帳戶已存在) 有關。
Resolution
因應措施:
登入目標虛擬機器,然後手動解除安裝 Dell FLR 代理程式。後續的 FLR 會執行全新的 Dell FLR 代理程式安裝。
下列知識文章詳細說明如何在虛擬機器上手動安裝 FLR 代理程式。
Additional Information
本內容以 15 種語言翻譯:
| https://downloads.dell.com/TranslatedPDF/CS_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/DA_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/FI_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/NO-NO_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/PL_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/TR_KB540824.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB540824.pdf |
Products
NetWorkerArticle Properties
Article Number: 000170937
Article Type: Solution
Last Modified: 04 Nov 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.