NVP-vProxy:FLR 失败并显示“filesystems:无法将文件“name-unknown”上传到虚拟机”

Summary: 文件级还原 (FLR) 无法使用“filesystems:无法将文件“name-unknown”上传到虚拟机“消息。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker VMware Protection (NVP) 解决方案已通过 vProxy 设备进行配置。虚拟机 (VM) 的文件级还原 (FLR) 无法在目标虚拟机上装载 VMDK。FLR 装载会话日志显示:

YYYY-MM-DD HH:MM:SS INFO:   [99] Found virtual machine '[VM_NAME]' with MORef 'vm-####'.
YYYY-MM-DD HH:MM:SS INFO:   [99] Adding VMDKs to VM '[VM_NAME]' (vm-####)
YYYY-MM-DD HH:MM:SS INFO:   [99] Added VMDKs to VM '[VM_NAME]' (vm-####).
YYYY-MM-DD HH:MM:SS INFO:   [99] Mounting disks on VM '[VM_NAME]' (vm-####)
YYYY-MM-DD HH:MM:SS ERROR:  [99] Unable to upload file 'name-unknown' to VM '[VM_NAME]' (vm-####): Command 'C:\Program Files (x86)\EMC\vProxy FLR Agent\bin\vflragentc.exe' terminated with exit code 2.
YYYY-MM-DD HH:MM:SS INFO:   [99] Unmounting after mount failure: Could not mount VMDKs onto VM '[VM_NAME]' (vm-####) filesystems: Unable to upload file 'name-unknown' to VM '[VM_NAME]' (vm-####): Command 'C:\Program Files (x86)\EMC\vProxy FLR Agent\bin\vflragentc.exe' terminated with exit code 2.
在目标虚拟机上, C:\Program Files (x86)\EMC\vProxy FLR Agent\logs\vflragentd\vflragentd.log 显示:
YYYY/MM/DD HH:MM:SS Recover agent Upgrade
YYYY/MM/DD HH:MM:SS Starting [C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\vflragentd-upgrade-2012.exe C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\emc-vProxy-FLRAgent.msi C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\vflragentd-upgrade-2012.exe.out]
YYYY/MM/DD HH:MM:SS [PID 5356] Performing FLR Agent upgrade (C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\emc-vProxy-FLRAgent.msi C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\vflragentd-upgrade-2012.exe.out)
YYYY/MM/DD HH:MM:SS Running [msiexec.exe /fvomus C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\emc-vProxy-FLRAgent.msi /Lweamruc! C:\Program Files (x86)\EMC\vProxy FLR Agent\logs\upgrade.log]
YYYY/MM/DD HH:MM:SS =====Output from agent upgrade:
YYYY/MM/DD HH:MM:SS Command execution error: exit status 1603
=== Logging started: MM/DD/YYYY HH:MM:SS ===
Error 1316. The specified account already exists.
=== Logging stopped: MM/DD/YYYY HH:MM:SS ===
YYYY/MM/DD HH:MM:SS =====End of output
YYYY/MM/DD HH:MM:SS [PID 5356] FLR Agent upgrade processing completed.
YYYY/MM/DD HH:MM:SS 'C:\Program Files (x86)\EMC\vProxy FLR Agent\tmp\vflragentd-upgrade-2012.exe' finished with error: <nil>

在目标虚拟机上, C:\Program Files (x86)\EMC\vProxy FLR Agent\logs\vflragentd\vflragentd-upgrade-####.exe.outupgrade.log 显示:
=== Logging started: MM/DD/YYYY HH:MM:SS ===
Error 1316. The specified account already exists.
=== Logging stopped: MM/DD/YYYY HH:MM:SS ===

Cause

vProxy 已升级,目标虚拟机上的 Dell FLR Agent 升级失败。Dell FLR Agent 升级失败的原因未知。

Microsoft Windows 安装程序 (msiexec.exe) 无法运行 Dell FLR Agent 升级,并生成 Windows 退出状态 1603(安装过程中出现致命错误)。Dell FLR Agent 输出文件指示致命错误与 Windows 退出状态 1316 相关(指定的帐户已存在)。

Resolution

解决方法:
登录到目标虚拟机并手动卸载 Dell FLR Agent。后续 FLR 将执行全新的 Dell FLR Agent 安装。

以下知识库文章详细介绍了如何在虚拟机上手动安装 FLR Agent。

Additional Information

此内容以 15 种语言进行翻译: 
https://downloads.dell.com/TranslatedPDF/CS_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/DA_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/FI_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/NO-NO_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/PL_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/TR_KB540824.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB540824.pdf

Products

NetWorker
Article Properties
Article Number: 000170937
Article Type: Solution
Last Modified: 04 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.