PowerPath 6.0へのアップグレード後にディスクがオフラインとしてマークされる

Summary: PowerPath 6.0にアップグレードした後、ディスクがオフラインとしてマークされます。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerPath 6.0にアップグレードした後、一部のディスクがオフラインとしてマークされます。

Cause

ディスクをオンラインまたはオフラインにするのはWindowsの機能であり、PowerPathではありません。

Resolution

オフラインの問題を回避するには、次の手順を実行する必要があります。
san policy=onlineall

Dell PowerPathおよびPowerPath/VE Family for Windowsバージョン6.0リリース ノート では、PowerPathの制限事項として、ディスクのオンラインまたはオフライン動作について説明しています。  

Windows Server 2008以降では、ディスクをホストに初めて追加したときにオフラインとしてマークされます。
これらのオフライン ディスクを使用する前に、ユーザーが手動で有効にする必要があります。
この問題を回避するには、diskpartで次のコマンド「san policy=onlineall」を実行します。
このコマンドは、新しいSANドライブをオンラインのままにするようにシステムを構成します。

Windows Server 2008以降およびWindows Server 2008 R2では、デフォルトのSANポリシーはOfflineSharedです。
ディスクをオンライン/オフラインにするのはWindowsの機能であるため、上記の制限は混乱を招きます。

要約すると、物理ディスクが追加され、ホスト側からスキャンされ、PowerPathがそれを制御した後、疑似デバイスがオフラインとして表示されるか、オフラインになります(既存のオンライン ディスクはオンラインになります)。

Additional Information

  • SANポリシーの変更
DISKPART> san
SAN Policy : Offline Shared

Change it using..

DISKPART> san policy=OnlineAll

DiskPart successfully changed the SAN policy for the current operating system.

then list the disks using..

DISKPART> LIST DISK

if any disk shows Offline, select that disk and clear the attributes.

DISKPART> select disk Disk#

Disk# is now the selected disk.

DISKPART> ATTRIBUTES DISK CLEAR READONLY

Disk attributes cleared successfully.

DISKPART> attributes disk
Current Read-only State : No
Read-only : No
Boot Disk : No
Pagefile Disk : No
Hibernation File Disk : No
Crashdump Disk : No
Clustered Disk : No

DISKPART> ONLINE DISK

DiskPart successfully onlined the selected disk.
  • ディスク管理を使用してディスク ステータスをオンラインに変更する。
POLICY=OnlineAllを使用してこの問題を回避することができますが、ディスクがサーバー間で共有されている場合、データが破損する可能性があることを明確にする必要があります。ユーザーは、適切なSANポリシーを使用してデータを保護することをお勧めします。
Article Properties
Article Number: 000171325
Article Type: Solution
Last Modified: 11 Mar 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.