IDPA ESXi-upgrade kan niet worden uitgevoerd en toont de foutmelding "[DependencyError]rn File path of '/opt/lsi/perccli/libstorelib.so' is claimed by multiple non-overlay VIBs"
Summary: Dit KB-artikel helpt u bij het oplossen van een probleem dat zich voordeed tijdens een IDPA-upgrade waarbij de ESXi-upgrade mislukt vanwege een afhankelijkheidsfout.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
De volgende fout kan worden waargenomen in het ESXi-upgradelogboek op ACM onder het pad "/data01/tmp/patch/logs" :
6/03/20 17:23:16 main() Package name: IDPA-13G-ESXi-6.5.0-002
26/03/20 17:23:16 main() Executing install packages command: esxcli software profile update --depot=https://192.168.100.100:9443/dataprotection-upgrade/esxi_upgrade --profile=IDPA-13G-ESXi-6.5.0-002
26/03/20 17:23:19 run() Parsing returnCode, output: ['', "[DependencyError]\r\n File path of '/opt/lsi/perccli/libstorelib.so' is claimed by multiple non-overlay VIBs: set(['LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01', 'LSI_bootbank_perccli_007.0127.0000.0000-2'])\r\n File path of '/opt/lsi/perccli/perccli' is claimed by multiple non-overlay VIBs: set(['LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01', 'LSI_bootbank_perccli_007.0127.0000.0000-2'])\r\n Please refer to the log file for more details.", 'Status: 1']
26/03/20 17:23:19 run_cmd_esxi() Command: esxcli software profile update --depot=https://192.168.100.100:9443/dataprotection-upgrade/esxi_upgrade --profile=IDPA-13G-ESXi-6.5.0-002
26/03/20 17:23:19 run_cmd_esxi() [DependencyError]
26/03/20 17:23:19 run_cmd_esxi() File path of '/opt/lsi/perccli/libstorelib.so' is claimed by multiple non-overlay VIBs: set(['LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01', 'LSI_bootbank_perccli_007.0127.0000.0000-2'])
26/03/20 17:23:19 run_cmd_esxi() File path of '/opt/lsi/perccli/perccli' is claimed by multiple non-overlay VIBs: set(['LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01', 'LSI_bootbank_perccli_007.0127.0000.0000-2'])
26/03/20 17:23:19 run_cmd_esxi() Please refer to the log file for more details.
26/03/20 17:23:19 run_cmd_esxi() Status: 1
26/03/20 17:23:19 main() Install packages command result: 1
26/03/20 17:23:19 main() Failed to install packages.
Cause
'vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01' VIB die op de ESXi-host is geïnstalleerd, veroorzaakt dit probleem
Resolution
Stap 1. Maak een SSH-verbinding met de betreffende ESXi-host.
Stap 2. Voer de volgende opdracht uit om de conflicterende VIB te verwijderen:
[root@esx1:~] esxcli software vib remove --vibname vmware-perccli-007.0529.0000.0000
Removal Result
Message: Operation finished successfully.
Reboot Required: false
VIBs Installed:
VIBs Removed: LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01
VIBs Skipped:
Stap 3. Controleer of de VIB is verwijderd:
Stap 4. Probeer de ESXi-upgrade uit te voeren vanuit de ACM-gebruikersinterface.
Stap 2. Voer de volgende opdracht uit om de conflicterende VIB te verwijderen:
- esxcli software vib remove --vibname vmware-perccli-007.0529.0000.0000
[root@esx1:~] esxcli software vib remove --vibname vmware-perccli-007.0529.0000.0000
Removal Result
Message: Operation finished successfully.
Reboot Required: false
VIBs Installed:
VIBs Removed: LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01
VIBs Skipped:
Stap 3. Controleer of de VIB is verwijderd:
- esxcli software vib list| grep -i perccli
Stap 4. Probeer de ESXi-upgrade uit te voeren vanuit de ACM-gebruikersinterface.
Affected Products
Integrated Data Protection Appliance FamilyProducts
PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware
, Integrated Data Protection Appliance Software
...
Article Properties
Article Number: 000173292
Article Type: Solution
Last Modified: 27 May 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.