RecoverPoint for Vms : La mise à niveau vers la version 5.3 peut échouer à 11-12 avec l’erreur interne « Certificats incorrects »
Summary: La mise à niveau vers RecoverPoint for VMs 5.3 échoue, clusterLogic et/ou les logs d’installation affichent des « Certificats incorrects »
Symptoms
Mise à niveau de RecoverPoint for VMs vers la version 5.3.x
La mise à niveau de RecoverPoint for VMs échoue à 11/12 % lors de la configuration du référentiel sur RPA1.
L’erreurinterne (/home/kos/RPServers/RPServers_logs/clusterLogic/clusterLogic.log) s’affiche :
2020/09/02 20:26:31.440 [pool-3-thread-1] (Task.java:111) DEBUG - GetRecentOperationsTask: task: Getting recent operations.old status is: RUNNING, setting status to SUCCESS. 2020/09/02 20:26:31.440 [pool-3-thread-1] (Task.java:98) ERROR - UpgradeClusterRestorableTask :Task failed: Executing NDU. com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume. at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91) at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.attemptToCompletePhase(RestorableSerialTask.java:94) at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.perform(RestorableSerialTask.java:63) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.call(Task.java:142) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748) Caused by: com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume. Caused by: com.emc.recoverpoint.cluster_logic.inner_model.exception.RpaAdapterException: Operation failed. Failed to verify certificates: Wrong Certificates 2020/08/31 18:43:06.334 [pool-3-thread-1] (BaseInstallationServerAdapter.java:317) ERROR - Transaction failed. transactionId=16, timeoutInSeconds=300, errorMSG=Operation failed. Failed to verify certificates: Wrong Certificates, errorType=OPERATION_FAILED, value=null 2020/08/31 18:43:06.335 [pool-3-thread-1] (BaseRpaCall.java:52) ERROR - ConfigureRepositoryVolumeCall failed. java.lang.RuntimeException: Operation failed. Failed to verify certificates: Wrong Certificates
Cause
Le certificat vCenter (VC) a été mis à jour, mais les informations d’identification VC n’ont pas été mises à jour dans le cluster RP. RPA valide le certificat VC lors des mises à niveau pour s’assurer qu’il se connecte au même VC.
Resolution
Solution de contournement préventive :
mettez à jour l’enregistrement VC dans RecoverPoint for VMs avant la mise à niveau
Vous pouvez utiliser le plugin ou la commande CLI « update_vcenter_server_registration -f »
1. Connectez-vous à RPA via SSH ou la console via les informations d’identification d’administrateur
2. Sélectionnez l’option #6 pour ouvrir admin CLI
3. Exécutez la commande update_vcenter_server_registration -f
4. Suivez les instructions
de commande interactives 5. Mettez à jour le certificat
vCenter 6. Suivez le processus de mise à niveau une fois le certificat mis à jour.
Remarque : Reportez-vous à la page 130 du guide
de référence de l’interface de lignede commande Solution de contournement :
une solution existe pour résoudre ce problème, mais l’intervention du personnel du support technique Dell EMC est requise. L’ingénieur du support devra vérifier le problème et exécuter une procédure pour revenir à la version précédente, mettre à jour les certificats et redémarrer la mise à niveau. Contactez le Centre de support client Dell EMC ou votre responsable de compte pour obtenir une assistance technique et indiquer cet ID de solution de la base de connaissances Dell EMC.
Résolution :
les ingénieurs Dell EMC examinent actuellement ce problème. Un correctif permanent est encore en cours d’exécution. Contactez le Centre de support client Dell EMC ou votre responsable de services pour obtenir de l’aide et consultez l’ID de cette solution.