RecoverPoint for VMs: Das Upgrade auf 5.3 schlägt möglicherweise bei 11-12 mit dem internen Fehler "Wrong Certificates" fehl.
Summary: Upgrade auf RecoverPoint for VMs 5.3 schlägt fehl, ClusterLogic und/oder Installationsprotokolle zeigen "falsche Zertifikate" an
Symptoms
Upgrade von RecoverPoint for VMs auf Version 5.3.x
Das Upgrade von RecoverPoint for VMs schlägt während der Repository-Konfiguration auf RPA1 bei 11/12 % fehl.
Der interne Fehler(/home/kos/RPServers/RPServers_logs/clusterLogic/clusterLogic.log) zeigt Folgendes an:
2020/09/02 20:26:31.440 [pool-3-thread-1] (Task.java:111) DEBUG - GetRecentOperationsTask: task: Getting recent operations.old status is: RUNNING, setting status to SUCCESS. 2020/09/02 20:26:31.440 [pool-3-thread-1] (Task.java:98) ERROR - UpgradeClusterRestorableTask :Task failed: Executing NDU. com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume. at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91) at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.attemptToCompletePhase(RestorableSerialTask.java:94) at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.perform(RestorableSerialTask.java:63) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.call(Task.java:142) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748) Caused by: com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume. Caused by: com.emc.recoverpoint.cluster_logic.inner_model.exception.RpaAdapterException: Operation failed. Failed to verify certificates: Wrong Certificates 2020/08/31 18:43:06.334 [pool-3-thread-1] (BaseInstallationServerAdapter.java:317) ERROR - Transaction failed. transactionId=16, timeoutInSeconds=300, errorMSG=Operation failed. Failed to verify certificates: Wrong Certificates, errorType=OPERATION_FAILED, value=null 2020/08/31 18:43:06.335 [pool-3-thread-1] (BaseRpaCall.java:52) ERROR - ConfigureRepositoryVolumeCall failed. java.lang.RuntimeException: Operation failed. Failed to verify certificates: Wrong Certificates
Cause
Das vCenter (VC)-Zertifikat wurde aktualisiert, aber die VC-Zugangsdaten wurden im RP-Cluster nicht aktualisiert. RPA validiert das VC-Zertifikat während Upgrades, um sicherzustellen, dass es eine Verbindung mit demselben VC herstellt.
Resolution
Vorbeugende Problemumgehung:
Aktualisieren der VC-Registrierung in RecoverPoint for VMs vor dem Upgrade
Sie können den Plug-in- oder CLI-Befehl "update_vcenter_server_registration -f" verwenden
1. Melden Sie sich über SSH oder die Konsole über Administratorzugangsdaten
bei RPA an. 2. Wählen Sie Option #6 aus, um die Admin-CLI
3 zu öffnen. Führen Sie den Befehl update_vcenter_server_registration -f
4 aus. Befolgen Sie die interaktive Befehlsanweisung
5. Aktualisieren Sie das vCenter-Zertifikat
6. Folgen Sie dem Upgrade-Prozess, sobald das Zertifikat aktualisiert wurde.
Hinweis: Weitere Informationen finden Sie auf Seite 130 im CLI-Referenzhandbuch
Workaround:Es gibt eine Lösung für dieses Problem,
aber es ist ein Eingreifen von Mitarbeitern des technischen Supports von Dell EMC erforderlich. Der Supporttechniker muss das Problem überprüfen und ein Verfahren ausführen, um zur vorherigen Version zurückzukehren, Zertifikate zu aktualisieren und das Upgrade neu zu starten. Wenden Sie sich an das Dell EMC Customer Support Center oder Ihren Servicemitarbeiter, um technische Unterstützung zu erhalten, und verweisen Sie auf diese Lösungs-ID der Dell EMC Wissensdatenbank.
Lösung:
Dell EMC Engineering untersucht derzeit dieses Problem. Es wird noch an einer dauerhaften Lösung gearbeitet. Wenden Sie sich an das Dell EMC Kundensupportcenter oder Ihren Servicemitarbeiter, um Unterstützung zu erhalten und geben Sie die Lösungs-ID an.