RecoverPoint for VMs: Aktualizacja do wersji 5.3 może zakończyć się niepowodzeniem o 12:11 z wewnętrznym błędem "Wrong Certificates"
Summary: Aktualizacja do RecoverPoint dla maszyn wirtualnych 5.3 kończy się niepowodzeniem, w dziennikach klastra Logic i/lub instalacji są wyświetlane "Nieprawidłowe certyfikaty"
Symptoms
Aktualizacja RecoverPoint dla maszyn wirtualnych do wersji 5.3.x
Aktualizacja RecoverPoint dla maszyn wirtualnych kończy się niepowodzeniem na poziomie 11/12% podczas konfiguracji repozytorium na RPA1.
Błądwewnętrzny (/home/kos/RPServers/RPServers_logs/clusterLogic/clusterLogic.log) pokazuje:
2020/09/02 20:26:31.440 [pool-3-thread-1] (Task.java:111) DEBUG - GetRecentOperationsTask: task: Getting recent operations.old status is: RUNNING, setting status to SUCCESS. 2020/09/02 20:26:31.440 [pool-3-thread-1] (Task.java:98) ERROR - UpgradeClusterRestorableTask :Task failed: Executing NDU. com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume. at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91) at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.attemptToCompletePhase(RestorableSerialTask.java:94) at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.perform(RestorableSerialTask.java:63) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91) at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.call(Task.java:142) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748) Caused by: com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume. Caused by: com.emc.recoverpoint.cluster_logic.inner_model.exception.RpaAdapterException: Operation failed. Failed to verify certificates: Wrong Certificates 2020/08/31 18:43:06.334 [pool-3-thread-1] (BaseInstallationServerAdapter.java:317) ERROR - Transaction failed. transactionId=16, timeoutInSeconds=300, errorMSG=Operation failed. Failed to verify certificates: Wrong Certificates, errorType=OPERATION_FAILED, value=null 2020/08/31 18:43:06.335 [pool-3-thread-1] (BaseRpaCall.java:52) ERROR - ConfigureRepositoryVolumeCall failed. java.lang.RuntimeException: Operation failed. Failed to verify certificates: Wrong Certificates
Cause
Certyfikat vCenter (VC) został zaktualizowany, ale poświadczenia VC nie zostały zaktualizowane w klastrze RP. RPA sprawdza poprawność certyfikatu VC podczas aktualizacji, aby upewnić się, że łączy się z tym samym VC.
Resolution
Obejście zapobiegawcze:
zaktualizuj rejestrację VC w RecoverPoint dla maszyn wirtualnych przed uaktualnieniem
Możesz użyć wtyczki lub polecenia CLI "update_vcenter_server_registration -f"
1. Zaloguj się do RPA przez SSH lub konsoli za pomocą poświadczeń administratora
2. Wybierz opcję #6, aby otworzyć interfejs wiersza poleceń
administratora 3. Uruchom polecenie update_vcenter_server_registration -f
4. Postępuj zgodnie z interaktywnymi instrukcjami
poleceń 5. Zaktualizuj certyfikat
vCenter 6. Po zaktualizowaniu certyfikatu postępuj zgodnie z procesem uaktualniania
Uwaga: Patrz strona 130 podręcznika informacyjnego
CLI Obejście problemu: rozwiązanie tego problemu istnieje,
ale wymagana jest interwencja personelu pomocy technicznej firmy Dell EMC. Inżynier pomocy technicznej musi zweryfikować problem i uruchomić procedurę powrotu do poprzedniej wersji, zaktualizować certyfikaty i ponownie uruchomić uaktualnienie. Skontaktuj się z pomocą techniczną Dell EMC lub przedstawicielem działu obsługi klienta, aby uzyskać pomoc techniczną i odwołaj się do tego identyfikatora rozwiązania bazy wiedzy Dell EMC.
Rozwiązanie:
Inżynierowie firmy Dell EMC obecnie badają ten problem. Prace nad trwałym rozwiązaniem są w toku. Skontaktuj się z pomocą techniczną Dell EMC lub przedstawicielem działu obsługi klienta, aby uzyskać pomoc i zapoznać się z identyfikatorem tego rozwiązania.