NetWorker:NWUIがグループのリストを取得できず、disk_uuid文字列を解析できません
Summary: NetWorker Webユーザー インターフェイス(NWUI)のグループ ページが情報を返しません。グループのリストを取得できなかったことを示すエラーが表示されます。'disk_uuid'文字列を解析できません。
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Symptoms
NWUIソリューションは、NetWorkerデータ ゾーンの管理に使用されています。ナビゲーション パネルで[Protection>Groups]を選択すると、詳細ペインに「Failed to get the list of groups. Unable to parse 'disk_uuid' string: '50301dd2-9032-1b04-eca2-c943c61fd55d.'VMware保護グループは、タグを使用して保護された仮想マシン(VM)を選択するルールで構成されており、参照されるVMにはディスク除外があります。
図1: NWUIグループのロードに失敗し、「disk_uuid文字列を解析できません」が表示されます
nwui.rawには次の情報が表示されます。
HH:MM:SS [https-jsse-nio-9090-exec-8] ERROR c.e.n.c.n.impl.PolicyApi - Could not fetch the list of groups.
- Linuxの場合
/opt/nwui/logs/nwui.raw - Windowsの場合:
C:\Program Files\EMC NetWorker\nwui\logs\nwui.raw - NetWorker:nsr_render_logの使用方法(英語)」を参照してください。
localhost_access*.txtファイルには、次の情報が表示されます。
XXX.XXX.XXX.XXX - - [DD/MM/YYYY:HH:MM:SS -0500] "GET /nwrestapi/v3/global/protectiongroups HTTP/1.1" 500 487
- Linuxの場合
/nsr/authc/logs/localhost_access*.txt - Windowsの場合:
C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\localhost_access*.txt
NetWorkerサーバー restapi.logには、次の情報が表示されます。
YYYY-MM-DD HH:MM:SS INFO [https-jsse-nio-9090-exec-2] c.e.n.w.WebApiRequest - Request method 'GET', URL 'v3/global/protectiongroups
YYYY-MM-DD HH:MM:SS ERROR [https-jsse-nio-9090-exec-2] c.e.n.w.WebApiExceptionMapper - Status 'Internal Server Error', msg: Unable to parse 'disk_uuid' string: '50301dd2-9032-1b04-eca2-c943c61fd55d,'
com.emc.nw.webapi.exception.InternalServerErrorException: Unable to parse 'disk_uuid' string: '50301dd2-9032-1b04-eca2-c943c61fd55d,'
at com.emc.nw.webapi.adapter.VMwareVmDataAdapter.convertJsonToXmlVmWorkItem(VMwareVmDataAdapter.java:639) ~[nwrestapi.jar:na]
at com.emc.nw.webapi.adapter.ProtectionGroupDataAdapter.expandVMwareAllWorkItemSelection(ProtectionGroupDataAdapter.java:137) ~[nwrestapi.jar:na]
at com.emc.nw.webapi.adapter.ProtectionGroupDataAdapter.getItems(ProtectionGroupDataAdapter.java:115) ~[nwrestapi.jar:na]
at com.emc.nw.webapi.common.WebLogic.getItemList(WebLogic.java:173) ~[nwrestapi.jar:na]
at com.emc.nw.webapi.common.WebLogic.getItemList(WebLogic.java:160) ~[nwrestapi.jar:na]
at com.emc.nw.webapi.resource.ProtectionGroups.get(ProtectionGroups.java:101) ~[nwrestapi.jar:na]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.8.0_211]
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[na:1.8.0_211]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[na:1.8.0_211]
at java.lang.reflect.Method.invoke(Unknown Source) ~[na:1.8.0_211]
...
YYYY-MM-DD HH:MM:SS INFO [https-jsse-nio-9090-exec-2] c.e.n.w.WebApiResponse - Response status Method: 'GET', URI:'v3/global/protectiongroups', Status '500'
- Linuxの場合
/nsr/logs/restapi/restapi.log - Windowsの場合:
C:\Program Files\EMC NetWorker\nsr\logs\restapi\restapi.log
Cause
VMware保護グループに、除外された.vmdkディスクのVM nullエントリーがある。NULLの.vmdkディスク エントリーが原因で、保護グループ情報の取得時に RESTAPI が失敗します。VMware保護グループ リソースのnullエントリーは、バックスペースと引用符(\"\")として表示されます。VMware保護グループのnullエントリーの例を次に示します。
{\"moref-id\":\"vm-1024536\",\"uuid\":\"50301dd2-9032-1b04-eca2-c943c61fd55d\",\"type\":\"VMDisk\",\"disks\":[\"\",\"6000C292-524d-1baa-f10b-5e780833a1ed\",\"6000C29c-75b5-ad1f-27d3-602b6d5da260\"]}
null エントリの原因は不明です。
Resolution
NetWorker管理プログラム(nsradmin)を使用して、nullの.vmdkディスク エントリーをNetWorkerリソース データベース(nsrdb)から削除します。
- サーバー保護バックアップ ジョブを実行し、ブートストラップ バックアップが取得されていることを確認します。
mminfo -B
- NetWorkerサーバー上にnsrdb ディレクトリーのコピーを作成します。
- Linuxの場合
/nsr/res/nsrdb - Windowsの場合:
C:\Program Files\EMC NetWorker\nsr\res\nsrdb
3.コマンド ラインまたはLinuxシェルからnsradminコマンド ライン ユーティリティを開き、次のように入力してビジュアル モードにアクセスします visualの詳細を確認してください。これにより、対話形式のコマンド ライン ユーティリティーがロードされ、NetWorkerリソースを移動して変更できます。
nsradmin > visual mode > NSR Protection Group > Select the "NSR Protection Group" > Edit > delete the NULL Disk entry in the "vproxy group exclude items" > save > Exit
処理前:
{\"moref-id\":\"vm-1024536\",\"uuid\":\"50301dd2-9032-1b04-eca2-c943c61fd55d\",\"type\":\"VMDisk\",\"disks\":[\"\",\"6000C292-524d-1baa-f10b-5e780833a1ed\",\"6000C29c-75b5-ad1f-27d3-602b6d5da260\"]}
処理後:
{\"moref-id\":\"vm-1024536\",\"uuid\":\"50301dd2-9032-1b04-eca2-c943c61fd55d\",\"type\":\"VMDisk\",\"disks\":[\"6000C292-524d-1baa-f10b-5e780833a1ed\",\"6000C29c-75b5-ad1f-27d3-602b6d5da260\"]}
問題が発生した場合は、変更が適用される前に作成されたnsrdbコピーに戻すことができます。
Article Properties
Article Number: 000173881
Article Type: Solution
Last Modified: 17 Nov 2025
Version: 4
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