PowerEdge: Las conexiones IPMI a través de LAN de iDRAC fallan después de importar el perfil de configuración del servidor

Summary: En este artículo de Dell EMC, se proporciona orientación paso a paso sobre cómo resolver el problema cuando iDRAC deja de aceptar comandos IPMI remotos después de importar los atributos de usuario de iDRAC con la característica "Valores hash de contraseña" habilitada. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Descripción

Es posible que iDRAC deje de aceptar comandos IPMI remotos después de importar atributos de usuario de iDRAC con la característica "Valores hash de contraseña" habilitada.
 

ipmitool -I lanplus -H 192.168.10.3 -U root -P calvin sdr elist
Error: Unable to establish IPMI v2 / RMCP+ session
Device not present (No Response)


Dell EMC iDRAC agregó soporte para importar contraseñas de usuario de iDRAC a través del emparejamiento de valores de HASH y Salt. Esta función agrega una capa adicional de seguridad al importar cuentas de usuario de iDRAC. Existen varios métodos comunes para exportar e importar contraseñas de usuario de iDRAC con contraseñas hash que pueden provocar este comportamiento:
 

  • Exportación/importación del perfil de configuración del servidor (opcional)
  • Creación de usuarios de iDRAC de la CLI de RACADM con contraseña HASH (opcional)
  • Creación de usuarios de iDRAC de la CLI de Redfish con contraseña HASH (opcional)
  • Función Easy Restore después del reemplazo de la placa base del sistema (opcional)

Cause

Dell EMC iDRAC9 introdujo una nueva función para enmascarar las contraseñas de usuario de texto no cifrado con la introducción inicial del producto. Cuando se aprovechan los valores de hash con sal para las contraseñas de usuario de iDRAC, se requiere la IPMITOOL de OEM de Dell para analizar el valor de la contraseña con hash.  

Resolution

Solución

La función "Password Hash Values" requiere una versión compatible de la herramienta IPMI de Dell EMC para manejar correctamente la contraseña HASH cifrada. Para soportar el cifrado de contraseña HASH, utilice como mínimo las versiones de Dell EMC IPMITOOL incluidas en los siguientes conjuntos de herramientas de BMC:
 


Los cambios de Dell EMC en IPMItool se enviaron a la comunidad de código abierto. Es posible que algunas distribuciones de Linux aprovechen las versiones más recientes de IPMItool que aún no admiten este cambio.

Recuperación:

Si las contraseñas HASH se aplicaron a una cuenta de usuario de iDRAC de manera accidental, sobrescribir la contraseña de usuario mediante texto no cifrado permite que las herramientas IPMI de terceros se vuelvan a conectar.

  • GUI >de iDRAC Configuración de iDRAC Usuarios >>>> Editar>
    Ajustes de configuración de usuario de iDRAC 
  • racadm set iDRAC.Users.X.Passowrd xxxxxxxxxxx
    /admin1-> racadm set iDRAC.Users.16.Password Dell1234
    [Key=iDRAC.Embedded.1#Users.16]
    Object value modified successfully
    /admin1->

Affected Products

iDRAC9

Products

PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515 , PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000178105
Article Type: Solution
Last Modified: 05 Dec 2024
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.