PowerEdge: 서버 구성 프로파일을 가져온 후 LAN 연결을 통한 iDRAC IPMI 실패

Summary: 이 Dell EMC 문서에서는 "암호 해시 값" 기능이 활성화된 iDRAC 사용자 특성을 가져온 후 iDRAC가 원격 IPMI 명령 수락을 중지할 때 문제를 해결하는 방법에 대한 단계별 지침을 제공합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

설명

"Password Hash Values" 기능이 활성화된 iDRAC 사용자 특성을 가져온 후 iDRAC에서 원격 IPMI 명령의 수락을 중지할 수 있습니다.
 

ipmitool -I lanplus -H 192.168.10.3 -U root -P calvin sdr elist
Error: Unable to establish IPMI v2 / RMCP+ session
Device not present (No Response)


Dell EMC iDRAC는 HASH 및 Salt 값 페어링을 통해 iDRAC 사용자 암호를 가져오기 위한 지원을 추가했습니다. 이 기능은 iDRAC 사용자 계정을 가져올 때 별도의 보안 계층을 추가합니다. 해시 암호를 사용하여 iDRAC 사용자 암호를 내보내고 가져오는 몇 가지 일반적인 방법으로 인해 이러한 동작이 발생할 수 있습니다.
 

  • 서버 구성 프로파일 내보내기/가져오기(선택 사항)
  • HASH 암호를 사용하여 RACADM CLI iDRAC 사용자 생성(선택 사항)
  • HASH 암호를 사용하여 Redfish CLI iDRAC 사용자 생성(선택 사항)
  • 시스템 마더보드 교체 후 간편 복원 기능(옵션)

Cause

Dell EMC iDRAC9은 제품을 처음 도입하면서 일반 텍스트 사용자 비밀번호를 마스킹하는 새로운 기능을 도입했습니다. iDRAC 사용자 비밀번호에 솔트 처리된 해시 값을 활용하는 경우 해시된 암호 값을 구문 분석하려면 Dell OEM IPMITOOL이 필요합니다.  

Resolution

해결책

"Password Hash Values" 기능을 사용하려면 암호화된 HASH 암호를 올바르게 처리하기 위해 지원되는 버전의 Dell EMC IPMItool이 필요합니다. HASH 암호의 암호화를 지원하려면 최소한 다음 BMC Toolset에 번들로 제공되는 Dell EMC IPMITOOL 버전을 사용하십시오.
 


Dell EMC의 IPMItool 변경 사항이 오픈 소스 커뮤니티에 제출되었습니다. 일부 Linux 배포판에는 아직 이 변경을 지원하지 않는 더 새로운 버전의 IPMItool을 활용할 수 있습니다.

복구:

해시 암호가 iDRAC 사용자 계정에 실수로 적용된 경우 일반 텍스트를 사용하여 사용자 암호를 덮어쓰면 타사 IPMI 툴을 다시 연결할 수 있습니다.

  • iDRAC GUI >iDRAC 설정>>사용자 >> 편집>
    iDRAC 사용자 구성 설정 
  • racadm set iDRAC.Users.X.Passowrd xxxxxxxxxxx
    /admin1-> racadm set iDRAC.Users.16.Password Dell1234
    [Key=iDRAC.Embedded.1#Users.16]
    Object value modified successfully
    /admin1->

Affected Products

iDRAC9

Products

PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515 , PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000178105
Article Type: Solution
Last Modified: 05 Dec 2024
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.