VNX: 3-Wege-NDMP-Backup kann nicht gestartet werden – Datenträgerfehler (durch Nutzer korrigierbar)

Summary: VNx 3-Wege-NDMP-Backup kann keine Datenübertragung starten.

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Symptoms

Wenn der Data Mover überwacht wird, sieht man eine NDMP-Kontrollpfadverbindung von der Backupsoftware. Während der Datenpfadverbindung meldet das Backup jedoch einen Datenträgerfehler und wird beendet.

Debugging-Level-3-Protokollierung

2020-10-07 08:13:21: 30336548864: NDMP: 7: Sitzung 123 (thread ndmp123) < ip=#####, port=0x269c >
07.10.2020 08:13:21: 43221450752: NDMP: 10: connect: check concurrent data streams.
2020-10-07 08:13:21: 26041581568: NDMP: 6: Active NDMP backup/restore streams: 2, system configured concurrent streams: 4, maximum concurrent sessions supported: 8. 
2020-10-07 08:13:21: 30336548864: NDMP: 7: Session 123 (thread ndmp123) NdmpdMover::getBuffer() success, buf 0x001ecf2000, CALLER_ADDRESS 0x0001c27253, CALLERCALLER_ADDRESS 0x0001c1e46b
2020-10-07 08:14:33: 13156679680: NDMP: 3: Session 122 (thread ndmp122) NdmpdMover::connect: connect error: Connection timed out 
2020-10-07 08:14:33: 26041581568: NDMP: 6: mover connect failed: NDMP_CONNECT_ERR.

Cause

Für einen sofortigen Ausfall in einem 3-Wege-Back während der NDMP-Connect-Phase gibt es in der Regel drei Ursachen:    
  1. Keine Verbindung zur Backupanwendung oder zum Medienserver von Data Mover:  
  2. NIC-Teaming für Lastenausgleich auf dem Medienserver der Backupanwendung aktiviert
  3. Firewall im Netzwerk oder Host blockiert eingehende Datenpfadverbindung von Data Mover:  

Route
So überprüfen Sie den Datenträger des Medienservers der Backupanwendung von der Control Station als nasadmin

IP des server_ping server_x-Medienservers<>

Eine neue Netzwerk- oder Hostverbindung ist erforderlich, wenn ein Problem beim Erreichen des Medienservers der Backupanwendung auftritt. Weitere Informationen finden Sie im KB-Artikel 008516 Konfigurieren von Routen für einen VNx Data Mover

NIC-Teaming
NIC-Teaming sollte auf dem Medienserver auf „Fault Tolerant“ eingestellt sein. Wird auch als NIC-Teaming mit aktiv/passiv in bestimmten Dokumenten bezeichnet.

Firewall
Die Backupanwendung gibt eine IP-Adresse und eine Portnummer im Kontrollpfad an, die für die Phase „Data Connect“ verwendet wird. Diese IP-Adresse und Portnummer gehören zum Medienserver, an den die Backupdaten gesendet werden. Es wird eine ausgehende TCP-Verbindung vom Data Mover zu dieser IP-Adresse und Portnummer hergestellt. Eine Firewall im Netzwerk oder auf dem Medienserver benötigt eine Regel, um diese eingehende Verbindung vom Data Mover zu erlauben. Die TCP-Portnummer wird von der Backupanwendung ausgewählt und stammt in der Regel aus einem konfigurierbaren Portbereich, aus dem eine zufällige Portnummer in von der Backupanwendung ausgewählt wird.

Diese IP-Adresse und Portnummer können in einer Netzwerkerfassung oder mithilfe vom Dell Support mit Debug-Level-3-Protokollierung auf der Data-Mover-Seite angezeigt werden. Lassen Sie die Debug-Level-Protokollierung nicht aktiviert, nachdem Sie das Problem reproduziert haben. Für das Troubleshooting bei der Verwendung einer Netzwerkerfassung sollten bidirektionale Netzwerkerfassungen auf dem Data Mover und dem Medienserver durchgeführt werden.

Resolution

In diesem Fall gab es keine Verbindung zwischen dem Data Mover und der IP-Adresse, die von der Backupanwendung angegeben wurde.  Dadurch konnte die Phase „Data Connect“ nicht gestartet werden. Eine Netzwerkerfassung zeigte die Verbindung vom Backupanwendungsserver zum Kontrollpfad an, aber es gab keine ausgehende Verbindung vom Data Mover zum Starten der Datenübertragung.

Affected Products

VNX1 Series, VNX2 Series
Article Properties
Article Number: 000181109
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  4
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