VNX: il backup tridirezionale NDMP non si avvia - Errore medio (correggibile dall'utente)

Summary: VNX: il backup NDMP tridirezionale non riesce ad avviare il trasferimento dei dati.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Osservando il data mover, viene visualizzata la connessione del percorso di controllo NDMP dal software di backup, ma durante la connessione al percorso dati il backup segnala un errore medio e si arresta.

Registrazione di debug di livello 3

2020-10-07 08:13:21: 30336548864: NDMP: 7: Sessione 123 (thread ndmp123) < ip=#####, port=0x269c >
07/10/2020 08:13:21: 43221450752: NDMP: 10: connect: check concurrent data streams.
2020-10-07 08:13:21: 26041581568: NDMP: 6: Active NDMP backup/restore streams: 2, system configured concurrent streams: 4, maximum concurrent sessions supported: 8. 
2020-10-07 08:13:21: 30336548864: NDMP: 7: Session 123 (thread ndmp123) NdmpdMover::getBuffer() success, buf 0x001ecf2000, CALLER_ADDRESS 0x0001c27253, CALLERCALLER_ADDRESS 0x0001c1e46b
2020-10-07 08:14:33: 13156679680: NDMP: 3. Session 122 (thread ndmp122) NdmpdMover::connect: connect error: Connection timed out 
2020-10-07 08:14:33: 26041581568: NDMP: 6: mover connect failed: NDMP_CONNECT_ERR.

Cause

Per un errore immediato in un backup tridirezionale durante la fase di connessione a NDMP, sono generalmente tre le cause:    
  1. Nessuna route al media server dell'applicazione di backup dal data mover:  
  2. Gruppo NIC per il bilanciamento del carico abilitato sul media server dell'applicazione di backup
  3. Firewall nella rete o nell'host che blocca la connessione al percorso dati in ingresso dal data mover:  

Route
Per controllare la route dal data mover del media server dell'applicazione di backup dalla control station come nasadmin

IP server_ping server_x<Media Server>

Se si verifica un problema di raggiungimento del media server dell'applicazione di backup, è necessaria una nuova ruote alla rete oppure all'host. Consultare l'articolo della KB 008516 Come configurare route per un data mover VNX? (in inglese)

Gruppo NIC
Il gruppo NIC deve essere impostato su Fault Tolerant sul media server. Noto anche come gruppo NIC con active/passive in alcuni file di documentazione.

Firewall
L'applicazione di backup specifica un IP e un numero di porta nel percorso di controllo, utilizzato per la fase di connessione dati. L'IP e il numero di porta sono quelli del media server a cui inviare i dati di backup. Una connessione TCP in uscita viene stabilita dal data mover a questo indirizzo IP e questo numero di porta. Un firewall nella rete o sul media server necessita di una regola per consentire questa connessione in entrata dal data mover. Il numero di porta TCP viene scelto dall'applicazione di backup e in genere è ricavato da un intervallo di porte configurabile e viene scelto un numero di porta casuale in questo intervallo dall'applicazione di backup.

L'indirizzo IP e il numero di porta possono essere visualizzati in un'acquisizione della rete o tramite il Supporto Dell utilizzando la registrazione di debug di livello tre sul lato data mover. Non lasciare la registrazione di debug abilitata dopo la riproduzione del problema. Per la risoluzione del problema tramite un'acquisizione della rete bidirezionale, quest'ultima deve essere eseguita sia sul data mover che sul media server.

Resolution

In questo caso non è stata specificata una route dal data mover all'indirizzo IP dall'applicazione di backup.  Ciò impedisce l'avvio della fase di connessione dati. Un'acquisizione di rete mostra la connessione al percorso di controllo dal server dell'applicazione di backup, ma non è presente una connessione in uscita dal data mover per avviare il trasferimento dei dati.

Affected Products

VNX1 Series, VNX2 Series
Article Properties
Article Number: 000181109
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.