VNX. не удается запустить трехстороннее резервное копирование NDMP — средняя ошибка (исправляется пользователем)

Summary: 3-стороннее резервное копирование NDMP VNX не может начать передачу данных.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Наблюдая за модулем переноса данных, мы видим подключение управляющего пути NDMP из ПО резервного копирования, но во время соединения маршрута данных резервная копия сообщает о средней ошибке и завершает работу.

Debug Level 3 Logging

2020-10-07 08:13:21: 30336548864. NDMP: 7. Сессия 123 (поток ndmp123) < ip=#####, port=0x269c >
07.10.2020 08:13:21: 43221450752. NDMP: 10: connect: check concurrent data streams.
2020-10-07 08:13:21: 26041581568. NDMP: 6: Active NDMP backup/restore streams: 2, system configured concurrent streams: 4, maximum concurrent sessions supported: 8. 
2020-10-07 08:13:21: 30336548864. NDMP: 7. Session 123 (thread ndmp123) NdmpdMover::getBuffer() success, buf 0x001ecf2000, CALLER_ADDRESS 0x0001c27253, CALLERCALLER_ADDRESS 0x0001c1e46b
2020-10-07 08:14:33: 13156679680. NDMP: 3. Session 122 (thread ndmp122) NdmpdMover::connect: connect error: Connection timed out 
2020-10-07 08:14:33: 26041581568. NDMP: 6: mover connect failed: NDMP_CONNECT_ERR.

Cause

Существует три причины для немедленного сбоя 3-стороннего резервного копирования на этапе подключения NDMP:    
  1. Нет маршрута к приложению резервного копирования или серверу мультимедиа из модуля переноса данных:  
  2. Объединение сетевых плат для балансировки нагрузки включено на сервере мультимедиа приложения резервного копирования
  3. Брандмауэр в сети или хосте блокирует входящие подключения к каналу данных из модуля переноса данных:  

Маршрут
Для проверки маршрута подключения из модуля переноса данных на сервер мультимедиа приложения резервного копирования с управляющей станции как nasadmin выполните следующую команду

IP-адрес медиасервераserver_ping server_x<>

При возникновении проблем с подключением к серверу мультимедиа приложения резервного копирования требуется новый маршрут сети или хоста. См. статью базы знаний 008516 Как настроить маршруты для модуля переноса данных VNX?

Объединение сетевых плат
Объединение сетевых плат на сервере мультимедиа должно быть установлено в значение «Fault Tolerant». В некоторых документах это также называется объединением сетевых плат в режиме «активный-пассивный».

Брандмауэр
Приложение резервного копирования определяет IP-адрес и номер порта в пути управления, который используется для этапа объединения данных. Этот IP-адрес и номер порта принадлежат серверу мультимедиа, на который отправляются данные резервного копирования. Исходящее подключение TCP устанавливается с модуля переноса данных на этот IP-адрес и номер порта. Брандмауэру в сети или на сервере мультимедиа требуется правило, разрешающее это входящее подключение от модуля переноса данных. Номер порта TCP выбирается приложением резервного копирования, обычно из настраиваемого диапазона портов, а случайный номер порта в этом диапазоне выбирается приложением резервного копирования.

Этот IP-адрес и номер порта можно просмотреть в перехвате сетевого трафика или в службе поддержки Dell с помощью ведения журнала отладки уровня 3 на стороне модуля переноса данных. Не оставляйте включенным ведение журнала на уровне отладки после воспроизведения проблемы. Для поиска и устранения неисправностей с помощью перехвата сетевого трафика необходимо выполнить двунаправленный захват сетевого трафика как на модуле переноса данных, так и на сервере мультимедиа.

Resolution

В этом случае не было маршрута от модуля переноса данных к IP-адресу, указанному приложением резервного копирования.  Это не позволило запустить фазу передачи данных. Захват сетевого трафика показал подключение управляющего пути от сервера приложения резервного копирования, но отсутствует исходящее соединение от модуля переноса данных для начала передачи данных.

Affected Products

VNX1 Series, VNX2 Series
Article Properties
Article Number: 000181109
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.