NetWorker:VMware グループがエラーで失敗し、インベントリのロードに失敗しました vCenter

Summary: 動的な関連づけがある NetWorker VMware グループがエラーで失敗し、vCenter からインベントリをロードできませんでした

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

1.グループタイプに関連づけられている NetWorker ワークフロー: VMware、動的な関連づけが有効 (タグベースの関連付け) が有効になっています。「インベントリのロードに失敗しました」というエラーで失敗します。
sr-2.ワークフローは、「個々のクライアントの起動」を試行しても、その下の仮想マシンをレポートしません。
3/3.次のエラーが、デーモンログに記録されます。

 

nsrdisp_nwbg NSR 重大インベントリセッションのステータスが障害で返されました。Error: ' < Vcenter 名 > ' からインベントリのロードに失敗しました。カテゴリ/タグ付けメタデータのロードに失敗しました: 「HTTPS://< vCenter 名前 >/rest/com/vmware/cis/session」で CIS サービスへのログインに失敗しました: Post https://< vcenter 名 >/rest/com/vmware/cis/session: net/http: 要求はキャンセルされました (クライアントは、ヘッダーを待っている間にタイムアウトを超過しました)。nsrdisp_nwbg NSR 重大インベントリセッションのステータスが障害で返されました。Error: ' < Vcenter 名 > ' からインベントリのロードに失敗しました。カテゴリ/タグ付けメタデータのロードに失敗しました: 無効なメモリアドレスまたは nil ポインタの逆参照「インベントリセッションステータスが失敗で返されました。Error: 「< VCenter 名前 >」からインベントリのロードに失敗しました。  カテゴリ/タグ付けメタデータのロードに失敗しました:  VCenter への REST リクエストの送信に失敗しました: Post https://< vCenter name >/rest/com/vmware/cis/tagging/tag-association/id: urn: vmomi: InventoryServiceTag: 73f530b9-ea0b-48db-b657-c6cf308c2a53: GLOBAL? ~ action = list-アタッチされたオブジェクト: net/http: request canceled (Client) は、ヘッダーの待機中にタイムアウトを超過しました)。

 


Cause

1.古いタグを cs からクリアするために vCenter から障害が発生しました。 id:

これを確認するには vCenter CLI で次のコマンドを実行します。VCenter postgres データベースに接続します。

/opt/vmware/vpostgres/current/bin/psql -d VCDB -U postgres


仮想マシンに関連づけられている古いタグをクエリーするには:

# select count (*) from cis_kv_keyvalue where kv_provider ' タグ付け:% '、kv_key like ' tag_association urn: vmomi: VirtualMachine:% ' および regexp_replace (kv_key、' tag_association urn: vmomi: VirtualMachine: vm-([0-9] +). * ', ' \ 1 '):: bigint not in (id を vpx_vm から選択)


ホストに関連づけられた古いタグをクエリーするには、次のようにします。 

# select count (*) from cis_kv_keyvalue where kv_provider like ' タグ付け:% ' および kv_key like ' tag_association urn: vmomi: HostSystem:% ' and regexp_replace (kv_key、' tag_association urn: vmomi: HostSystem: host-([0-9] +). * '、' \ 1 '):: bigint not in (id を vpx_host から選択)



2.Crunch が原因で vCenter の VAPI エンドポイントが失敗し、次のヒープメモリがダンプされました。

これは、vCenter CLI で次のコマンドを実行することで識別できます。

# ls-ltrh * hprof * |awk {' print $9 '} java_pid45649 java_pid62528 hprof java_pid36715. hprof java_pid2514. hprof java_pid43896 hprof java_pid52081. hprof

これらのそれぞれは、デーモンのエラーを発見した時間に対応しています。 NetWorker にログオンします。 

Resolution

上記の各ケースは、以下の推奨事項に従って、VMware 管理者によって解決される必要があります。

1古いタグ:

 古いタグをクリアするには、次のようにします。

a。Vpxd & Content library サービスを停止します。

サービスコントロール--停止 vmware-vpxd サービス制御--停止 vmware-コンテンツライブラリ

b.vCenter postgres データベースへの接続
 

/opt/vmware/vpostgres/current/bin/psql -d VCDB -U postgres


古いタグを削除するには、次のようにします。
 

次 cis_kv_keyvalue の kv_provider 場所から削除します。「タグづけ:%」および kv_key like ' tag_association urn: vmomi: VirtualMachine:% ' and regexp_replace (kv_key、' tag_association urn: vmomi: VirtualMachine: vm-([0-9] +). * ', ' \ 1 '):: bigint not in (vpx_vm からの id の選択) kv_key、kv_value次 cis_kv_keyvalue の kv_provider 場所から削除します。「タグづけ:%」や kv_key like 「tag_association urn: vmomi: HostSystem:%」と regexp_replace (kv_key、' tag_association urn: vmomi: HostSystem: host-([0-9] +). * '、' \ 1 '):: bigint not in (vpx_host からの id の選択)]cis_kv_keyvalue from kv_provider ' タグ付け:% '、kv_key like ' tag_association urn: vmomi: データストア:% ' および regexp_replace (kv_key、' tag_association urn: vmomi: データストア: データストア-([0-9] +). * '、' \ 1 '):: bigint not in (vpx_datastore からの id の選択) kv_key を返します。


a. 次の2つの select クエリーコマンドをもう一度実行して、カウントが 0
であることを確認します。b.サービスの開始:

サービス-制御--スタート vmware-vpxd サービス制御--スタート vmware-コンテンツライブラリ

c. vCenter セッションをログアウトして再度ログインし、環境、タグ、NSX、バックアップ、プロビジョニングなど

を確認します。VCenter が正常に表示されない場合は、コマンド「vc-support」を使用して vCenter からログを収集し、VMware に連絡してください。


2.VAPI クラッシュ:

、.VAPI に割り当てられたメモリを特定し、メモリが不足していない場合は、VMware サポートによって決定できます。

 

#cloudvm-ram サイズ-l |grep-i vapi vmware-vapi-endpoint = 256


この行を次のように変更します。

#cloudvm-ram サイズ-l |grep-i vapi vmware-vapi-endpoint = 1120

 


Article Properties
Article Number: 000181215
Article Type: Solution
Last Modified: 22 Jan 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.