RecoverPoint for Virtual Machines: Uppgradering från version 5.2.x till 5.3.1 slutförs inte

Summary: Uppgradering av RecoverPoint for VMs från version 5.2 till 5.3.1 stöter på ett problem och slutförs inte, vilket lämnar klustret i ett delvis uppdaterat läge.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Följande visas i RecoverPoint /home/kos/installationLogs/server.log:
XXXX/XX/XX 10:30:10.797 [pool-4-thread-1] (Task.java:98) ERROR - UpgradeClusterRestorableTask :Task failed: Executing NDU.
com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume.
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.attemptToCompletePhase(RestorableSerialTask.java:94)
at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.perform(RestorableSerialTask.java:63)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.call(Task.java:142)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:823)
Caused by: com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume.
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:32)
... 9 more

XXXX/XX/XX 10:30:09,763 [CommandWorker-1] (CreateVCConnectionCommand.java:49) ERROR - Failed to connect to VCenter server.
XXXX/XX/XX 10:30:09,764 [CommandWorker-1] (Command.java:88) ERROR - Command#run() ServerException errorType[OPERATION_FAILED_NO_MESSAGE] errorMessage[Entering vCenter credentials failed. Check that all entered credentials are correct. If problem recurs, check that vCenter Server and communication are fully functional. If the problem persists, Please contact Customer Support for assistance.] failure UID: >
com.kashya.installation.server.exceptions.CommandFailedException: Entering vCenter credentials failed. Check that all entered credentials are correct. If problem recurs, check that vCenter Server and communication are fully functional. If the problem persists, Please contact Customer Support for assistance.
at com.kashya.installation.server.commands.vsphere.CreateVCConnectionCommand.execute(CreateVCConnectionCommand.java:50) ~[classes/:?]
at com.kashya.installation.server.commands.vsphere.CreateVCConnectionCommand.execute(CreateVCConnectionCommand.java:17) ~[classes/:?]
at com.kashya.installation.server.commands.Command.runNormal(Command.java:109) [classes/:?]
at com.kashya.installation.server.commands.Command.run(Command.java:49) [classes/:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_265]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_265]
at com.kashya.installation.server.commands.Command.executeInternalCommand(Command.java:266) [classes/:?]

Cause

Under uppgraderingen från RecoverPoint for VMs 5.2 försöker Deployer spara den vCenter UUID som krävs i en tweak med namnet "t_deployed_vc_uuid".  Det sker genom att upprätta en anslutning till vCenter och validera om vRPA:erna finns i just det vCenter.

Men när ett vCenter har ett CA-certifikat med mer än en kedjelängd misslyckas anslutningen eftersom den gamla truststore inte har kopierats ännu.

Resolution

Workaround:
När det här problemet uppstår måste vi lägga till justeringen "t_deployed_vc_uuid" med distribuerad VC UUID till filen "tweak.params.system_layout" på berörd vRPA. VCenter UUID-värdet hittas genom att köra kommandot get_storage på en opåverkade vRPA i det klustret. Det värde som krävs för justeringen anges under serienumret i kommandot get_storage CLI. 

Kontrollera vilken RPA som saknar "t_deployed_vc_uuid".

Öppna den berörda RPA:en med ett rotkonto via SSH eller webbkonsolen och utför följande steg:
  1. Skriv kommando:
su - admin
  1. Välj alternativet [6] System management CLI
  2. Skriv kommando:
get_storage
  1. Ange det RPA-klusternamn som du måste lägga till i vCenter
  2. På de resultat som visas samlar du in värdet för serienumret
  3. Skriv kommando: 
quit
  1. Skriv in alternativ Q och skriv Y för att återgå till root
  2. När du har loggat in på RPA1 som root skriver du tweak och trycker på Enter
  3. Skriv kommando: 
vi tweak.params.system_layout
  1. I slutet av filen lägger du till nedanstående information:
t_deployed_vc_uuid = >
  1. Tryck på ESC och skriv wq!
  2. Starta om RPA1
När du har slutfört stegen ovan kan vCenter autentiseras korrekt och information visas i RecoverPoint-insticksprogrammet.

När klusterlogiktjänsten är igång på berörd vRPA bör uppgraderingen börja gå vidare från föregående steg utan åtgärder.

Driftsättningsenheten kan också hämtas och fortsätta om den lämnas öppen. Om det stängdes kontrollerar du CLI-status för de andra vRPA:erna för att se om de också har börjat uppgradera, även när Deployer är stängt.

Om det inte sker kontaktar du Dell RecoverPoint-supporten för att få hjälp.

Upplösning:
Problemet har åtgärdats i RecoverPoint for Virtual Machines version 5.3.1.1.

Om du vill ta reda på om en uppgradering är lämplig för din miljö kan du kontakta Dells kundsupport eller din kundtjänstrepresentant och hänvisa till detta lösnings-ID.

Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000182619
Article Type: Solution
Last Modified: 27 Sep 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.