RecoverPoint for VMs: Das Upgrade von Version 5.2.x auf 5.3.1 wird nicht abgeschlossen.

Summary: Beim Upgrade von RecoverPoint for VMs von Version 5.2 auf 5.3.1 tritt ein Problem auf und wird nicht abgeschlossen, sodass sich das Cluster in einem teilweise aktualisierten Zustand befindet. ...

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Symptoms

Folgendes wird in RecoverPoint /home/kos/installationLogs/server.log angezeigt:
XXXX/XX/XX 10:30:10.797 [pool-4-thread-1] (Task.java:98) ERROR - UpgradeClusterRestorableTask :Task failed: Executing NDU.
com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume.
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.attemptToCompletePhase(RestorableSerialTask.java:94)
at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.perform(RestorableSerialTask.java:63)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.call(Task.java:142)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:823)
Caused by: com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume.
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:32)
... 9 more

XXXX/XX/XX 10:30:09,763 [CommandWorker-1] (CreateVCConnectionCommand.java:49) ERROR - Failed to connect to VCenter server.
XXXX/XX/XX 10:30:09,764 [CommandWorker-1] (Command.java:88) ERROR - Command#run() ServerException errorType[OPERATION_FAILED_NO_MESSAGE] errorMessage[Entering vCenter credentials failed. Check that all entered credentials are correct. If problem recurs, check that vCenter Server and communication are fully functional. If the problem persists, Please contact Customer Support for assistance.] failure UID: >
com.kashya.installation.server.exceptions.CommandFailedException: Entering vCenter credentials failed. Check that all entered credentials are correct. If problem recurs, check that vCenter Server and communication are fully functional. If the problem persists, Please contact Customer Support for assistance.
at com.kashya.installation.server.commands.vsphere.CreateVCConnectionCommand.execute(CreateVCConnectionCommand.java:50) ~[classes/:?]
at com.kashya.installation.server.commands.vsphere.CreateVCConnectionCommand.execute(CreateVCConnectionCommand.java:17) ~[classes/:?]
at com.kashya.installation.server.commands.Command.runNormal(Command.java:109) [classes/:?]
at com.kashya.installation.server.commands.Command.run(Command.java:49) [classes/:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_265]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_265]
at com.kashya.installation.server.commands.Command.executeInternalCommand(Command.java:266) [classes/:?]

Cause

Während des Upgrades von RecoverPoint for VMs 5.2 versucht Deployer, die erforderliche vCenter UUID in einer Optimierung namens "t_deployed_vc_uuid" zu speichern.  Dies geschieht, indem eine Verbindung zum vCenter hergestellt und validiert wird, ob die vRPAs in diesem bestimmten vCenter vorhanden sind.

Wenn ein vCenter jedoch über ein CA-Zertifikat mit mehr als einer Kettenlänge verfügt, schlägt die Verbindung fehl, da der alte Truststore noch nicht kopiert wurde.

Resolution

Problemumgehung:
Sobald dieses Problem auftritt, müssen wir die Optimierung "t_deployed_vc_uuid" mit der bereitgestellten VC UUID zur Datei "tweak.params.system_layout" auf der betroffenen vRPA hinzufügen. Der vCenter UUID-Wert wird durch Ausführen des Befehls get_storage auf einer noch aktiven vRPA in diesem Cluster gefunden. Der erforderliche Wert für die Optimierung wird unter dem Seriennummernwert innerhalb des CLI-Befehls get_storage aufgeführt. 

Überprüfen Sie, bei welcher RPA die "t_deployed_vc_uuid"

fehlt.Greifen Sie mit einem Root-Konto über SSH oder die Webkonsole auf die betroffene RPA zu und führen Sie die folgenden Schritte aus:
  1. Geben Sie den folgenden Befehl ein:
su - admin
  1. Wählen Sie die Option [6] System Management CLI aus.
  2. Geben Sie den folgenden Befehl ein:
get_storage
  1. Geben Sie den RPA-Clusternamen ein, den Sie zu vCenter hinzufügen müssen.
  2. Erfassen Sie in den angezeigten Ergebnissen den Wert für die Seriennummer.
  3. Geben Sie den folgenden Befehl ein: 
quit
  1. Geben Sie Option Q ein und geben Sie dann Y ein, um zum Stammverzeichnis zurückzukehren.
  2. Sobald Sie sich bei RPA1 als Root angemeldet haben, geben Sie tweak ein und drücken Sie die Eingabetaste.
  3. Geben Sie den folgenden Befehl ein: 
vi tweak.params.system_layout
  1. Fügen Sie am Ende der Datei die folgenden Informationen hinzu:
t_deployed_vc_uuid = >
  1. Drücken Sie die ESC-Taste und geben Sie wq! ein.
  2. Starten Sie RPA1 neu.
Sobald Sie die obigen Schritte abgeschlossen haben, kann sich vCenter ordnungsgemäß authentifizieren und die Informationen werden im RecoverPoint-Plug-in angezeigt.

Sobald der Cluster Logic-Service auf der betroffenen vRPA aktiv ist, sollte das Upgrade ohne Intervention mit dem vorherigen Schritt fortfahren.

Der Deployer kann auch den Vorgang aufnehmen und weitermachen, wenn er offen gelassen wurde. Wenn es geschlossen wurde, überprüfen Sie den CLI-Status der anderen vRPAs, um festzustellen, ob sie auch mit dem Upgrade begonnen haben, selbst wenn Deployer geschlossen ist.

Wenn dies nicht der Fall ist, wenden Sie sich an den Dell RecoverPoint-Support , um Unterstützung zu erhalten.

Auflösung:
Dieses Problem wurde in RecoverPoint for Virtual Machines Version 5.3.1.1 behoben.

Um festzustellen, ob ein Upgrade für Ihre Umgebung geeignet ist, wenden Sie sich an den Dell Kundensupport oder Ihren Servicemitarbeiter und geben Sie diese Lösungs-ID an.

Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000182619
Article Type: Solution
Last Modified: 27 Sep 2023
Version:  6
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