Sanal Makineler için RecoverPoint: Sürüm 5.2.x'den 5.3.1'e Yükseltme Tamam değil

Summary: RecoverPoint for VM'leri sürüm 5.2'den 5.3.1'e yükseltmek bir sorunla karşılaşır ve tamamlanmıyor ve kümeyi kısmen güncelleştirilmiş durumda bırakarak tamamlanmıyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

RecoverPoint /home/bios/installationLogs/server.log dosyasında aşağıdakiler görülür:
XXXX/XX/XX 10:30:10.797 [pool-4-thread-1] (Task.java:98) ERROR - UpgradeClusterRestorableTask :Task failed: Executing NDU.
com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume.
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.attemptToCompletePhase(RestorableSerialTask.java:94)
at com.emc.recoverpoint.utils.javainfra.status.tasks.RestorableSerialTask.perform(RestorableSerialTask.java:63)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.call(Task.java:142)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:823)
Caused by: com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: could not configure repository volume.
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:35)
at com.emc.recoverpoint.utils.javainfra.status.tasks.Task.executeSync(Task.java:91)
at com.emc.recoverpoint.utils.javainfra.status.tasks.SerialTask.perform(SerialTask.java:32)
... 9 more

XXXX/XX/XX 10:30:09,763 [CommandWorker-1] (CreateVCConnectionCommand.java:49) ERROR - Failed to connect to VCenter server.
XXXX/XX/XX 10:30:09,764 [CommandWorker-1] (Command.java:88) ERROR - Command#run() ServerException errorType[OPERATION_FAILED_NO_MESSAGE] errorMessage[Entering vCenter credentials failed. Check that all entered credentials are correct. If problem recurs, check that vCenter Server and communication are fully functional. If the problem persists, Please contact Customer Support for assistance.] failure UID: >
com.kashya.installation.server.exceptions.CommandFailedException: Entering vCenter credentials failed. Check that all entered credentials are correct. If problem recurs, check that vCenter Server and communication are fully functional. If the problem persists, Please contact Customer Support for assistance.
at com.kashya.installation.server.commands.vsphere.CreateVCConnectionCommand.execute(CreateVCConnectionCommand.java:50) ~[classes/:?]
at com.kashya.installation.server.commands.vsphere.CreateVCConnectionCommand.execute(CreateVCConnectionCommand.java:17) ~[classes/:?]
at com.kashya.installation.server.commands.Command.runNormal(Command.java:109) [classes/:?]
at com.kashya.installation.server.commands.Command.run(Command.java:49) [classes/:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_265]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_265]
at com.kashya.installation.server.commands.Command.executeInternalCommand(Command.java:266) [classes/:?]

Cause

RecoverPoint for VMs 5.2'den yükseltme sırasında Deployer, gerekli vCenter UUID'yi "t_deployed_vc_uuid" adlı bir ince ayarda kaydetmeye çalışacaktır.  Bunu, vCenter'a bir bağlantı yaparak ve vRPA'ların ilgili vCenter'da mevcut olup olmadığını doğrular.

Ancak bir vCenter birden fazla zincir uzunluğuna sahip bir CA Sertifikasına sahipse eski Truststore henüz kopyalanmadıktan sonra bağlantı başarısız olur.

Resolution

Geçi -ci çözüm:
Bu sorun oluştuğunda, etkilenen vRPA'da "t_deployed_vc_uuid" ince ayarı dağıtılan VC UUID'sini "tweak.params.system_layout" dosyasına eklemelisiniz. vCenter UUID değeri, söz get_storage çalışan bir vRPA'da get_storage komutu çalıştırıldığında bulunur. Ayar için gerekli değer, cli komutundaki seri numarası get_storage listelenir. 

Hangi RPA'nın "t_deployed_vc_uuid." öğesinin eksik olduğunu doğrulayın.

SSH veya Web Konsolu kullanarak kök hesabıyla etkilenen RPA'ya erişin ve aşağıdaki adımları gerçekleştirin:
  1. Komut yazın:
su - admin
  1. [6] System management CLI (Sistem yönetimi CLI) öğesini seçin
  2. Komut yazın:
get_storage
  1. vCenter'a eklemeniz gereken RPA küme adını girin
  2. Görüntülenen sonuçlarda Seri Numarası değerini toplama
  3. Komut yazın: 
quit
  1. Köke geri dönmek için Q seçeneği ve ardından Y yazın
  2. RPA1'de kök olarak oturum açtıkten sonra tweak yazın ve Enter tuşuna basın
  3. Komut yazın: 
vi tweak.params.system_layout
  1. Dosyanın sonunda aşağıdaki bilgileri ekleyin:
t_deployed_vc_uuid = >
  1. ESC tuşuna basın ve wq! yazın
  2. RPA1'i yeniden başlatın
Yukarıdaki adımları tamamladıktan sonra vCenter doğru şekilde kimlik doğrular ve RecoverPoint eklentisinde bilgiler görüntülenir.

Küme Mantığı hizmeti etkilenen vRPA'da çalışmaya başlandıktan sonra yükseltme, müdahale olmadan önceki adımdan ilerlemeye başlamalıdır.

Dağıtım aygıtı açık bırakıldığı zaman da alınabilir ve devam olabilir. Kapatıldıysa Diğer vRPA'ların CLI durumunu kontrol edin ve Deployer kapalıyken bile yükseltmeye başladıklarından emin olun.

Bu gerçekleşmezse yardım için Dell RecoverPoint Destek ile iletişime geçin.

Çözünürlük:
Bu sorun, RecoverPoint for Virtual Machines sürüm 5.3.1.1'de giderildi.

Ortamınız için bir yükseltmenin uygun olup olmadığını belirlemek için Dell Müşteri Destek birimine veya servis temsilcinize başvurun ve bu çözüm kimliğini referans alın.

Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000182619
Article Type: Solution
Last Modified: 27 Sep 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.