Dell Unity: Як вирішити можливу проблему з дозволом NAS

Summary: Як вирішити можливу проблему з дозволом NAS після зміни домену SMB Active Directory, коли ввімкнено багатопротокольність. (Виправляється користувачем)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Якщо для сервера NAS увімкнено багатопротокольність, не рекомендується змінювати домен SMB Active Directory. Якщо домен SMB Active Directory буде змінено, може виникнути проблема з дозволом через дублювання записів Secmap для одного й того ж імені користувача.

Наприклад: Існує багатопротокольний сервер NAS "cxnas1224" з доменом SMB Active Directory "VITA". З svc_cifssupport 'secmap' ми можемо побачити, що є користувач "cifsuser", який був зіставлений з UID 1012:
-secmap -список виведених команд

Після зміни домену SMB Active Directory з "VITA" на "PITHOS" можуть бути дубльовані записи Secmap для одного і того ж імені користувача, як ми можемо бачити, є два записи "cifsuser" з двох доменів, обидва з яких зіставлені з UID 1012:
-secmap -список -uid виведення команди

Це може спричинити певні проблеми з дозволами. Наприклад, якщо політика доступу до ФС встановлена на «Windows». Після зміни домену "PITHOS\cifsuser" створює файл з SMB, а потім намагається отримати доступ до нього з NFS. Доступ з NFS може бути невдалим, оскільки UID 1012 може бути зіставлено з "VITA\cifsuser".

 

Cause

БД Secmap не буде автоматично оновлюватися після зміни домену Active Directory.
Середовище: Масиви Unity з увімкненим сервером NAS з мультипротоколом

 

Resolution

Після зміни домену Active Directory клієнт повинен вручну видалити застарілі записи зі старого домену за допомогою svc_cifssupport команда. Використовуйте SID для ідентифікації запису, оскільки -delete -name <name> -domain <domain_name> може вийти з ладу через зміну домену. Наприклад:
-delete -name вивід команди

 

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000182731
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.