Data Protection Central (DPC)で、初期インストール後にUIへのアクセス中にエラー502が発生する

Summary: このKBでは、DPCの初期インストール後にData Protection Central (DPC) UIにログインする際のエラーを解決する方法について説明します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

DPCのインストール後、DPC UIにログインしようとすると、HTTPエラー502.
が表示されますDPCサービスを確認した後、ファイル状態の複数のサービスを見つけます。

/var/log/dpc/elg/elg.logファイルで、次のようなエラーを見つけます。

2021-02-16 15:35:57,340 ERROR main o.s.b.SpringApplication Application run failed
com.emc.clp.spi.UnavailableException: Unable to init ELG
...
Caused by: java.util.concurrent.ExecutionException: java.util.concurrent.CompletionException: java.lang.IllegalStateException: Could not create URI object: Illegal character in hostname at index 10: https://dp_central.lab.dell.com/pf-admin-api/v1/oauth/clients

Cause

DPCのホスト名に不正な文字が含まれていると、この問題が発生します。

 

Resolution

この問題を解決するには、サポートされている文字のみを含むホスト名でDPCを再導入します。

上記の例では、ホスト名は「dp_central.lab.dell.com」です。アンダースコア「_」はサポートされている文字ではありません。
DPCホスト名は、次の基準のみをサポートします。

  • ホスト名の各要素の長さは 1 から 63 文字でなければなりません。
  • ホスト名全体(ドットを含む)の長さは、253文字以下にする必要があります。
  • 有効な文字は、文字 a から z、数字 0 から 9、ハイフン "-" です。ホスト名はハイフン "-" で始めることはできません。
  • 各要素はドットで区切られます。

 

Affected Products

Data Protection Central
Article Properties
Article Number: 000183400
Article Type: Solution
Last Modified: 16 Jan 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.