Dell Unity: Výstraha v prostředí Unisphere: Failed to get technical advisory with configured proxy. (oprava společností Dell)

Summary: Výstraha v prostředí Unisphere: Failed to get technical advisory with configured proxy. Nelze konfigurovat proxy server ze softwaru Unisphere.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 Při načítání či aktualizaci technických doporučení pomocí nakonfigurovaného proxy serveru se v prostředí Unisphere zobrazí výstraha. 
 Text výstrahy: Failed to get technical advisory with configured proxy https://xxxxxxxxxxxxxx

Odstraňování problémů:   
  • Curl colu server (server Dell zodpovědný za načítání technických doporučení) bez proxy serveru. Vyprší časový limit serveru, protože komunikace mimo prostředí uživatele bez proxy serveru není povolena.
curl -X POST https://colu.emc.v ; date
Thu Oct 22 09:13:32 UTC 2021
Hostname was NOT found in DNS cache
Trying 168.x.x.x
connect to 168.x.x.x port 443 failed: Connection timed out
Failed to connect to colu.emc.com port 443: Connection timed out
Closing connection 0
curl: (7) Failed to connect to colu.emc.com port 443: Connection timed out
Thu Oct 22 09:15:39 UTC 2020
  • Curl colu server pomocí proxy serveru vrátí "HTTP/1.1 400 Bad Request".
curl -x http://< proxy_server_ip>:<port> -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H " SOAPAction:" -v
                
* Název hostitele NEBYL nalezen v mezipaměti
DNS* Pokus 10.x.x.x
* Připojeno k portu 10.x.x.x (10.x.x.x) x
* Vytvoření tunelu proxy HTTP pro colu.emc.com:443>
PŘIPOJENÍ colu.emc.com:443 HTTP/1.1
> Hostitel: colu.emc.com:443>
User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive HTTP/1.1 200 Připojení navázáno<

* Proxy odpověděl OK na požadavek
CONNECT* úspěšně nastavený umístění ověření certifikátu:*

>
<   CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, Certificate (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
*        subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
*        start date: 2020-08-25 03:21:00 GMT
*        expire date: 2022-08-25 03:21:00 GMT
*        subjectAltName: colu.emc.com matched
*        issuer: C = USA; O = Entrust, Inc.; OU=Viz www.xxx.net/x; OU=(c) 2012 Entrust, Inc. - pouze pro autorizované použití; CN=Svěřit certifikační autoritu – L1K
* Ověření certifikátu SSL je v pořádku.
> POST /soap/rpc HTTP/1.1
> User-Agent: curl/7.37.0>
Hostitel: colu.emc.com
> Přijmout:  */*
Content-Type: text/xml;charset=UTF-8
>
< HTTP/1.1 400 Chybné datum požadavku:
<> Thu, 18 Feb 2021 10:55:45 GMT
* Server Dell není na černé listině
< Server: dell
< Typ obsahu: text/html; charset=utf-8
< X-Content-Type-Options: nosniff
< Různé: Accept-Encoding Připojení: zavřít<
Transfer-Encoding: chunked<<

!
< DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html><
head<>title>400 Bad Request</title<>/head><
body
><h1>Bad Request</h1 h3
<>>Požadavek odeslaný klientem byl syntakticky nesprávný.</h3>
<
/body>
* Closing connection 0
* SSLv3, TLS alert, Client hello (1):         

Cause

Připojení mezi webem colu.emc.com a proxy serverem bylo uzavřeno dřív, než mohlo dojít k úplnému odeslání dat aplikace z webu colu.emc.com do pole Unity. Zdá se, že je to způsobeno tím, jak proces curl zpracovává připojení.     

Resolution

K tomuto problému nedochází v nové verzi. Nová verze upgradovala knihovnu curl na verzi 7.63.0, zatímco starší verze používá verzi 7.50.2.

Tento problém by měl vyřešit upgrade na další verzi.

Dočasná zástupná řešení:    
  • Nepoužívejte proxy server.
  • Zakázání či deaktivace výstrah.
Article Properties
Article Number: 000183648
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.