VPLEX: Después del cambio de contraseña del usuario de vinculación de Active Directory para LDAPS, la reconfiguración falla
Summary: Después del cambio de contraseña del usuario de vinculación de Active Directory para LDAPS en el servidor de Active Directory, la reconfiguración en los clústeres de VPlex falla. El usuario de AD ya no se puede autenticar en VPlex. ...
Symptoms
Hardware afectado:
hardware Dell EMC: VPLEX VS2
Hardware Dell EMC: VPLEX-Local
Hardware Dell EMC: VPLEX-Metro
Software VPLEX GeoSynchrony afectado:
software Dell EMC: GeoSynchrony 5.5.x
Software de Dell EMC: GeoSynchrony 6.0.x
Software de Dell EMC: GeoSynchrony 6.1.x
Software de Dell EMC: GeoSynchrony 6.2.0.03
Software Dell EMC: GeoSynchrony 6.2.0.04
Síntomas:
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El usuario de VPLEX autenticado por el servidor de AD no puede iniciar sesión en VPLEX.
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La configuración de LDAPS de VPLEX se eliminó y no se puede volver a configurar, debido a que el comando "authentication directory-service configure" indicó el error " ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)"
Cause
El usuario mantiene actualizado el servidor de Active Directory y las versiones actuales necesitan las versiones 1.1 o 1.2 de TLS (en este caso, el servidor de Windows 2016). En el servidor de administración de VPLEX o MMCS está SLES 11.4 en uso, esto incluye OpenSSL versión 0.9.8. Esta versión no soporta las versiones 1.1 y 1.2 de TLS.
Ha finalizado el soporte para la versión 0.9.8 de OpenSSL a partir del 1 de enero de 2016 y ya no recibe actualizaciones.
La versión mínima de OpenSSL que soporta TLS 1.1 y 1.2 es la versión 1.0.1.
Resolution
El equipo de desarrollo de ingeniería de VPLEX está trabajando en una solución para el problema. Actualmente, VPLEX utiliza SLES11 SP4 y el plan es actualizar a SLES15 y realizar los cambios, además de la complejidad que implica la modificación del código, por lo que se están realizando muchas pruebas.